aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorMichael Lippautz <michael.lippautz@gmail.com>2010-11-04 14:48:20 +0100
committerMichael Lippautz <michael.lippautz@gmail.com>2010-11-04 15:00:23 +0100
commit89362b3b559a4e49fb282949419ab3c69fcbfaf2 (patch)
treefd3dcad5e4c6eb1c9642f1bd9fc5405520c338b6 /recipes
parenta33cf7368366d425c71369339e88a50d5660b7c0 (diff)
downloadopenembedded-89362b3b559a4e49fb282949419ab3c69fcbfaf2.tar.gz
ddclient: Unbreak recipe
* ddclient expects its default config at /etc/ddclient/ddclient.conf instead of /etc/ddclient.conf Signed-off-by: Michael Lippautz <michael.lippautz@gmail.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/ddclient/ddclient_3.6.3.bb13
1 files changed, 7 insertions, 6 deletions
diff --git a/recipes/ddclient/ddclient_3.6.3.bb b/recipes/ddclient/ddclient_3.6.3.bb
index dcf8993b8a..5e393e7172 100644
--- a/recipes/ddclient/ddclient_3.6.3.bb
+++ b/recipes/ddclient/ddclient_3.6.3.bb
@@ -2,26 +2,27 @@ SECTION = "console/network"
DESCRIPTION = "Ddclient is a Perl client used to update dynamic DNS entries for accounts on Dynamic DNS Network Services"
HOMEPAGE = "http://ddclient.sourceforge.net/"
LICENSE = "GPL"
-PR = "r1"
+PR = "r4"
SRC_URI = "${SOURCEFORGE_MIRROR}/ddclient/ddclient-${PV}.tar.bz2 \
file://ip-up"
-RDEPENDS_${PN} = "perl perl-module-strict perl-module-getopt-long perl-module-vars perl-module-warnings-register perl-module-warnings perl-module-carp perl-module-exporter perl-module-constant perl-module-exporter-heavy perl-module-sys-hostname perl-module-xsloader perl-module-autoloader perl-module-io-socket perl-module-io-handle perl-module-symbol perl-module-selectsaver perl-module-io perl-module-socket perl-module-errno perl-module-config perl-module-io-socket-inet perl-module-io-socket-unix perl-module-integer"
+RDEPENDS_${PN} = "perl perl-module-strict perl-module-getopt-long perl-module-vars perl-module-warnings-register perl-module-warnings perl-module-carp perl-module-exporter perl-module-constant perl-module-exporter-heavy perl-module-sys-hostname perl-module-xsloader perl-module-autoloader perl-module-io-socket perl-module-io-handle perl-module-symbol perl-module-selectsaver perl-module-io perl-module-socket perl-module-errno perl-module-config perl-module-io-socket-inet perl-module-io-socket-unix perl-module-integer perl-module-overload"
do_install() {
- install -d ${D}${sbindir} ${D}${sysconfdir} ${D}${sysconfdir}/init.d
+ install -d ${D}${sbindir} ${D}${sysconfdir}/ddclient ${D}${sysconfdir}/init.d
install -d ${D}${sysconfdir}/ppp/ip-up.d/ install -d ${D}${docdir}/ddclient
install -m 755 ${S}/ddclient ${D}${sbindir}
- install ${S}/sample-etc_ddclient.conf ${D}${sysconfdir}/ddclient.conf
+ install ${S}/sample-etc_ddclient.conf ${D}${sysconfdir}/ddclient/ddclient.conf
install -m 755 ${WORKDIR}/ip-up ${D}${sysconfdir}/ppp/ip-up.d/ddclient
- install -m 755 ${S}/sample-etc_rc.d_init.d_ddclient ${D}${sysconfdir}/init.d/ddclient
+ sed -e 's|/etc/ddclient.conf|/etc/ddclient/ddclient.conf|g' ${S}/sample-etc_rc.d_init.d_ddclient > ${S}/rc_init
+ install -m 755 ${S}/rc_init ${D}${sysconfdir}/init.d/ddclient
install ${S}/README* ${D}${docdir}/ddclient
install ${S}/COPY* ${D}${docdir}/ddclient
install ${S}/sample* ${D}${docdir}/ddclient
}
-CONFFILES_${PN}_nylon = "${sysconfdir}/ddclient.conf"
+CONFFILES_${PN} = "${sysconfdir}/ddclient/ddclient.conf"
SRC_URI[md5sum] = "42a3a420e492c0111adc58ac08ff6d04"
SRC_URI[sha256sum] = "28be7102bde3bc9b39be2732b89da9fbab79b7ac3898075ed414a45258bb3026"