aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorYann Dirson <ydirson@altern.org>2010-08-04 16:37:20 +0000
committerEric Bénard <eric@eukrea.com>2010-11-06 22:16:09 +0100
commitc6551e24443066c7e3c8d40b1766c0f45553fb2a (patch)
tree13c24cb63c684efc294d9ca40c9766abefee2f8a /recipes
parent98a11d033bd20c014e1363e9dcbe83a564fd5152 (diff)
downloadopenembedded-c6551e24443066c7e3c8d40b1766c0f45553fb2a.tar.gz
mped: add new recipe
"Minimum Profit" is a lightweight developer text editor. Forged a desktop file, and stole the icon from leafpad. EB : fixed GNU HASH + mped.png location + mped.desktop Signed-off-by: Yann Dirson <ydirson@altern.org> Signed-off-by: Eric Bénard <eric@eukrea.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/mped/files/mped.desktop9
-rw-r--r--recipes/mped/files/mped.pngbin0 -> 1950 bytes
-rw-r--r--recipes/mped/mped_5.1.3.bb35
3 files changed, 44 insertions, 0 deletions
diff --git a/recipes/mped/files/mped.desktop b/recipes/mped/files/mped.desktop
new file mode 100644
index 0000000000..b6f9cc8039
--- /dev/null
+++ b/recipes/mped/files/mped.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Encoding=UTF-8
+Name=MP editor
+Exec=/usr/bin/mp-5
+Icon=mped
+Terminal=false
+MimeType=text/plain;
+Categories=GTK;Utility;TextEditor;
diff --git a/recipes/mped/files/mped.png b/recipes/mped/files/mped.png
new file mode 100644
index 0000000000..c5ee0cff85
--- /dev/null
+++ b/recipes/mped/files/mped.png
Binary files differ
diff --git a/recipes/mped/mped_5.1.3.bb b/recipes/mped/mped_5.1.3.bb
new file mode 100644
index 0000000000..abeaf399b4
--- /dev/null
+++ b/recipes/mped/mped_5.1.3.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "Lightweight text editor for programmers."
+HOMEPAGE = "http://triptico.com/software/mp.html"
+SECTION = "x11"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+DEPENDS = "gtk+"
+SRC_URI = "http://triptico.com/download/mp-${PV}.tar.gz \
+ file://mped.desktop \
+ file://mped.png "
+
+S = "${WORKDIR}/mp-${PV}"
+PR = "r0"
+
+inherit base
+
+do_configure() {
+ ./config.sh --without-curses --prefix=/usr
+}
+do_install() {
+ mkdir -p ${D}/usr/bin
+ oe_runmake install DESTDIR=${D}
+ mkdir -p ${D}/usr/share/applications ${D}/usr/share/pixmaps
+ install -m644 ../mped.desktop ${D}/usr/share/applications
+ install -m644 ../mped.png ${D}/usr/share/pixmaps
+}
+
+TARGET_CC_ARCH += "${LDFLAGS}"
+
+FILES_${PN} += "/usr/share/mp*/mp_*"
+#FIXME: /usr/share/mp-5/lang
+
+# FIXME: should verify those checksums through other means
+SRC_URI[md5sum] = "6ed30d6be7da70e13111dbc7fca00e70"
+SRC_URI[sha256sum] = "b9c2773408638eeddfa0eef912cc289b0b92df34ce621dc46eca47a2dc518986"