summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-06-02 12:47:00 -0700
committerKhem Raj <raj.khem@gmail.com>2010-06-05 06:52:39 -0700
commit3dd56a5f0c928b34419c9d8830ff8b3df22c0ac9 (patch)
tree3156c87f9e53f01b1589cf354132e59788af49dc /recipes
parent9991720b9967ee803bea600a355410878569c843 (diff)
downloadopenembedded-3dd56a5f0c928b34419c9d8830ff8b3df22c0ac9.tar.gz
coreutils-8.5: Add recipes for version 8.5
Signed-off-by: Khem Raj <raj.khem@gmail.com> Acked-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/coreutils/coreutils-8.5.inc7
-rw-r--r--recipes/coreutils/coreutils-8.5/onceonly.m463
-rw-r--r--recipes/coreutils/coreutils-native_8.5.bb4
-rw-r--r--recipes/coreutils/coreutils_8.5.bb4
4 files changed, 78 insertions, 0 deletions
diff --git a/recipes/coreutils/coreutils-8.5.inc b/recipes/coreutils/coreutils-8.5.inc
new file mode 100644
index 0000000000..da577453ad
--- /dev/null
+++ b/recipes/coreutils/coreutils-8.5.inc
@@ -0,0 +1,7 @@
+require coreutils.inc
+
+SRC_URI = "ftp://ftp.gnu.org/gnu/coreutils/coreutils-${PV}.tar.gz \
+ "
+SRC_URI[md5sum] = "c1ffe586d001e87d66cd80c4536ee823"
+SRC_URI[sha256sum] = "dd243e2ac7d0ed203b170ecfb8299643779e7501fec2b45ae1cea8a450fa8ca0"
+
diff --git a/recipes/coreutils/coreutils-8.5/onceonly.m4 b/recipes/coreutils/coreutils-8.5/onceonly.m4
new file mode 100644
index 0000000000..f6fec37cbf
--- /dev/null
+++ b/recipes/coreutils/coreutils-8.5/onceonly.m4
@@ -0,0 +1,63 @@
+# onceonly.m4 serial 3
+dnl Copyright (C) 2002, 2003 Free Software Foundation, Inc.
+dnl This file is free software, distributed under the terms of the GNU
+dnl General Public License. As a special exception to the GNU General
+dnl Public License, this file may be distributed as part of a program
+dnl that contains a configuration script generated by Autoconf, under
+dnl the same distribution terms as the rest of that program.
+
+dnl This file defines some "once only" variants of standard autoconf macros.
+dnl AC_CHECK_HEADERS_ONCE like AC_CHECK_HEADERS
+dnl AC_CHECK_FUNCS_ONCE like AC_CHECK_FUNCS
+dnl AC_CHECK_DECLS_ONCE like AC_CHECK_DECLS
+dnl AC_REQUIRE([AC_HEADER_STDC]) like AC_HEADER_STDC
+dnl The advantage is that the check for each of the headers/functions/decls
+dnl will be put only once into the 'configure' file. It keeps the size of
+dnl the 'configure' file down, and avoids redundant output when 'configure'
+dnl is run.
+dnl The drawback is that the checks cannot be conditionalized. If you write
+dnl if some_condition; then gl_CHECK_HEADERS(stdlib.h); fi
+dnl inside an AC_DEFUNed function, the gl_CHECK_HEADERS macro call expands to
+dnl empty, and the check will be inserted before the body of the AC_DEFUNed
+dnl function.
+
+dnl Autoconf version 2.57 or newer is recommended.
+AC_PREREQ(2.54)
+
+# AC_CHECK_HEADERS_ONCE(HEADER1 HEADER2 ...) is a once-only variant of
+# AC_CHECK_HEADERS(HEADER1 HEADER2 ...).
+AC_DEFUN([AC_CHECK_HEADERS_ONCE], [
+ :
+ AC_FOREACH([gl_HEADER_NAME], [$1], [
+ AC_DEFUN([gl_CHECK_HEADER_]m4_quote(translit(defn([gl_HEADER_NAME]),
+ [-./], [___])), [
+ AC_CHECK_HEADERS(gl_HEADER_NAME)
+ ])
+ AC_REQUIRE([gl_CHECK_HEADER_]m4_quote(translit(gl_HEADER_NAME,
+ [-./], [___])))
+ ])
+])
+
+# AC_CHECK_FUNCS_ONCE(FUNC1 FUNC2 ...) is a once-only variant of
+# AC_CHECK_FUNCS(FUNC1 FUNC2 ...).
+AC_DEFUN([AC_CHECK_FUNCS_ONCE], [
+ :
+ AC_FOREACH([gl_FUNC_NAME], [$1], [
+ AC_DEFUN([gl_CHECK_FUNC_]defn([gl_FUNC_NAME]), [
+ AC_CHECK_FUNCS(defn([gl_FUNC_NAME]))
+ ])
+ AC_REQUIRE([gl_CHECK_FUNC_]defn([gl_FUNC_NAME]))
+ ])
+])
+
+# AC_CHECK_DECLS_ONCE(DECL1 DECL2 ...) is a once-only variant of
+# AC_CHECK_DECLS(DECL1, DECL2, ...).
+AC_DEFUN([AC_CHECK_DECLS_ONCE], [
+ :
+ AC_FOREACH([gl_DECL_NAME], [$1], [
+ AC_DEFUN([gl_CHECK_DECL_]defn([gl_DECL_NAME]), [
+ AC_CHECK_DECLS(defn([gl_DECL_NAME]))
+ ])
+ AC_REQUIRE([gl_CHECK_DECL_]defn([gl_DECL_NAME]))
+ ])
+])
diff --git a/recipes/coreutils/coreutils-native_8.5.bb b/recipes/coreutils/coreutils-native_8.5.bb
new file mode 100644
index 0000000000..fbf416eab2
--- /dev/null
+++ b/recipes/coreutils/coreutils-native_8.5.bb
@@ -0,0 +1,4 @@
+require coreutils-${PV}.inc
+require coreutils-native.inc
+
+PR = "r0"
diff --git a/recipes/coreutils/coreutils_8.5.bb b/recipes/coreutils/coreutils_8.5.bb
new file mode 100644
index 0000000000..b4025c2bd7
--- /dev/null
+++ b/recipes/coreutils/coreutils_8.5.bb
@@ -0,0 +1,4 @@
+require coreutils-${PV}.inc
+require coreutils-target.inc
+
+PR = "r0"