summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorGraham Gower <graham.gower@gmail.com>2010-08-09 21:13:17 +0000
committerKhem Raj <raj.khem@gmail.com>2010-09-01 19:01:01 -0700
commit47f52315e12511e589c171a9d377077923983be5 (patch)
treed3d5f86880e95f8d7b1c52d414664e3126a47bf7 /recipes
parentc5e0035ea336623608a73a13246f910b574a2204 (diff)
downloadopenembedded-47f52315e12511e589c171a9d377077923983be5.tar.gz
task-boot.bb: Don't pull in u-a if ONLINE_PACKAGE_MANAGEMENT="none".
This makes it possible to build an opkgless system, without having to set DISTRO_UPDATE_ALTERNATIVES. In the unlikely event that someone doesn't want opkg, but does want update-alternatives, one can set DISTRO_UPDATE_ALTERNATIVES in the local.conf. Signed-off-by: Graham Gower <graham.gower@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/tasks/task-boot.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes/tasks/task-boot.bb b/recipes/tasks/task-boot.bb
index 45d50ef672..d193393875 100644
--- a/recipes/tasks/task-boot.bb
+++ b/recipes/tasks/task-boot.bb
@@ -17,7 +17,7 @@ MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS ?= ""
# u-a script used for building image which is defined with
# PREFERRED_PROVIDER_virtual/update-alternatives-native
-DISTRO_UPDATE_ALTERNATIVES ?= "${PREFERRED_PROVIDER_virtual/update-alternatives}"
+DISTRO_UPDATE_ALTERNATIVES ?= "${@base_conditional("ONLINE_PACKAGE_MANAGEMENT", "none", "", "${PREFERRED_PROVIDER_virtual/update-alternatives}", d)}"
# Make sure we build the kernel
DEPENDS = "virtual/kernel"