summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorTom Rini <trini@embeddedalley.com>2009-06-19 19:56:18 -0400
committerTom Rini <trini@embeddedalley.com>2009-06-19 19:56:18 -0400
commit598ee434efdc895bfdbc004b8e51b5d5707bc6b6 (patch)
treeb77a3b4938fecd19a760145305fb39d51140974d /recipes
parent793b86cc83d0822d50e65422fd00ce9479129fbe (diff)
downloadopenembedded-598ee434efdc895bfdbc004b8e51b5d5707bc6b6.tar.gz
gcc-package-sdk.inc: ${layout_base_bindir} is not the path to where the real binary is.
The binary will always be two levels back, and it will always be in ${bindir} as that's what we pass to configure, so basename that to find the right directory name. Bump INC_PR in gcc-canadian-sdk 4.2.4, gcc-cross-sdk 4.2.4/4.3.3/4.4.0
Diffstat (limited to 'recipes')
-rw-r--r--recipes/gcc/gcc-canadian-sdk_4.2.4.bb2
-rw-r--r--recipes/gcc/gcc-cross-sdk_4.2.4.bb2
-rw-r--r--recipes/gcc/gcc-cross-sdk_4.3.3.bb2
-rw-r--r--recipes/gcc/gcc-package-sdk.inc5
4 files changed, 5 insertions, 6 deletions
diff --git a/recipes/gcc/gcc-canadian-sdk_4.2.4.bb b/recipes/gcc/gcc-canadian-sdk_4.2.4.bb
index 409970be5f..dadb5b04f6 100644
--- a/recipes/gcc/gcc-canadian-sdk_4.2.4.bb
+++ b/recipes/gcc/gcc-canadian-sdk_4.2.4.bb
@@ -1,6 +1,6 @@
inherit canadian-sdk
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gcc-${PV}"
diff --git a/recipes/gcc/gcc-cross-sdk_4.2.4.bb b/recipes/gcc/gcc-cross-sdk_4.2.4.bb
index c5a0a1aa88..ab52a9ae04 100644
--- a/recipes/gcc/gcc-cross-sdk_4.2.4.bb
+++ b/recipes/gcc/gcc-cross-sdk_4.2.4.bb
@@ -1,4 +1,4 @@
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
inherit sdk
diff --git a/recipes/gcc/gcc-cross-sdk_4.3.3.bb b/recipes/gcc/gcc-cross-sdk_4.3.3.bb
index 27a7ae0a7f..6be2538cd5 100644
--- a/recipes/gcc/gcc-cross-sdk_4.3.3.bb
+++ b/recipes/gcc/gcc-cross-sdk_4.3.3.bb
@@ -1,4 +1,4 @@
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
inherit sdk
diff --git a/recipes/gcc/gcc-package-sdk.inc b/recipes/gcc/gcc-package-sdk.inc
index 3d9cc0c53a..dcf2c890e4 100644
--- a/recipes/gcc/gcc-package-sdk.inc
+++ b/recipes/gcc/gcc-package-sdk.inc
@@ -48,10 +48,9 @@ do_install () {
# Create the ${prefix}/${TARGET_SYS}/bin/* symlinks
install -d ${D}${prefix}/${TARGET_SYS}/bin/
for l in ${D}${bindir}/*; do
- echo $l
- ln -sf "../../${layout_base_bindir}/`basename $l`" "${D}${prefix}/${TARGET_SYS}/bin/`basename $l | sed -e 's,${TARGET_PREFIX},,'`"
+ ln -sf "../../`basename ${bindir}`/`basename $l`" "${D}${prefix}/${TARGET_SYS}/bin/`basename $l | sed -e 's,${TARGET_PREFIX},,'`"
done
- ln -sf "${bindir}/${TARGET_PREFIX}gcc${EXEEXT}" "${D}${prefix}/${TARGET_SYS}/bin/cc${EXEEXT}"
+ ln -sf "../../`basename ${bindir}`/${TARGET_PREFIX}gcc${EXEEXT}" "${D}${prefix}/${TARGET_SYS}/bin/cc${EXEEXT}"
# Manually run the target stripper since we won't get it run by
# the packaging.