summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2010-06-07 08:54:13 -0700
committerTom Rini <tom_rini@mentor.com>2010-06-07 08:54:13 -0700
commit5e813f8a9e1b607233f3794b2c981ce1d8c84fac (patch)
tree60fcbff3000c59d8ac7f9f28314ae6054c1e273b /recipes
parent87ec7b6c9a418455f3d05139a0832c73eba292c7 (diff)
downloadopenembedded-5e813f8a9e1b607233f3794b2c981ce1d8c84fac.tar.gz
rootfs_ipk/meta-toolchain: Add locking on tasks that add package_update_index_ipk
We add a lockfile of do_populate_sdk and do_rootfs (in rootfs_ipk) that is also the lockfile that package_update_index_ipk uses. With enough threads it is possible that one image (or meta-toolchain) is attempting to use the package index while another has only reached the point of generating the index leading to an empty index being seen later on. Acked-by: Chris Larson <chris_larson@mentor.com> Acked-by: Roman I Khimov <khimov@altell.ru> Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/meta/canadian-sdk.bb1
-rw-r--r--recipes/meta/meta-toolchain.bb1
2 files changed, 2 insertions, 0 deletions
diff --git a/recipes/meta/canadian-sdk.bb b/recipes/meta/canadian-sdk.bb
index 47529a2d96..216044156d 100644
--- a/recipes/meta/canadian-sdk.bb
+++ b/recipes/meta/canadian-sdk.bb
@@ -169,5 +169,6 @@ do_populate_sdk() {
}
do_populate_sdk[nostamp] = "1"
+do_populate_sdk[lockfiles] = "${DEPLOY_DIR_IPK}.lock"
addtask package_update_index_ipk before do_populate_sdk
addtask populate_sdk before do_build after do_install
diff --git a/recipes/meta/meta-toolchain.bb b/recipes/meta/meta-toolchain.bb
index 064fc3b193..82918addec 100644
--- a/recipes/meta/meta-toolchain.bb
+++ b/recipes/meta/meta-toolchain.bb
@@ -177,5 +177,6 @@ do_populate_sdk() {
}
do_populate_sdk[nostamp] = "1"
+do_populate_sdk[lockfiles] = "${DEPLOY_DIR_IPK}.lock"
addtask package_update_index_ipk before do_populate_sdk
addtask populate_sdk before do_build after do_install