summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2010-06-18 18:51:04 +0400
committerDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2010-06-20 19:23:46 +0400
commit65e509aeddd26a6829ee10aa21fa20d6fd3def3e (patch)
tree472ccde0b7a45989d2769f771b879c38f9deb4d5 /recipes
parent69d4f160583e764448f359d2aced62345be3e387 (diff)
downloadopenembedded-65e509aeddd26a6829ee10aa21fa20d6fd3def3e.tar.gz
gcc-4.3/4.4: correct flags passed to native parts of the build
Target CFLAGS (LIBCFLAGS in fact) are leaking into native parts of the build. Fix that (thus making gcc buildable for ppc, e.g.). Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/gcc/files/gcc-4.3.3-fix-EXTRA_BUILD.patch12
-rw-r--r--recipes/gcc/gcc-4.3.1.inc1
-rw-r--r--recipes/gcc/gcc-4.3.2.inc1
-rw-r--r--recipes/gcc/gcc-4.3.3.inc3
-rw-r--r--recipes/gcc/gcc-4.3.4.inc1
-rw-r--r--recipes/gcc/gcc-4.4.1.inc1
-rw-r--r--recipes/gcc/gcc-4.4.2.inc1
-rw-r--r--recipes/gcc/gcc-4.4.4.inc1
8 files changed, 20 insertions, 1 deletions
diff --git a/recipes/gcc/files/gcc-4.3.3-fix-EXTRA_BUILD.patch b/recipes/gcc/files/gcc-4.3.3-fix-EXTRA_BUILD.patch
new file mode 100644
index 0000000000..8a2a4c4040
--- /dev/null
+++ b/recipes/gcc/files/gcc-4.3.3-fix-EXTRA_BUILD.patch
@@ -0,0 +1,12 @@
+Index: gcc-4.3.3/Makefile.in
+===================================================================
+--- gcc-4.3.3.orig/Makefile.in 2010-06-16 18:04:38.379008150 +0400
++++ gcc-4.3.3/Makefile.in 2010-06-16 18:05:29.115006261 +0400
+@@ -148,6 +148,7 @@
+ # built for the build system to override those in BASE_FLAGS_TO_PASSS.
+ EXTRA_BUILD_FLAGS = \
+ CFLAGS="$(CFLAGS_FOR_BUILD)" \
++ LIBCFLAGS="$(CFLAGS_FOR_BUILD)" \
+ LDFLAGS="$(LDFLAGS_FOR_BUILD)"
+
+ # This is the list of directories to built for the host system.
diff --git a/recipes/gcc/gcc-4.3.1.inc b/recipes/gcc/gcc-4.3.1.inc
index 3352868986..04c0246785 100644
--- a/recipes/gcc/gcc-4.3.1.inc
+++ b/recipes/gcc/gcc-4.3.1.inc
@@ -61,6 +61,7 @@ SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2;name=archive \
file://gcc-4.3.1-SYSROOT_CFLAGS_FOR_TARGET.patch \
file://gcc-4.3.1-ARCH_FLAGS_FOR_TARGET.patch \
file://zecke-xgcc-cpp.patch \
+ file://gcc-4.3.3-fix-EXTRA_BUILD.patch \
file://gcc-flags-for-build.patch \
"
diff --git a/recipes/gcc/gcc-4.3.2.inc b/recipes/gcc/gcc-4.3.2.inc
index 897d4f3964..a3ef606d6c 100644
--- a/recipes/gcc/gcc-4.3.2.inc
+++ b/recipes/gcc/gcc-4.3.2.inc
@@ -57,6 +57,7 @@ SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2;name=archive \
file://gcc-4.3.2-SYSROOT_CFLAGS_FOR_TARGET.patch \
file://gcc-4.3.1-ARCH_FLAGS_FOR_TARGET.patch \
file://zecke-xgcc-cpp.patch \
+ file://gcc-4.3.3-fix-EXTRA_BUILD.patch \
file://gcc-flags-for-build.patch \
"
diff --git a/recipes/gcc/gcc-4.3.3.inc b/recipes/gcc/gcc-4.3.3.inc
index 77cd521839..e39b1192ca 100644
--- a/recipes/gcc/gcc-4.3.3.inc
+++ b/recipes/gcc/gcc-4.3.3.inc
@@ -8,7 +8,7 @@ LICENSE = "GPLv3"
DEPENDS = "mpfr gmp"
NATIVEDEPS = "mpfr-native gmp-native"
-INC_PR = "r12"
+INC_PR = "r13"
SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2;name=archive \
file://fedora/gcc43-c++-builtin-redecl.patch;striplevel=0 \
@@ -59,6 +59,7 @@ SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2;name=archive \
file://gcc-flags-for-build.patch \
file://gcc-pr36218.patch \
file://gcc-4.3.3-SYSROOT_CFLAGS_FOR_TARGET.patch \
+ file://gcc-4.3.3-fix-EXTRA_BUILD.patch \
file://arm-gcc-objective.patch \
"
diff --git a/recipes/gcc/gcc-4.3.4.inc b/recipes/gcc/gcc-4.3.4.inc
index 9711813085..b9531d5e36 100644
--- a/recipes/gcc/gcc-4.3.4.inc
+++ b/recipes/gcc/gcc-4.3.4.inc
@@ -57,6 +57,7 @@ SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2;name=archive \
file://gcc-4.3.4-SYSROOT_CFLAGS_FOR_TARGET.patch \
file://gcc-4.3.1-ARCH_FLAGS_FOR_TARGET.patch \
file://zecke-xgcc-cpp.patch \
+ file://gcc-4.3.3-fix-EXTRA_BUILD.patch \
file://gcc-flags-for-build.patch \
"
diff --git a/recipes/gcc/gcc-4.4.1.inc b/recipes/gcc/gcc-4.4.1.inc
index 11b1535428..c4138b84b5 100644
--- a/recipes/gcc/gcc-4.4.1.inc
+++ b/recipes/gcc/gcc-4.4.1.inc
@@ -25,6 +25,7 @@ SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2;name=archive \
file://gcc-ppc_add_d_constraint.patch \
file://gcc-pr41175.patch \
file://gcc-armv4-pass-fix-v4bx-to-ld.patch \
+ file://gcc-4.3.3-fix-EXTRA_BUILD.patch \
"
# Language Overrides
FORTRAN = ""
diff --git a/recipes/gcc/gcc-4.4.2.inc b/recipes/gcc/gcc-4.4.2.inc
index 8d14c99677..0ad3fe51c9 100644
--- a/recipes/gcc/gcc-4.4.2.inc
+++ b/recipes/gcc/gcc-4.4.2.inc
@@ -25,6 +25,7 @@ SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2;name=archive \
file://gcc-ppc_add_d_constraint.patch \
file://gcc-pr41175.patch \
file://gcc-armv4-pass-fix-v4bx-to-ld.patch \
+ file://gcc-4.3.3-fix-EXTRA_BUILD.patch \
"
# Language Overrides
FORTRAN = ""
diff --git a/recipes/gcc/gcc-4.4.4.inc b/recipes/gcc/gcc-4.4.4.inc
index 4dd1bf6d70..37c8cd0001 100644
--- a/recipes/gcc/gcc-4.4.4.inc
+++ b/recipes/gcc/gcc-4.4.4.inc
@@ -26,6 +26,7 @@ SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2;name=gcc444tarbz2 \
file://gcc-pr41175.patch \
file://gcc-armv4-pass-fix-v4bx-to-ld.patch \
file://gcc-add-t-slibgcc-libgcc.patch \
+ file://gcc-4.3.3-fix-EXTRA_BUILD.patch \
"
SRC_URI[gcc444tarbz2.md5sum] = "7ff5ce9e5f0b088ab48720bbd7203530"
SRC_URI[gcc444tarbz2.sha256sum] = "e1c13696b45752ad3f652304fab5120a43a8a5c0f438d3bda78cf16b620c0c58"