summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2010-09-08 09:25:21 -0700
committerTom Rini <tom_rini@mentor.com>2010-09-13 09:00:41 -0700
commit6ed4b0e2b64aecb5155dd6b880407a94f28e0e82 (patch)
treef4bb398ad019c75e5affe0d642febc9cf61c09f2 /recipes
parentbfd4f01d2f34fe7c160640ac913b8f6d47f3e9bd (diff)
downloadopenembedded-6ed4b0e2b64aecb5155dd6b880407a94f28e0e82.tar.gz
ffmpeg: Pass along all of CCLDs flags, fix !Altivec PowerPC
What's passed for --enable-ldflags is for ffmpeg using cc-as-ld but not just using CCLD, so pass in TOOLCHAIN_OPTIONS. For PowerPC, only pass --enable-altivec on ppce600 (only case of it we support) otherwise disable as ffmpeg defaults to enabled. Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/ffmpeg/ffmpeg.inc2
-rw-r--r--recipes/ffmpeg/ffmpeg_0.5.bb2
2 files changed, 3 insertions, 1 deletions
diff --git a/recipes/ffmpeg/ffmpeg.inc b/recipes/ffmpeg/ffmpeg.inc
index be67e61250..4352339119 100644
--- a/recipes/ffmpeg/ffmpeg.inc
+++ b/recipes/ffmpeg/ffmpeg.inc
@@ -32,6 +32,8 @@ EXTRA_OECONF = "\
\
"
+EXTRA_OECONF_append_powerpc += "--${@['disable-altivec','enable-altivec'][bb.data.getVar('BASE_PACKAGE_ARCH',d,1) in ['ppce600']]}"
+
FFMPEG_LIBS = "libavcodec libavdevice libavformat \
libavutil libpostproc libswscale libavfilter"
diff --git a/recipes/ffmpeg/ffmpeg_0.5.bb b/recipes/ffmpeg/ffmpeg_0.5.bb
index 0c82100318..07af21d04c 100644
--- a/recipes/ffmpeg/ffmpeg_0.5.bb
+++ b/recipes/ffmpeg/ffmpeg_0.5.bb
@@ -46,7 +46,7 @@ EXTRA_OECONF = " \
--arch=${TARGET_ARCH} \
--enable-cross-compile \
--extra-cflags="${TARGET_CFLAGS} ${HOST_CC_ARCH}${TOOLCHAIN_OPTIONS}" \
- --extra-ldflags="${TARGET_LDFLAGS}" \
+ --extra-ldflags="${TARGET_LDFLAGS} ${HOST_CC_ARCH}${TOOLCHAIN_OPTIONS}" \
--enable-hardcoded-tables \
${EXTRA_FFCONF} \
"