summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorMike Rapoport <mike@compulab.co.il>2009-12-01 22:23:14 +0000
committerKoen Kooi <koen@openembedded.org>2009-12-02 15:11:05 +0100
commit83bd1ed815a4e716ce5bc00f4dbbaeae1b5fd8e6 (patch)
treeea84b9153a4a03e4ad3314d3bbd93570a9987257 /recipes
parent195b77e4f4501a1ab6273bfec02d1d577c474871 (diff)
downloadopenembedded-83bd1ed815a4e716ce5bc00f4dbbaeae1b5fd8e6.tar.gz
omap3-sgx-modules: fix build for recent kernels
Starting from v2.6.32-rc6 of linux-omap tree the arch/arm/plat-omap/include/mach has been moved to arch/arm/plat-omap/include/plat Take care of that change Signed-off-by: Mike Rapoport <mike@compulab.co.il>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/powervr-drivers/omap3-sgx-modules/0001-Compile-fixes-for-recent-kernels.patch28
-rw-r--r--recipes/powervr-drivers/omap3-sgx-modules_1.3.13.1607.bb1
2 files changed, 29 insertions, 0 deletions
diff --git a/recipes/powervr-drivers/omap3-sgx-modules/0001-Compile-fixes-for-recent-kernels.patch b/recipes/powervr-drivers/omap3-sgx-modules/0001-Compile-fixes-for-recent-kernels.patch
new file mode 100644
index 0000000000..53b1f2772e
--- /dev/null
+++ b/recipes/powervr-drivers/omap3-sgx-modules/0001-Compile-fixes-for-recent-kernels.patch
@@ -0,0 +1,28 @@
+From ef693358e658a7cbab4d2696108d9d4240ab8096 Mon Sep 17 00:00:00 2001
+From: Mike Rapoport <mike@compulab.co.il>
+Date: Wed, 2 Dec 2009 10:13:15 +0200
+Subject: [PATCH] Compile fixes for recent kernels
+
+---
+ .../3rdparty/dc_omap3430_linux/omaplfb_linux.c | 4 ++++
+ 1 files changed, 4 insertions(+), 0 deletions(-)
+
+diff --git a/services4/3rdparty/dc_omap3430_linux/omaplfb_linux.c b/services4/3rdparty/dc_omap3430_linux/omaplfb_linux.c
+index 935f78b..4d41829 100755
+--- a/services4/3rdparty/dc_omap3430_linux/omaplfb_linux.c
++++ b/services4/3rdparty/dc_omap3430_linux/omaplfb_linux.c
+@@ -57,7 +57,11 @@ extern int omap_dispc_request_irq(unsigned long, void (*)(void *), void *);
+ extern void omap_dispc_free_irq(unsigned long, void (*)(void *), void *);
+ extern void omap_dispc_set_plane_base(int plane, IMG_UINT32 phys_addr);
+ #else
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,32)
++#include <plat/display.h>
++#else
+ #include <mach/display.h>
++#endif
+ #include <linux/console.h>
+ #include <linux/fb.h>
+ #endif
+--
+1.6.4.4
+
diff --git a/recipes/powervr-drivers/omap3-sgx-modules_1.3.13.1607.bb b/recipes/powervr-drivers/omap3-sgx-modules_1.3.13.1607.bb
index 9bd77ad9af..603c81f9a4 100644
--- a/recipes/powervr-drivers/omap3-sgx-modules_1.3.13.1607.bb
+++ b/recipes/powervr-drivers/omap3-sgx-modules_1.3.13.1607.bb
@@ -8,6 +8,7 @@ SRC_URI = "file://omap3-sgx-modules-${PV}.tar.bz2 \
file://rotation-dss2.patch;patch=1 \
file://build_es3.x_sgx.patch;patch=1 \
file://proc-interface.patch;patch=1 \
+ file://0001-Compile-fixes-for-recent-kernels.patch;patch=1 \
"
PVRBUILD = "release"