summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-07-31 20:11:10 +0200
committerKoen Kooi <koen@openembedded.org>2009-07-31 20:11:10 +0200
commit8e6e8ded5a421d044fd5f97f290ae538255ff529 (patch)
tree91b55b12a47e1001ebd24d30c50eb30933bfdbb5 /recipes
parentc1cf6902c04f40bf79b796815436877205387e05 (diff)
parent758a9ce142a669fce2b6eee0c4730716916f3038 (diff)
downloadopenembedded-8e6e8ded5a421d044fd5f97f290ae538255ff529.tar.gz
Merge branch 'org.openembedded.dev' of git@git.openembedded.org:openembedded into org.openembedded.dev
Diffstat (limited to 'recipes')
-rw-r--r--recipes/efl1/emotion_svn.bb4
-rw-r--r--recipes/libdbi/libdbi-drivers.inc47
-rw-r--r--recipes/libdbi/libdbi-drivers_0.7.1.bb40
-rw-r--r--recipes/libdbi/libdbi-drivers_0.8.3-1.bb2
-rw-r--r--recipes/libdbi/libdbi_0.8.3.bb (renamed from recipes/libdbi/libdbi_0.8.2.bb)0
-rw-r--r--recipes/qt4/qt4-embedded-gles_4.5.2.bb.disabled2
-rw-r--r--recipes/qt4/qt4-embedded_4.5.2.bb2
-rw-r--r--recipes/qt4/qt4-tools-native_4.5.2.bb1
-rw-r--r--recipes/qt4/qt4-tools-sdk_4.5.2.bb2
-rw-r--r--recipes/qt4/qt4-x11-free-gles_git.bb.disabled2
-rw-r--r--recipes/qt4/qt4-x11-free_4.5.2.bb2
-rw-r--r--recipes/tinylogin/tinylogin_1.4.bb3
-rw-r--r--recipes/unzip/unzip_552.bb3
13 files changed, 61 insertions, 49 deletions
diff --git a/recipes/efl1/emotion_svn.bb b/recipes/efl1/emotion_svn.bb
index 455bc82b18..0f31e667cc 100644
--- a/recipes/efl1/emotion_svn.bb
+++ b/recipes/efl1/emotion_svn.bb
@@ -3,11 +3,11 @@ LICENSE = "MIT BSD"
# we no longer build the libxine backend, since the gstreamer backend seems more promising
DEPENDS = "eet evas ecore edje gstreamer gst-plugins-base"
PV = "0.1.0.042+svnr${SRCREV}"
-PR = "r1"
+PR = "r2"
inherit efl
-EXTRA_OECONF = "--disable-xine --enable-gstreamer"
+EXTRA_OECONF = "--disable-xine --enable-gstreamer --with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc"
PACKAGES =+ "emotion-backend-gstreamer"
FILES_emotion-backend-gstreamer = "${libdir}/emotion/*.so"
diff --git a/recipes/libdbi/libdbi-drivers.inc b/recipes/libdbi/libdbi-drivers.inc
new file mode 100644
index 0000000000..b5875eb893
--- /dev/null
+++ b/recipes/libdbi/libdbi-drivers.inc
@@ -0,0 +1,47 @@
+# libdbi-drivers OE build file
+# Copyright (C) 2005, Koninklijke Philips Electronics NV. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION = "Database Drivers for libdbi"
+HOMEPAGE = "http://libdbi-drivers.sourceforge.net/"
+LICENSE = "LGPL"
+SECTION = "libs"
+
+PROVIDES = "libdbd-sqlite"
+DEPENDS = "libdbi sqlite sqlite3 mysql postgresql"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/libdbi-drivers/libdbi-drivers-${PV}.tar.gz"
+
+inherit autotools
+
+PACKAGES += "libdbd-sqlite3 libdbd-sqlite libdbd-pgsql libdbd-mysql"
+
+EXTRA_OECONF = "--with-dbi-incdir=${STAGING_INCDIR} \
+ --with-sqlite \
+ --with-sqlite3 \
+ --with-pgsql \
+ --with-mysql \
+ --with-sqlite-libdir=${STAGING_LIBDIR} \
+ --with-sqlite-incdir=${STAGING_INCDIR} \
+ --with-sqlite3-incdir=${STAGING_INCDIR} \
+ --with-sqlite3-libdir=${STAGING_LIBDIR} \
+ --with-mysql-incdir=${STAGING_INCDIR} \
+ --with-mysql-libdir=${STAGING_LIBDIR} \
+ --with-pgsql-incdir=${STAGING_INCDIR} \
+ --with-pgsql-libdir=${STAGING_LIBDIR}"
+
+FILES_${PN}-dbg += " ${libdir}/dbd/.debug/*.so"
+FILES_${PN}-dev += " ${libdir}/dbd/*.la ${libdir}/dbd/*.a"
+
+DESCRIPTION_libdbd-sqlite = "SQLite database driver for libdbi"
+FILES_libdbd-sqlite = "${libdir}/dbd/libdbdsqlite.so"
+
+DESCRIPTION_libdbd-sqlite3 = "SQLite3 database driver for libdbi"
+FILES_libdbd-sqlite3 = "${libdir}/dbd/libdbdsqlite3.so"
+
+DESCRIPTION_libdbd-mysql = "MySQL4 database driver for libdbi"
+FILES_libdbd-mysql = "${libdir}/dbd/libdbdmysql.so"
+
+DESCRIPTION_libdbd-psql = "Postgres SQL database driver for libdbi"
+FILES_libdbd-pgsql = "${libdir}/dbd/libdbdpgsql.so"
+
diff --git a/recipes/libdbi/libdbi-drivers_0.7.1.bb b/recipes/libdbi/libdbi-drivers_0.7.1.bb
deleted file mode 100644
index eea45ca4bb..0000000000
--- a/recipes/libdbi/libdbi-drivers_0.7.1.bb
+++ /dev/null
@@ -1,40 +0,0 @@
-# libdbi-drivers OE build file
-# Copyright (C) 2005, Koninklijke Philips Electronics NV. All Rights Reserved
-# Released under the MIT license (see packages/COPYING)
-
-DESCRIPTION = "Database Drivers for libdbi"
-HOMEPAGE = "http://libdbi-drivers.sourceforge.net/"
-LICENSE = "GPLv2"
-SECTION = "libs"
-
-PROVIDES = "libdbd-sqlite"
-DEPENDS = "libdbi sqlite"
-
-SRC_URI = "${SOURCEFORGE_MIRROR}/libdbi-drivers/libdbi-drivers-${PV}.tar.gz"
-
-inherit autotools
-
-PACKAGES = "${PN}-dbg libdbd-sqlite ${PN}"
-
-EXTRA_OECONF = "--with-dbi-incdir=${STAGING_INCDIR} \
- --with-sqlite \
- --with-sqlite-libdir=${STAGING_LIBDIR} \
- --with-sqlite-incdir=${STAGING_INCDIR}"
-
-FILES_libdbd-sqlite = "/usr/lib/dbd/libsqlite.so \
- /usr/lib/dbd/libsqlite.la \
- /usr/lib/dbd/libsqlite.a"
-
-DESCRIPTION_libdbd-sqlite = "SQLite database driver for libdbi"
-
-do_configure_old () {
- ./configure \
- --build=${BUILD_SYS} \
- --host=${HOST_SYS} \
- --target=${TARGET_SYS} \
- --prefix=${prefix} \
- --with-sqlite \
- --with-sqlite-libdir=${STAGING_LIBDIR} \
- --with-sqlite-incdir=${STAGING_INCDIR}
-}
-
diff --git a/recipes/libdbi/libdbi-drivers_0.8.3-1.bb b/recipes/libdbi/libdbi-drivers_0.8.3-1.bb
new file mode 100644
index 0000000000..efbc61f5c0
--- /dev/null
+++ b/recipes/libdbi/libdbi-drivers_0.8.3-1.bb
@@ -0,0 +1,2 @@
+require ${PN}.inc
+LICENSE = "LGPL"
diff --git a/recipes/libdbi/libdbi_0.8.2.bb b/recipes/libdbi/libdbi_0.8.3.bb
index bd54419686..bd54419686 100644
--- a/recipes/libdbi/libdbi_0.8.2.bb
+++ b/recipes/libdbi/libdbi_0.8.3.bb
diff --git a/recipes/qt4/qt4-embedded-gles_4.5.2.bb.disabled b/recipes/qt4/qt4-embedded-gles_4.5.2.bb.disabled
index 31bfe0fee2..5aa07c2ebb 100644
--- a/recipes/qt4/qt4-embedded-gles_4.5.2.bb.disabled
+++ b/recipes/qt4/qt4-embedded-gles_4.5.2.bb.disabled
@@ -6,6 +6,8 @@ QT_CONFIG_FLAGS += "-D QT_QWS_CLIENTBLIT -depths 16,24,32 -opengl es1 -plugin-gf
require qt4-embedded_${PV}.bb
+LICENSE = "LGPLv2.1 GPLv3"
+
DEPENDS += "virtual/egl"
SRC_URI += "file://sgx-hack.patch;patch=1"
diff --git a/recipes/qt4/qt4-embedded_4.5.2.bb b/recipes/qt4/qt4-embedded_4.5.2.bb
index dff754c68c..bbe119c89f 100644
--- a/recipes/qt4/qt4-embedded_4.5.2.bb
+++ b/recipes/qt4/qt4-embedded_4.5.2.bb
@@ -2,5 +2,5 @@ include qt4-embedded.inc
PR = "${INC_PR}.1"
-LICENSE += "LGPL"
+LICENSE = "LGPLv2.1 GPLv3"
SRC_URI += "file://0010-no-simpledecoration-example.patch;patch=1"
diff --git a/recipes/qt4/qt4-tools-native_4.5.2.bb b/recipes/qt4/qt4-tools-native_4.5.2.bb
index d1962bf98f..8eed0034db 100644
--- a/recipes/qt4/qt4-tools-native_4.5.2.bb
+++ b/recipes/qt4/qt4-tools-native_4.5.2.bb
@@ -1,4 +1,5 @@
require qt4-tools-native.inc
+LICENSE = "LGPLv2.1 GPLv3"
PR = "${INC_PR}.1"
TOBUILD := "src/tools/bootstrap ${TOBUILD}"
diff --git a/recipes/qt4/qt4-tools-sdk_4.5.2.bb b/recipes/qt4/qt4-tools-sdk_4.5.2.bb
index db919fd6df..fafb7710c9 100644
--- a/recipes/qt4/qt4-tools-sdk_4.5.2.bb
+++ b/recipes/qt4/qt4-tools-sdk_4.5.2.bb
@@ -3,7 +3,7 @@ DEPENDS = "zlib-native dbus-native"
SECTION = "libs"
HOMEPAGE = "http://www.trolltech.com"
PRIORITY = "optional"
-LICENSE = "GPL"
+LICENSE = "LGPLv2.1 GPLv3"
inherit sdk
diff --git a/recipes/qt4/qt4-x11-free-gles_git.bb.disabled b/recipes/qt4/qt4-x11-free-gles_git.bb.disabled
index 2e2364414d..bb5f355e6a 100644
--- a/recipes/qt4/qt4-x11-free-gles_git.bb.disabled
+++ b/recipes/qt4/qt4-x11-free-gles_git.bb.disabled
@@ -5,7 +5,7 @@ FILESPATHPKG =. "qt4-x11-free-${PV}:qt4-x11-free:"
QT_GLFLAGS = "-opengl es1 -openvg"
include qt4-x11-free.inc
-LICENSE += "LGPL"
+LICENSE = "LGPLv2.1 GPLv3"
PR = "${INC_PR}.0+gitr${SRCREV}"
DEPENDS += "virtual/egl"
diff --git a/recipes/qt4/qt4-x11-free_4.5.2.bb b/recipes/qt4/qt4-x11-free_4.5.2.bb
index 14d635c04f..27e45ed167 100644
--- a/recipes/qt4/qt4-x11-free_4.5.2.bb
+++ b/recipes/qt4/qt4-x11-free_4.5.2.bb
@@ -1,4 +1,4 @@
include qt4-x11-free.inc
-LICENSE += "LGPL"
+LICENSE = "LGPLv2.1 GPLv3"
PR = "${INC_PR}.2"
diff --git a/recipes/tinylogin/tinylogin_1.4.bb b/recipes/tinylogin/tinylogin_1.4.bb
index 54708b2d4b..23ee694b1c 100644
--- a/recipes/tinylogin/tinylogin_1.4.bb
+++ b/recipes/tinylogin/tinylogin_1.4.bb
@@ -7,7 +7,8 @@ SECTION = "base"
LICENSE = "GPL"
PR = "r6"
-SRC_URI = "http://tinylogin.busybox.net/downloads/tinylogin-${PV}.tar.bz2 \
+#SRC_URI = "http://tinylogin.busybox.net/downloads/tinylogin-${PV}.tar.bz2 \
+SRC_URI = "http://limpens.net/trac/at91-kit-trac/export/4/trunk/sources/tinylogin-${PV}.tar.bz2 \
file://cvs-20040608.patch;patch=1;pnum=1 \
file://add-system.patch;patch=1;pnum=1 \
file://adduser-empty_pwd.patch;patch=1 \
diff --git a/recipes/unzip/unzip_552.bb b/recipes/unzip/unzip_552.bb
index d8809196d8..16b63de2dd 100644
--- a/recipes/unzip/unzip_552.bb
+++ b/recipes/unzip/unzip_552.bb
@@ -2,8 +2,7 @@ DESCRIPTION = "A (de)compression library for the ZIP format"
SECTION = "console/utils"
LICENSE = "Info-ZIP"
PR = "r1"
-
-SRC_URI = "http://ftp.info-zip.org/pub/infozip/src/unzip${PV}.tar.gz"
+SRC_URI = "${SOURCEFORGE_MIRROR}/project/infozip/UnZip%205.x%20and%20earlier/5.52/unzip${PV}.tar.gz"
S = "${WORKDIR}/unzip-5.52"
export LD = "${CC} ${LDFLAGS}"