summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-06-02 13:11:23 -0700
committerKhem Raj <raj.khem@gmail.com>2010-06-05 06:52:42 -0700
commit972d824c01b550adf4c9495f25ac0c63233b9dc7 (patch)
tree51a201d3b445cc7041edb035f2a0133c1b620b9d /recipes
parent0df02f7d999090a40eea1858e43557fc4e1ccaf3 (diff)
downloadopenembedded-972d824c01b550adf4c9495f25ac0c63233b9dc7.tar.gz
libx11_1.3.2.bb: Add -fforward-propagate on arm.
* Needed on -O1 compile. Generally we use -Os where this option is already enabled. But we enable is anyway so it gets picked at -O1 too which we use with DEBUG builds. Signed-off-by: Khem Raj <raj.khem@gmail.com> Acked-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/xorg-lib/libx11_1.3.2.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/recipes/xorg-lib/libx11_1.3.2.bb b/recipes/xorg-lib/libx11_1.3.2.bb
index 855dfa2f83..291486bc5b 100644
--- a/recipes/xorg-lib/libx11_1.3.2.bb
+++ b/recipes/xorg-lib/libx11_1.3.2.bb
@@ -5,7 +5,7 @@ DEPENDS += "bigreqsproto xproto xextproto xtrans libxau xcmiscproto \
libxdmcp xf86bigfontproto kbproto inputproto xproto-native"
PROVIDES = "virtual/libx11"
PE = "1"
-PR = "r3"
+PR = "r4"
XORG_PN = "libX11"
@@ -15,6 +15,12 @@ SRC_URI += "file://x11_disable_makekeys.1.6.3.patch \
EXTRA_OECONF += "--without-xcb --with-keysymdef=${STAGING_INCDIR}/X11/keysymdef.h"
+# Below option is added to overcome the GCC bug on ARM
+# see http://gcc.gnu.org/PR42981 for further details.
+# We could potentially take it off when its fixed in gcc 4.5
+
+CFLAGS_append_arm = " -fforward-propagate "
+
do_compile() {
(
unset CC LD CXX CCLD CFLAGS CPPFLAGS LDFLAGS CXXFLAGS