summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorMartin Dietze <herbert@spamcop.net>2009-11-29 21:20:21 +0100
committerMartin Dietze <herbert@spamcop.net>2009-11-29 21:20:21 +0100
commita6f587c3ac875f4d89cedef234e6c6762cbdfaaa (patch)
treef0a1f83566cff30b3ba06be1fc4059571efaca65 /recipes
parent8c1731d818c89a291f80940c1912587ff9ce46b7 (diff)
downloadopenembedded-a6f587c3ac875f4d89cedef234e6c6762cbdfaaa.tar.gz
opkg-nogpg_svn.bb: link without `-Wl,--as-needed' for nylon
* nylon uses a gcc3-based toolchain which does not support this option, thus added an override
Diffstat (limited to 'recipes')
-rw-r--r--recipes/opkg/opkg-nogpg_svn.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes/opkg/opkg-nogpg_svn.bb b/recipes/opkg/opkg-nogpg_svn.bb
index 9ddc589b49..33d9987463 100644
--- a/recipes/opkg/opkg-nogpg_svn.bb
+++ b/recipes/opkg/opkg-nogpg_svn.bb
@@ -20,5 +20,8 @@ LDFLAGS_append = " -Wl,--as-needed"
do_configure_prepend() {
sed -i -e s:-Werror::g ${S}/libopkg/Makefile.am
}
+do_configure_prepend_nylon() {
+ LDFLAGS="`echo "$LDFLAGS" | sed "s/ -Wl,--as-needed//"`"
+}
DEFAULT_PREFERENCE = "-1"