summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-03-22 16:22:30 +0100
committerKoen Kooi <koen@openembedded.org>2010-04-12 19:43:29 +0200
commitbb3c6f24758b490366543e7392dd13cdcb200b6f (patch)
tree682049818f80651900d07e7c4bf91037170d55fd /recipes
parent616f5f6d11a71401eb6dbd4585db972178b2b339 (diff)
downloadopenembedded-bb3c6f24758b490366543e7392dd13cdcb200b6f.tar.gz
rt3070: also install .bin file, move to directory with other ralink recipes
Diffstat (limited to 'recipes')
-rw-r--r--recipes/rt2x00/files/config.patch (renamed from recipes/ralink/files/config.patch)0
-rw-r--r--recipes/rt2x00/files/makefile.patch (renamed from recipes/ralink/files/makefile.patch)0
-rw-r--r--recipes/rt2x00/rt3070_2.1.1.0.bb (renamed from recipes/ralink/rt3070_2.1.1.0.bb)9
3 files changed, 8 insertions, 1 deletions
diff --git a/recipes/ralink/files/config.patch b/recipes/rt2x00/files/config.patch
index 89a26caea0..89a26caea0 100644
--- a/recipes/ralink/files/config.patch
+++ b/recipes/rt2x00/files/config.patch
diff --git a/recipes/ralink/files/makefile.patch b/recipes/rt2x00/files/makefile.patch
index ca949023cf..ca949023cf 100644
--- a/recipes/ralink/files/makefile.patch
+++ b/recipes/rt2x00/files/makefile.patch
diff --git a/recipes/ralink/rt3070_2.1.1.0.bb b/recipes/rt2x00/rt3070_2.1.1.0.bb
index 23b0de7d32..324471ad8f 100644
--- a/recipes/ralink/rt3070_2.1.1.0.bb
+++ b/recipes/rt2x00/rt3070_2.1.1.0.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "Ralink 3070"
SECTION = "kernel/modules"
LICENSE = "GPLv2"
-PR = "r1"
+PR = "r2"
inherit module
@@ -19,4 +19,11 @@ do_install() {
install -m 0644 ${S}/os/linux/rt3070sta.ko ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/net/wireless
install -d ${D}/etc/Wireless/RT2870STA
install -m 0644 ${S}/RT2870STA.dat ${D}/etc/Wireless/RT2870STA
+ install -d ${D}/lib/firmware
+ install -m 0644 ${S}/common/*.bin ${D}/lib/firmware/
}
+
+PACKAGES =+ "${PN}-firmware"
+FILES_${PN}-firmware = "/etc /lib/firmware"
+
+RDEPENDS_${PN} = "${PN}-firmware"