summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-11-29 21:28:30 +0100
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-11-29 21:28:30 +0100
commitbeb449962d53005af62c8141effb0e0723e0b49d (patch)
treeacb503377e968640ce19ce65da4aae2273229c79 /recipes
parent0249f685da226c36be2f472bcd2af9e4aa94a132 (diff)
parentf32389464a0a74358d5b8f92f7dfbbda05aa0c0a (diff)
downloadopenembedded-beb449962d53005af62c8141effb0e0723e0b49d.tar.gz
Merge branch 'org.openembedded.dev' of git.openembedded.org:openembedded into org.openembedded.dev
Diffstat (limited to 'recipes')
-rw-r--r--recipes/e17/exhibit_svn.bb4
-rw-r--r--recipes/e2fsprogs-libs/e2fsprogs-libs.inc9
-rw-r--r--recipes/freesmartphone/fsodatad_git.bb6
-rw-r--r--recipes/freesmartphone/fsodeviced_git.bb7
-rw-r--r--recipes/freesmartphone/fsolocationd_git.bb (renamed from recipes/freesmartphone/fsogpsd_git.bb)2
-rw-r--r--recipes/freesmartphone/fsomusicd_git.bb20
-rw-r--r--recipes/gcc/gcc-configure-common.inc1
-rw-r--r--recipes/linux/linux-mtx-1-2.4.27/49-bash4-configure.patch11
-rw-r--r--recipes/linux/linux-mtx-1_2.4.27.bb1
-rw-r--r--recipes/linux/linux-mtx-2-2.4.27/49-bash4-configure.patch11
-rw-r--r--recipes/linux/linux-mtx-2_2.4.27.bb1
-rw-r--r--recipes/linux/linux-openmoko-2.6.31/0006-gta02-defconfig-enable-NFS-and-INOTIFY_USER.patch124
-rw-r--r--recipes/linux/linux-openmoko-2.6.31_git.bb5
-rw-r--r--recipes/mtd/mtd-utils.inc8
-rw-r--r--recipes/openmoko-3rdparty/babiloo-efl_bzr.bb2
-rw-r--r--recipes/opkg/opkg-nogpg_svn.bb3
-rw-r--r--recipes/opkg/opkg_svn.bb2
-rw-r--r--recipes/python/python-phoneutils_git.bb6
-rw-r--r--recipes/zaurus-utils/nandlogical-klibc-static_1.0.0.bb10
-rw-r--r--recipes/zaurus-utils/nandlogical/mtd-abi.h152
-rw-r--r--recipes/zaurus-utils/nandlogical/mtd-user.h21
-rw-r--r--recipes/zaurus-utils/nandlogical_1.0.0.bb4
22 files changed, 216 insertions, 194 deletions
diff --git a/recipes/e17/exhibit_svn.bb b/recipes/e17/exhibit_svn.bb
index ac2b67de35..16bd1fbee9 100644
--- a/recipes/e17/exhibit_svn.bb
+++ b/recipes/e17/exhibit_svn.bb
@@ -2,6 +2,8 @@ DESCRIPTION = "Exhibit is the ETK picture viewer"
LICENSE = "MIT BSD"
DEPENDS = "evas ecore epsilon edje eet etk efreet"
PV = "0.1.1+svnr${SRCPV}"
-PR = "r1"
+PR = "r2"
inherit e
+
+SRC_URI = "svn://svn.enlightenment.org/svn/e/trunk/OLD;module=${SRCNAME};proto=http"
diff --git a/recipes/e2fsprogs-libs/e2fsprogs-libs.inc b/recipes/e2fsprogs-libs/e2fsprogs-libs.inc
index 45618b008c..f5e974b8aa 100644
--- a/recipes/e2fsprogs-libs/e2fsprogs-libs.inc
+++ b/recipes/e2fsprogs-libs/e2fsprogs-libs.inc
@@ -35,3 +35,12 @@ do_stage () {
install -m 0644 lib/ss/ss.h ${STAGING_INCDIR}/ss/
install -m 0644 lib/ss/ss_err.h ${STAGING_INCDIR}/ss/
}
+
+# avoid requiring unsupported util-linux-ng for nylon, provide uuid for others...
+DEPENDS_nylon = ""
+EXTRA_OECONF_nylon = ""
+do_stage_append_nylon() {
+ install -d ${STAGING_INCDIR}/uuid
+ install -m 0644 lib/uuid/uuid.h ${STAGING_INCDIR}/uuid/
+ install -m 0644 lib/uuid/libuuid.a ${STAGING_LIBDIR}/
+}
diff --git a/recipes/freesmartphone/fsodatad_git.bb b/recipes/freesmartphone/fsodatad_git.bb
new file mode 100644
index 0000000000..de13bedc0a
--- /dev/null
+++ b/recipes/freesmartphone/fsodatad_git.bb
@@ -0,0 +1,6 @@
+require cornucopia.inc
+inherit fso-plugin
+PR = "${INC_PR}.0"
+PV = "0.0.0+gitr${SRCREV}"
+
+DEPENDS += "libxml2 mobile-broadband-provider-info"
diff --git a/recipes/freesmartphone/fsodeviced_git.bb b/recipes/freesmartphone/fsodeviced_git.bb
index d1aedc16b9..3406806a6c 100644
--- a/recipes/freesmartphone/fsodeviced_git.bb
+++ b/recipes/freesmartphone/fsodeviced_git.bb
@@ -6,7 +6,12 @@ RDEPENDS += "libcanberra-alsa"
RRECOMMENDS += "fso-alsa-data"
PV = "0.9.0+gitr${SRCREV}"
PE = "1"
-PR = "${INC_PR}.4"
+PR = "${INC_PR}.5"
+
+EXTRA_OECONF = "\
+ --enable-kernel26-rfkill \
+ --enable-player-canberra \
+"
inherit update-rc.d
diff --git a/recipes/freesmartphone/fsogpsd_git.bb b/recipes/freesmartphone/fsolocationd_git.bb
index 1e3f5718ed..a70bf596f5 100644
--- a/recipes/freesmartphone/fsogpsd_git.bb
+++ b/recipes/freesmartphone/fsolocationd_git.bb
@@ -3,4 +3,4 @@ inherit fso-plugin
PR = "${INC_PR}.0"
PV = "0.0.0+gitr${SRCREV}"
-DEPENDS += "libfsoresource"
+DEPENDS += "libfsotransport libfsoresource"
diff --git a/recipes/freesmartphone/fsomusicd_git.bb b/recipes/freesmartphone/fsomusicd_git.bb
new file mode 100644
index 0000000000..0081298909
--- /dev/null
+++ b/recipes/freesmartphone/fsomusicd_git.bb
@@ -0,0 +1,20 @@
+require cornucopia.inc
+DEPENDS += "gstreamer"
+PV = "0.0.1+gitr${SRCREV}"
+PR = "${INC_PR}.0"
+
+RDEPENDS += "\
+ gst-plugin-volume \
+ gst-plugin-mad \
+ gst-plugin-oggdemux \
+ gst-plugin-ivorbisdec \
+ gst-plugin-audioconvert \
+ gst-plugin-flacdec \
+ gst-plugin-waveparse \
+ gst-plugin-siddec \
+ gst-plugin-modplug \
+ gst-plugin-filesrc \
+ gst-plugin-souphttpsrc \
+ gst-plugin-mmssrc \
+ gst-plugin-alsasink \
+"
diff --git a/recipes/gcc/gcc-configure-common.inc b/recipes/gcc/gcc-configure-common.inc
index efe8ee8787..8a96326b7d 100644
--- a/recipes/gcc/gcc-configure-common.inc
+++ b/recipes/gcc/gcc-configure-common.inc
@@ -12,6 +12,7 @@ JAVA_sh3 ?= ""
OBJC_linux-uclibceabi ?= ""
OBJC_linux-uclibc ?= ""
OBJC_avr ?= ""
+OBJC_nylon ?= ""
OBJC ?= ",objc"
# gcc 3.x expects 'f77', 4.0 expects 'f95', 4.1 and 4.2 expect 'fortran'
diff --git a/recipes/linux/linux-mtx-1-2.4.27/49-bash4-configure.patch b/recipes/linux/linux-mtx-1-2.4.27/49-bash4-configure.patch
new file mode 100644
index 0000000000..222567d12e
--- /dev/null
+++ b/recipes/linux/linux-mtx-1-2.4.27/49-bash4-configure.patch
@@ -0,0 +1,11 @@
+--- linux/scripts/Configure-orig 2009-11-29 19:12:02.000000000 +0100
++++ linux/scripts/Configure 2009-11-29 19:12:27.000000000 +0100
+@@ -543,7 +543,7 @@
+ echo "#"
+ echo "# Using defaults found in" $DEFAULTS
+ echo "#"
+- . $DEFAULTS
++ . ./$DEFAULTS
+ sed -e 's/# \(CONFIG_[^ ]*\) is not.*/\1=n/' <$DEFAULTS >.config-is-not.$$
+ . .config-is-not.$$
+ rm .config-is-not.$$
diff --git a/recipes/linux/linux-mtx-1_2.4.27.bb b/recipes/linux/linux-mtx-1_2.4.27.bb
index 6dd7121bae..952edb0140 100644
--- a/recipes/linux/linux-mtx-1_2.4.27.bb
+++ b/recipes/linux/linux-mtx-1_2.4.27.bb
@@ -41,6 +41,7 @@ SRC_URI = "cvs://cvs:cvs@ftp.linux-mips.org/home/cvs;module=linux;tag=linux_2_4_
file://43-usbserial-27-32-backport.diff;patch=1 \
file://45-acm-tty-and-sb2.patch;patch=1 \
file://48-pptp.patch;patch=1 \
+ file://49-bash4-configure.patch;patch=1 \
file://defconfig-mtx-1"
S = "${WORKDIR}/linux"
diff --git a/recipes/linux/linux-mtx-2-2.4.27/49-bash4-configure.patch b/recipes/linux/linux-mtx-2-2.4.27/49-bash4-configure.patch
new file mode 100644
index 0000000000..222567d12e
--- /dev/null
+++ b/recipes/linux/linux-mtx-2-2.4.27/49-bash4-configure.patch
@@ -0,0 +1,11 @@
+--- linux/scripts/Configure-orig 2009-11-29 19:12:02.000000000 +0100
++++ linux/scripts/Configure 2009-11-29 19:12:27.000000000 +0100
+@@ -543,7 +543,7 @@
+ echo "#"
+ echo "# Using defaults found in" $DEFAULTS
+ echo "#"
+- . $DEFAULTS
++ . ./$DEFAULTS
+ sed -e 's/# \(CONFIG_[^ ]*\) is not.*/\1=n/' <$DEFAULTS >.config-is-not.$$
+ . .config-is-not.$$
+ rm .config-is-not.$$
diff --git a/recipes/linux/linux-mtx-2_2.4.27.bb b/recipes/linux/linux-mtx-2_2.4.27.bb
index 5b26903ec0..3379d548a1 100644
--- a/recipes/linux/linux-mtx-2_2.4.27.bb
+++ b/recipes/linux/linux-mtx-2_2.4.27.bb
@@ -43,6 +43,7 @@ SRC_URI += "cvs://cvs:cvs@ftp.linux-mips.org/home/cvs;module=linux;tag=linux_2_4
file://46-otg.patch;patch=1 \
file://47-au1000_eth.patch;patch=1 \
file://48-pptp.patch;patch=1 \
+ file://49-bash4-configure.patch;patch=1 \
file://defconfig-mtx-2"
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/linux-mtx-2-${PV}"
diff --git a/recipes/linux/linux-openmoko-2.6.31/0006-gta02-defconfig-enable-NFS-and-INOTIFY_USER.patch b/recipes/linux/linux-openmoko-2.6.31/0006-gta02-defconfig-enable-NFS-and-INOTIFY_USER.patch
new file mode 100644
index 0000000000..31d2b6569b
--- /dev/null
+++ b/recipes/linux/linux-openmoko-2.6.31/0006-gta02-defconfig-enable-NFS-and-INOTIFY_USER.patch
@@ -0,0 +1,124 @@
+From 20aa0022f765e702f76fe1cae429b1d58faa9ec4 Mon Sep 17 00:00:00 2001
+From: Martin Jansa <Martin.Jansa@gmail.com>
+Date: Sat, 28 Nov 2009 19:24:49 +0100
+Subject: [PATCH] gta02-defconfig: enable NFS and INOTIFY_USER
+
+---
+ arch/arm/configs/gta02_defconfig | 48 ++++++++++++++++++++++++++++++-------
+ 1 files changed, 39 insertions(+), 9 deletions(-)
+
+diff --git a/arch/arm/configs/gta02_defconfig b/arch/arm/configs/gta02_defconfig
+index 1cce709..acf225e 100644
+--- a/arch/arm/configs/gta02_defconfig
++++ b/arch/arm/configs/gta02_defconfig
+@@ -860,7 +860,7 @@ CONFIG_I2C_CHARDEV=y
+ #
+ # I2C Algorithms
+ #
+-# CONFIG_I2C_ALGOBIT is not set
++CONFIG_I2C_ALGOBIT=y
+ # CONFIG_I2C_ALGOPCF is not set
+ # CONFIG_I2C_ALGOPCA is not set
+
+@@ -953,6 +953,7 @@ CONFIG_POWER_SUPPLY=y
+ CONFIG_CHARGER_PCF50633=y
+ CONFIG_BATTERY_BQ27000_HDQ=y
+ CONFIG_HDQ_GPIO_BITBANG=y
++# CONFIG_BATTERY_PLATFORM is not set
+ # CONFIG_HWMON is not set
+ # CONFIG_THERMAL is not set
+ # CONFIG_THERMAL_HWMON is not set
+@@ -1444,15 +1445,15 @@ CONFIG_JBD=y
+ # CONFIG_JBD_DEBUG is not set
+ # CONFIG_REISERFS_FS is not set
+ # CONFIG_JFS_FS is not set
+-# CONFIG_FS_POSIX_ACL is not set
++CONFIG_FS_POSIX_ACL=y
+ # CONFIG_XFS_FS is not set
+ # CONFIG_OCFS2_FS is not set
+ # CONFIG_BTRFS_FS is not set
+ CONFIG_FILE_LOCKING=y
+-# CONFIG_FSNOTIFY is not set
++CONFIG_FSNOTIFY=y
+ # CONFIG_DNOTIFY is not set
+ CONFIG_INOTIFY=y
+-# CONFIG_INOTIFY_USER is not set
++CONFIG_INOTIFY_USER=y
+ # CONFIG_QUOTA is not set
+ # CONFIG_AUTOFS_FS is not set
+ # CONFIG_AUTOFS4_FS is not set
+@@ -1526,7 +1527,31 @@ CONFIG_UBIFS_FS_ZLIB=y
+ # CONFIG_SYSV_FS is not set
+ # CONFIG_UFS_FS is not set
+ # CONFIG_NILFS2_FS is not set
+-# CONFIG_NETWORK_FILESYSTEMS is not set
++CONFIG_NETWORK_FILESYSTEMS=y
++CONFIG_NFS_FS=m
++CONFIG_NFS_V3=y
++CONFIG_NFS_V3_ACL=y
++CONFIG_NFS_V4=y
++# CONFIG_NFS_V4_1 is not set
++CONFIG_NFSD=m
++CONFIG_NFSD_V2_ACL=y
++CONFIG_NFSD_V3=y
++CONFIG_NFSD_V3_ACL=y
++CONFIG_NFSD_V4=y
++CONFIG_LOCKD=m
++CONFIG_LOCKD_V4=y
++CONFIG_EXPORTFS=m
++CONFIG_NFS_ACL_SUPPORT=m
++CONFIG_NFS_COMMON=y
++CONFIG_SUNRPC=m
++CONFIG_SUNRPC_GSS=m
++CONFIG_RPCSEC_GSS_KRB5=m
++# CONFIG_RPCSEC_GSS_SPKM3 is not set
++# CONFIG_SMB_FS is not set
++# CONFIG_CIFS is not set
++# CONFIG_NCP_FS is not set
++# CONFIG_CODA_FS is not set
++# CONFIG_AFS_FS is not set
+
+ #
+ # Partition Types
+@@ -1634,13 +1659,18 @@ CONFIG_CRYPTO=y
+ # CONFIG_CRYPTO_FIPS is not set
+ CONFIG_CRYPTO_ALGAPI=y
+ CONFIG_CRYPTO_ALGAPI2=y
++CONFIG_CRYPTO_AEAD2=y
++CONFIG_CRYPTO_BLKCIPHER=m
++CONFIG_CRYPTO_BLKCIPHER2=y
+ CONFIG_CRYPTO_HASH=y
+ CONFIG_CRYPTO_HASH2=y
++CONFIG_CRYPTO_RNG2=y
+ CONFIG_CRYPTO_PCOMP=y
+-# CONFIG_CRYPTO_MANAGER is not set
+-# CONFIG_CRYPTO_MANAGER2 is not set
++CONFIG_CRYPTO_MANAGER=m
++CONFIG_CRYPTO_MANAGER2=y
+ # CONFIG_CRYPTO_GF128MUL is not set
+ # CONFIG_CRYPTO_NULL is not set
++CONFIG_CRYPTO_WORKQUEUE=y
+ # CONFIG_CRYPTO_CRYPTD is not set
+ # CONFIG_CRYPTO_AUTHENC is not set
+ # CONFIG_CRYPTO_TEST is not set
+@@ -1655,7 +1685,7 @@ CONFIG_CRYPTO_PCOMP=y
+ #
+ # Block modes
+ #
+-# CONFIG_CRYPTO_CBC is not set
++CONFIG_CRYPTO_CBC=m
+ # CONFIG_CRYPTO_CTR is not set
+ # CONFIG_CRYPTO_CTS is not set
+ # CONFIG_CRYPTO_ECB is not set
+@@ -1696,7 +1726,7 @@ CONFIG_CRYPTO_MD5=y
+ # CONFIG_CRYPTO_CAMELLIA is not set
+ # CONFIG_CRYPTO_CAST5 is not set
+ # CONFIG_CRYPTO_CAST6 is not set
+-# CONFIG_CRYPTO_DES is not set
++CONFIG_CRYPTO_DES=m
+ # CONFIG_CRYPTO_FCRYPT is not set
+ # CONFIG_CRYPTO_KHAZAD is not set
+ # CONFIG_CRYPTO_SALSA20 is not set
+--
+1.6.5.3
+
diff --git a/recipes/linux/linux-openmoko-2.6.31_git.bb b/recipes/linux/linux-openmoko-2.6.31_git.bb
index 346cdece1e..301ac6b863 100644
--- a/recipes/linux/linux-openmoko-2.6.31_git.bb
+++ b/recipes/linux/linux-openmoko-2.6.31_git.bb
@@ -8,7 +8,7 @@ KERNEL_VERSION = "${KERNEL_RELEASE}"
OEV = "oe1"
PV = "${KERNEL_RELEASE}-${OEV}+gitr${SRCREV}"
-PR = "r4"
+PR = "r5"
SRC_URI = "\
git://git.openmoko.org/git/kernel.git;protocol=git;branch=om-2.6.31 \
@@ -19,10 +19,11 @@ SRC_URI = "\
file://0002-Glamo-DRM-and-KMS-driver.patch;patch=1 \
file://0003-Work-on-Glamo-core-for-DRM.patch;patch=1 \
file://0004-Add-JBT6k74-hook-for-use-by-KMS.patch;patch=1 \
-# enable UBI+DRM
+# enable UBI+DRM+NFS+INOTIFY_USER
file://0004-gta02_defconfig-Enable-UBI-support.patch;patch=1 \
file://0005-gta02_defconfig-Enable-UBI-debug.patch;patch=1 \
file://0001-gta02_defconfig-Enable-GLAMO_DRM.patch;patch=1 \
+ file://0006-gta02-defconfig-enable-NFS-and-INOTIFY_USER.patch \
"
S = "${WORKDIR}/git"
diff --git a/recipes/mtd/mtd-utils.inc b/recipes/mtd/mtd-utils.inc
index dcf0e7c832..813a09fb13 100644
--- a/recipes/mtd/mtd-utils.inc
+++ b/recipes/mtd/mtd-utils.inc
@@ -17,7 +17,9 @@ do_stage () {
install -m 0644 $f ${STAGING_INCDIR}/mtd/
done
for binary in ${mtd_utils}; do
- install -m 0755 $binary ${STAGING_BINDIR}
+ if [ -f $binary ]; then
+ install -m 0755 $binary ${STAGING_BINDIR}
+ fi
done
}
@@ -25,7 +27,9 @@ do_install () {
install -d ${D}${bindir}
install -d ${D}${includedir}/mtd
for binary in ${mtd_utils}; do
- install -m 0755 $binary ${D}${bindir}
+ if [ -f $binary ]; then
+ install -m 0755 $binary ${D}${bindir}
+ fi
done
for f in ${S}/include/mtd/*.h; do
install -m 0644 $f ${D}${includedir}/mtd
diff --git a/recipes/openmoko-3rdparty/babiloo-efl_bzr.bb b/recipes/openmoko-3rdparty/babiloo-efl_bzr.bb
index 5c9c22503f..614c095b8b 100644
--- a/recipes/openmoko-3rdparty/babiloo-efl_bzr.bb
+++ b/recipes/openmoko-3rdparty/babiloo-efl_bzr.bb
@@ -9,7 +9,7 @@ RDEPENDS = "python-elementary python-compression python-misc python-netclient"
PACKAGE_ARCH = "all"
DEFAULT_PREFERENCE = "-1"
-PV = "2.0.9-bzrr${SRCREV}"
+PV = "2.0.9-bzrr${SRCPV}"
SRC_URI = "bzr://bazaar.launchpad.net/~vaudano/babiloo/efl"
diff --git a/recipes/opkg/opkg-nogpg_svn.bb b/recipes/opkg/opkg-nogpg_svn.bb
index 9ddc589b49..33d9987463 100644
--- a/recipes/opkg/opkg-nogpg_svn.bb
+++ b/recipes/opkg/opkg-nogpg_svn.bb
@@ -20,5 +20,8 @@ LDFLAGS_append = " -Wl,--as-needed"
do_configure_prepend() {
sed -i -e s:-Werror::g ${S}/libopkg/Makefile.am
}
+do_configure_prepend_nylon() {
+ LDFLAGS="`echo "$LDFLAGS" | sed "s/ -Wl,--as-needed//"`"
+}
DEFAULT_PREFERENCE = "-1"
diff --git a/recipes/opkg/opkg_svn.bb b/recipes/opkg/opkg_svn.bb
index 676a8cb499..57b2774b65 100644
--- a/recipes/opkg/opkg_svn.bb
+++ b/recipes/opkg/opkg_svn.bb
@@ -1,5 +1,7 @@
require opkg.inc
+DEPENDS_append = " openssl"
+
PR = "${INC_PR}"
PACKAGES =+ "libopkg-dev libopkg"
diff --git a/recipes/python/python-phoneutils_git.bb b/recipes/python/python-phoneutils_git.bb
index c1e1dbe16e..c616a2beed 100644
--- a/recipes/python/python-phoneutils_git.bb
+++ b/recipes/python/python-phoneutils_git.bb
@@ -1,8 +1,10 @@
DESCRIPTION = "Python Bindings for libphone-utils"
SECTION = "devel/python"
-DEPENDS = "libphone-utils"
+DEPENDS = "libphone-utils python-cython-native python-pyrex-native"
+RDEPENDS = "libphone-utils"
+
PV = "0.0.2+gitr${SRCREV}"
-PR = "r1"
+PR = "r2"
SRC_URI = "git://git.shr-project.org/repo/libphone-utils.git;protocol=http;branch=master"
S = "${WORKDIR}/git/src/python"
diff --git a/recipes/zaurus-utils/nandlogical-klibc-static_1.0.0.bb b/recipes/zaurus-utils/nandlogical-klibc-static_1.0.0.bb
index 42d30c90f8..f9a6b0e55d 100644
--- a/recipes/zaurus-utils/nandlogical-klibc-static_1.0.0.bb
+++ b/recipes/zaurus-utils/nandlogical-klibc-static_1.0.0.bb
@@ -2,9 +2,6 @@ require nandlogical_${PV}.bb
FILESPATHPKG =. "nandlogical:"
-SRC_URI_append = " file://mtd-user.h \
- file://mtd-abi.h \
- "
DEPENDS += "klibc"
export CC = ${TARGET_PREFIX}klcc
@@ -14,11 +11,6 @@ export CFLAGS = ""
export CPPFLAGS = ""
export LDFLAGS = ""
-do_configure_prepend() {
- sed -i 's:<mtd/mtd-user.h>:"mtd-user.h":g' '${S}/nandlogical.c'
- sed -i 's:<mtd/mtd-abi.h>:"mtd-abi.h":g' '${S}/mtd-user.h'
-}
-
do_compile() {
- ${CC} nandlogical.c -o nandlogical ${CFLAGS} ${LDFLAGS} -static
+ ${CC} ${CFLAGS} ${LDFLAGS} -static -I${STAGING_INCDIR} nandlogical.c -o nandlogical
}
diff --git a/recipes/zaurus-utils/nandlogical/mtd-abi.h b/recipes/zaurus-utils/nandlogical/mtd-abi.h
deleted file mode 100644
index 86defe175f..0000000000
--- a/recipes/zaurus-utils/nandlogical/mtd-abi.h
+++ /dev/null
@@ -1,152 +0,0 @@
-/*
- * $Id: mtd-abi.h,v 1.13 2005/11/07 11:14:56 gleixner Exp $
- *
- * Portions of MTD ABI definition which are shared by kernel and user space
- */
-
-#ifndef __MTD_ABI_H__
-#define __MTD_ABI_H__
-
-struct erase_info_user {
- uint32_t start;
- uint32_t length;
-};
-
-struct mtd_oob_buf {
- uint32_t start;
- uint32_t length;
- unsigned char *ptr;
-};
-
-#define MTD_ABSENT 0
-#define MTD_RAM 1
-#define MTD_ROM 2
-#define MTD_NORFLASH 3
-#define MTD_NANDFLASH 4
-#define MTD_DATAFLASH 6
-#define MTD_UBIVOLUME 7
-
-#define MTD_WRITEABLE 0x400 /* Device is writeable */
-#define MTD_BIT_WRITEABLE 0x800 /* Single bits can be flipped */
-#define MTD_NO_ERASE 0x1000 /* No erase necessary */
-#define MTD_STUPID_LOCK 0x2000 /* Always locked after reset */
-
-// Some common devices / combinations of capabilities
-#define MTD_CAP_ROM 0
-#define MTD_CAP_RAM (MTD_WRITEABLE | MTD_BIT_WRITEABLE | MTD_NO_ERASE)
-#define MTD_CAP_NORFLASH (MTD_WRITEABLE | MTD_BIT_WRITEABLE)
-#define MTD_CAP_NANDFLASH (MTD_WRITEABLE)
-
-/* ECC byte placement */
-#define MTD_NANDECC_OFF 0 // Switch off ECC (Not recommended)
-#define MTD_NANDECC_PLACE 1 // Use the given placement in the structure (YAFFS1 legacy mode)
-#define MTD_NANDECC_AUTOPLACE 2 // Use the default placement scheme
-#define MTD_NANDECC_PLACEONLY 3 // Use the given placement in the structure (Do not store ecc result on read)
-#define MTD_NANDECC_AUTOPL_USR 4 // Use the given autoplacement scheme rather than using the default
-
-/* OTP mode selection */
-#define MTD_OTP_OFF 0
-#define MTD_OTP_FACTORY 1
-#define MTD_OTP_USER 2
-
-struct mtd_info_user {
- uint8_t type;
- uint32_t flags;
- uint32_t size; // Total size of the MTD
- uint32_t erasesize;
- uint32_t writesize;
- uint32_t oobsize; // Amount of OOB data per block (e.g. 16)
- /* The below two fields are obsolete and broken, do not use them
- * (TODO: remove at some point) */
- uint32_t ecctype;
- uint32_t eccsize;
-};
-
-struct region_info_user {
- uint32_t offset; /* At which this region starts,
- * from the beginning of the MTD */
- uint32_t erasesize; /* For this region */
- uint32_t numblocks; /* Number of blocks in this region */
- uint32_t regionindex;
-};
-
-struct otp_info {
- uint32_t start;
- uint32_t length;
- uint32_t locked;
-};
-
-#define MEMGETINFO _IOR('M', 1, struct mtd_info_user)
-#define MEMERASE _IOW('M', 2, struct erase_info_user)
-#define MEMWRITEOOB _IOWR('M', 3, struct mtd_oob_buf)
-#define MEMREADOOB _IOWR('M', 4, struct mtd_oob_buf)
-#define MEMLOCK _IOW('M', 5, struct erase_info_user)
-#define MEMUNLOCK _IOW('M', 6, struct erase_info_user)
-#define MEMGETREGIONCOUNT _IOR('M', 7, int)
-#define MEMGETREGIONINFO _IOWR('M', 8, struct region_info_user)
-#define MEMSETOOBSEL _IOW('M', 9, struct nand_oobinfo)
-#define MEMGETOOBSEL _IOR('M', 10, struct nand_oobinfo)
-#define MEMGETBADBLOCK _IOW('M', 11, loff_t)
-#define MEMSETBADBLOCK _IOW('M', 12, loff_t)
-#define OTPSELECT _IOR('M', 13, int)
-#define OTPGETREGIONCOUNT _IOW('M', 14, int)
-#define OTPGETREGIONINFO _IOW('M', 15, struct otp_info)
-#define OTPLOCK _IOR('M', 16, struct otp_info)
-#define ECCGETLAYOUT _IOR('M', 17, struct nand_ecclayout)
-#define ECCGETSTATS _IOR('M', 18, struct mtd_ecc_stats)
-#define MTDFILEMODE _IO('M', 19)
-
-/*
- * Obsolete legacy interface. Keep it in order not to break userspace
- * interfaces
- */
-struct nand_oobinfo {
- uint32_t useecc;
- uint32_t eccbytes;
- uint32_t oobfree[8][2];
- uint32_t eccpos[32];
-};
-
-struct nand_oobfree {
- uint32_t offset;
- uint32_t length;
-};
-
-#define MTD_MAX_OOBFREE_ENTRIES 8
-/*
- * ECC layout control structure. Exported to userspace for
- * diagnosis and to allow creation of raw images
- */
-struct nand_ecclayout {
- uint32_t eccbytes;
- uint32_t eccpos[64];
- uint32_t oobavail;
- struct nand_oobfree oobfree[MTD_MAX_OOBFREE_ENTRIES];
-};
-
-/**
- * struct mtd_ecc_stats - error correction stats
- *
- * @corrected: number of corrected bits
- * @failed: number of uncorrectable errors
- * @badblocks: number of bad blocks in this partition
- * @bbtblocks: number of blocks reserved for bad block tables
- */
-struct mtd_ecc_stats {
- uint32_t corrected;
- uint32_t failed;
- uint32_t badblocks;
- uint32_t bbtblocks;
-};
-
-/*
- * Read/write file modes for access to MTD
- */
-enum mtd_file_modes {
- MTD_MODE_NORMAL = MTD_OTP_OFF,
- MTD_MODE_OTP_FACTORY = MTD_OTP_FACTORY,
- MTD_MODE_OTP_USER = MTD_OTP_USER,
- MTD_MODE_RAW,
-};
-
-#endif /* __MTD_ABI_H__ */
diff --git a/recipes/zaurus-utils/nandlogical/mtd-user.h b/recipes/zaurus-utils/nandlogical/mtd-user.h
deleted file mode 100644
index 713f34d3e6..0000000000
--- a/recipes/zaurus-utils/nandlogical/mtd-user.h
+++ /dev/null
@@ -1,21 +0,0 @@
-/*
- * $Id: mtd-user.h,v 1.2 2004/05/05 14:44:57 dwmw2 Exp $
- *
- * MTD ABI header for use by user space only.
- */
-
-#ifndef __MTD_USER_H__
-#define __MTD_USER_H__
-
-#include <stdint.h>
-
-/* This file is blessed for inclusion by userspace */
-#include <mtd/mtd-abi.h>
-
-typedef struct mtd_info_user mtd_info_t;
-typedef struct erase_info_user erase_info_t;
-typedef struct region_info_user region_info_t;
-typedef struct nand_oobinfo nand_oobinfo_t;
-typedef struct nand_ecclayout nand_ecclayout_t;
-
-#endif /* __MTD_USER_H__ */
diff --git a/recipes/zaurus-utils/nandlogical_1.0.0.bb b/recipes/zaurus-utils/nandlogical_1.0.0.bb
index d567b48a3c..df261540bd 100644
--- a/recipes/zaurus-utils/nandlogical_1.0.0.bb
+++ b/recipes/zaurus-utils/nandlogical_1.0.0.bb
@@ -2,14 +2,14 @@ DESCRIPTION = "Nandlogical for Sharp mtd1"
LICENSE = "GPL"
DEPENDS = "mtd-utils"
COMPATIBLE_MACHINE = "(poodle|c7x0|akita|spitz|tosa)"
-PR = "r2"
+PR = "r3"
SRC_URI = "file://nandlogical.c"
S = "${WORKDIR}"
do_compile () {
- ${CC} nandlogical.c -o nandlogical ${CFLAGS} ${LDFLAGS}
+ ${CC} ${CFLAGS} ${LDFLAGS} nandlogical.c -o nandlogical
}
do_install () {