summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorChase Maupin <chasemaupin03@gmail.com>2010-09-10 08:02:20 +0000
committerDenys Dmytriyenko <denis@denix.org>2010-09-11 16:06:26 -0400
commite4a5af399446d0d0bc3afb02d581b27c41f4350e (patch)
tree7b1b902581effcb795b5f6b9873fdb429bcc7221 /recipes
parentf66709f94f315ab11aff903183c89fef8b99a2f2 (diff)
downloadopenembedded-e4a5af399446d0d0bc3afb02d581b27c41f4350e.tar.gz
jpeg_8b: Allow using older versions of automake
* Added patch to allow using older versions of automake such as 1.10.3 when building jpeg version 8b. * Only use the AM_SILENT_RULES if it is available. Signed-off-by: Chase Maupin <chase.maupin@ti.com> Acked-by: Denys Dmytriyenko <denis@denix.org> Signed-off-by: Denys Dmytriyenko <denis@denix.org>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/jpeg/jpeg-8b/0001-configure-make-jpeg-work-with-older-autotools.patch30
-rw-r--r--recipes/jpeg/jpeg_8b.bb7
2 files changed, 35 insertions, 2 deletions
diff --git a/recipes/jpeg/jpeg-8b/0001-configure-make-jpeg-work-with-older-autotools.patch b/recipes/jpeg/jpeg-8b/0001-configure-make-jpeg-work-with-older-autotools.patch
new file mode 100644
index 0000000000..dd6fd52f63
--- /dev/null
+++ b/recipes/jpeg/jpeg-8b/0001-configure-make-jpeg-work-with-older-autotools.patch
@@ -0,0 +1,30 @@
+From e9e77ee999553f9b94de0288688a0bdc60b92e0f Mon Sep 17 00:00:00 2001
+From: Chase Maupin <chase.maupin@ti.com>
+Date: Tue, 17 Aug 2010 08:30:56 -0500
+Subject: [PATCH] configure: make jpeg work with older autotools
+
+* Only use the AM_SILENT_RULES variable if it is defined. Older
+ versions of automake don't support this option.
+
+Signed-off-by: Chase Maupin <chase.maupin@ti.com>
+---
+ configure.ac | 3 ++-
+ 1 files changed, 2 insertions(+), 1 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 96da13b..9a58c51 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -26,7 +26,8 @@ AM_INIT_AUTOMAKE([-Wall -Werror ansi2knr no-dist foreign])
+ # Make --enable-silent-rules the default.
+ # To get verbose build output you may configure
+ # with --disable-silent-rules or use "make V=1".
+-AM_SILENT_RULES([yes])
++# only use if available
++m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
+
+ # This is required when using the de-ANSI-fication feature.
+ AM_C_PROTOTYPES
+--
+1.7.0.4
+
diff --git a/recipes/jpeg/jpeg_8b.bb b/recipes/jpeg/jpeg_8b.bb
index 4251ca6538..688dcd8db9 100644
--- a/recipes/jpeg/jpeg_8b.bb
+++ b/recipes/jpeg/jpeg_8b.bb
@@ -2,12 +2,15 @@ DESCRIPTION = "libjpeg is a library for handling the JPEG (JFIF) image format."
LICENSE = "jpeg"
SECTION = "libs"
PRIORITY = "required"
-PR = "r0"
+PR = "r1"
# TODO: really needed?
RPROVIDES_${PN} = "jpeg"
-SRC_URI = "http://www.ijg.org/files/jpegsrc.v${PV}.tar.gz"
+SRC_URI = "\
+ http://www.ijg.org/files/jpegsrc.v${PV}.tar.gz \
+ file://0001-configure-make-jpeg-work-with-older-autotools.patch \
+ "
S = "${WORKDIR}/jpeg-${PV}"
inherit autotools