summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2009-04-23 23:46:21 +0200
committerAndrea Adami <andrea.adami@gmail.com>2009-04-23 23:49:33 +0200
commitf822ec3f5a0820addc1025a132ae27fa43b11c9f (patch)
treef5a539dfed9fd46a17d2e23274ccb66f042ae6b2 /recipes
parent9ce2add5af0a4c21a6255b3fd235d99cb9722cf4 (diff)
downloadopenembedded-f822ec3f5a0820addc1025a132ae27fa43b11c9f.tar.gz
console-base-image,console-image,gnuradio-image: readd psplash-zap
- for distros without psplash keep the old behaviour and check 'screen'
Diffstat (limited to 'recipes')
-rw-r--r--recipes/images/console-base-image.bb8
-rw-r--r--recipes/images/console-image.bb8
-rw-r--r--recipes/images/gnuradio-image.bb8
3 files changed, 15 insertions, 9 deletions
diff --git a/recipes/images/console-base-image.bb b/recipes/images/console-base-image.bb
index 93391c6776..d25a4fc79e 100644
--- a/recipes/images/console-base-image.bb
+++ b/recipes/images/console-base-image.bb
@@ -4,18 +4,20 @@ IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
ANGSTROM_EXTRA_INSTALL ?= ""
-SPLASH ?= ' ${@base_contains("MACHINE_FEATURES", "screen", "psplash-zap", "",d)}'
+SPLASH ?= ""
+ZZAPSPLASH = ' ${@base_contains("MACHINE_FEATURES", "screen", "psplash-zap", "",d)}'
DEPENDS = "task-base \
${SPLASH} \
+ ${ZZAPSPLASH} \
"
IMAGE_INSTALL = "task-base \
${ANGSTROM_EXTRA_INSTALL} \
${SPLASH} \
- "
+ ${ZZAPSPLASH} \
+ "
IMAGE_LINGUAS = ""
inherit image
-
diff --git a/recipes/images/console-image.bb b/recipes/images/console-image.bb
index e30793b05f..9707881402 100644
--- a/recipes/images/console-image.bb
+++ b/recipes/images/console-image.bb
@@ -4,19 +4,21 @@ IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
ANGSTROM_EXTRA_INSTALL ?= ""
-SPLASH ?= ' ${@base_contains("MACHINE_FEATURES", "screen", "psplash-zap", "",d)}'
+SPLASH ?= ""
+ZZAPSPLASH = ' ${@base_contains("MACHINE_FEATURES", "screen", "psplash-zap", "",d)}'
DEPENDS = "task-base-extended \
${SPLASH} \
+ ${ZZAPSPLASH} \
"
IMAGE_INSTALL = "task-base-extended \
${ANGSTROM_EXTRA_INSTALL} \
${SPLASH} \
- "
+ ${ZZAPSPLASH} \
+ "
export IMAGE_BASENAME = "console-image"
IMAGE_LINGUAS = ""
inherit image
-
diff --git a/recipes/images/gnuradio-image.bb b/recipes/images/gnuradio-image.bb
index ce4f4997eb..53e79b8a1a 100644
--- a/recipes/images/gnuradio-image.bb
+++ b/recipes/images/gnuradio-image.bb
@@ -4,25 +4,27 @@ IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
IMAGE_EXTRA_INSTALL ?= ""
-SPLASH ?= ' ${@base_contains("MACHINE_FEATURES", "screen", "psplash-zap", "",d)}'
+SPLASH ?= ""
+ZZAPSPLASH = ' ${@base_contains("MACHINE_FEATURES", "screen", "psplash-zap", "",d)}'
DEPENDS = "task-base-extended \
${SPLASH} \
+ ${ZZAPSPLASH} \
"
IMAGE_INSTALL = "task-base-extended \
${IMAGE_EXTRA_INSTALL} \
${SPLASH} \
+ ${ZZAPSPLASH} \
oprofile \
screen \
ntp ntp-bin \
make \
nfs-utils-client \
gnuradio gnuradio-examples \
- "
+ "
export IMAGE_BASENAME = "gnuradio-image"
IMAGE_LINGUAS = ""
inherit image
-