aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2011-01-05 23:33:32 +0000
committerKoen Kooi <koen@openembedded.org>2011-01-06 16:43:56 +0100
commit11b6464b01541afeaedb07a51e1ed0c5bdad175e (patch)
tree982b63d318e35568884a59b3d754a49f218fa107 /recipes
parent77cc42b7c2b69fbb33411af2f8eb7bc67361941f (diff)
downloadopenembedded-11b6464b01541afeaedb07a51e1ed0c5bdad175e.tar.gz
mysql5-native: put make install to do_install after autotools_stage_all was removed with do_stage in eaf0fc03acfb262bcd614a14086a1b28ec850f46
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com> Signed-off-by: Koen Kooi <koen@openembedded.org>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/mysql/mysql5-native_5.1.40.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/recipes/mysql/mysql5-native_5.1.40.bb b/recipes/mysql/mysql5-native_5.1.40.bb
index 40d07ec88e..800178330b 100644
--- a/recipes/mysql/mysql5-native_5.1.40.bb
+++ b/recipes/mysql/mysql5-native_5.1.40.bb
@@ -12,6 +12,10 @@ EXTRA_OEMAKE = ""
EXTRA_OECONF = " --with-embedded-server "
do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+ mv -f ${D}${libdir}/mysql/* ${D}${libdir}
+ rmdir ${D}${libdir}/mysql
+
install -d ${D}${bindir}
install -m 0755 sql/gen_lex_hash ${D}${bindir}/
}