aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorChase Maupin <Chase.Maupin@ti.com>2011-01-07 05:39:45 +0000
committerKoen Kooi <koen@openembedded.org>2011-01-07 09:55:53 +0100
commitf3930609a879a14b75d4735f1cea125a39834213 (patch)
tree77e440fd193bc4f8d09eae4c0d7761ace6f08ccc /recipes
parente5bdccdf86d7fb24075fe039c307fbb4475a3e94 (diff)
downloadopenembedded-f3930609a879a14b75d4735f1cea125a39834213.tar.gz
ocf-linux: add recipe to stage ocf linux headers
* This recipe is used to stage ocf linux headers in the proper usr/include/crypto directory structure expected by packages such as openssl. Signed-off-by: Chase Maupin <Chase.Maupin@ti.com> Signed-off-by: Koen Kooi <koen@openembedded.org>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/openssl/ocf-linux.inc23
-rw-r--r--recipes/openssl/ocf-linux_20100325.bb6
2 files changed, 29 insertions, 0 deletions
diff --git a/recipes/openssl/ocf-linux.inc b/recipes/openssl/ocf-linux.inc
new file mode 100644
index 0000000000..9d8e08911c
--- /dev/null
+++ b/recipes/openssl/ocf-linux.inc
@@ -0,0 +1,23 @@
+DESCRIPTION = "Install required headers to enable OCF Linux support"
+LICENSE = "BSD"
+
+INC_PR = "r0"
+
+SRC_URI = "http://sourceforge.net/projects/ocf-linux/files/ocf-linux/${PV}/ocf-linux-${PV}.tar.gz"
+
+S = "${WORKDIR}/ocf-linux-${PV}"
+
+# Need to unpack the the ocf-linux.tar.gz file contained inside the
+# downloaded tarball
+do_install_prepend() {
+ cd ${S}
+ tar xzf ocf-linux.tar.gz
+}
+
+# Install the OCF Linux headers so that other packages such as openssl
+# can find them. The headers must be in a crypto directory according to
+# the README file.
+do_install() {
+ install -d ${D}${includedir}/crypto
+ install -m 0644 ${S}/ocf/*.h ${D}${includedir}/crypto/
+}
diff --git a/recipes/openssl/ocf-linux_20100325.bb b/recipes/openssl/ocf-linux_20100325.bb
new file mode 100644
index 0000000000..9dccc3c32f
--- /dev/null
+++ b/recipes/openssl/ocf-linux_20100325.bb
@@ -0,0 +1,6 @@
+require ocf-linux.inc
+
+PR = "${INC_PR}.0"
+
+SRC_URI[md5sum] = "ce5ad54aa94226d496df1f0f3cf0c11f"
+SRC_URI[sha256sum] = "9d17cbd13849939c70699b520280e3b94cf77401cdc131108d4aeaaeea587f6b"