aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2012-07-24 00:14:11 -0400
committerDenys Dmytriyenko <denys@ti.com>2012-07-24 00:14:11 -0400
commitd4f5768ba2b31e47973535b522cbc4e43f8170ce (patch)
tree0abf644874c0f8ffec853ca720e8e198c7777ce6 /recipes
parentf9611c025109a3e0d6cebf12f49ae24c97759c09 (diff)
downloadopenembedded-d4f5768ba2b31e47973535b522cbc4e43f8170ce.tar.gz
opkg-utils: bump SRCREV to pick up subprocess.check_output fixes
There were few breakages related to subprocess.check_output() with Python versions prior to 2.7 (although I had them even with 2.7.3), most notably in opkg-make-index: Log data follows: | + do_package_update_index_ipk | + set -x | + ipkgarchs='all any noarch arm armv4 armv4t armv5te armv6 armv7 armv7a am37x-evm' | + '[' '!' -z '' ']' | + mkdir -p /OE/deploy/glibc/ipk | + touch /OE/deploy/glibc/ipk/Packages | + opkg-make-index -r /OE/deploy/glibc/ipk/Packages -p /OE/deploy/glibc/ipk/Packages -l /OE/deploy/glibc/ipk/Packages.filelist -m /OE/deploy/glibc/ipk | Traceback (most recent call last): | File "/OE/sysroots/x86_64-linux/usr/bin/opkg-make-index", line 189, in <module> | rc = subprocess.check_output(gzip_cmd, shell=True) | AttributeError: 'module' object has no attribute 'check_output' NOTE: package my-image-1.0-r0: task do_package_update_index_ipk: Failed The following fixes are required: http://git.yoctoproject.org/cgit/cgit.cgi/opkg-utils/commit/?id=423ecd36b4782327c16f516885d1248249c7724a http://git.yoctoproject.org/cgit/cgit.cgi/opkg-utils/commit/?id=49cc783d8e0415059d126ae22c892988717ffda7 Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/opkg-utils/opkg-utils_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes/opkg-utils/opkg-utils_git.bb b/recipes/opkg-utils/opkg-utils_git.bb
index 997b292b57..a9c9803830 100644
--- a/recipes/opkg-utils/opkg-utils_git.bb
+++ b/recipes/opkg-utils/opkg-utils_git.bb
@@ -6,9 +6,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
file://opkg.py;beginline=1;endline=18;md5=15917491ad6bf7acc666ca5f7cc1e083"
RDEPENDS_${PN} = "python"
RDEPENDS_${PN}_virtclass-native = ""
-SRCREV = "44df9dd3dc411ca1255cb4b23bde7eb71aed4778"
+SRCREV = "49cc783d8e0415059d126ae22c892988717ffda7"
PV = "0.1.8+git${SRCPV}"
-PR = "r1"
+PR = "r2"
SRC_URI = "git://git.yoctoproject.org/opkg-utils;protocol=git \
"