aboutsummaryrefslogtreecommitdiffstats
path: root/rxvt-unicode
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2004-03-13 08:26:04 +0000
committerChris Larson <clarson@kergoth.com>2004-03-13 08:26:04 +0000
commit113e9f87ad0dcb2a5c7d71cadfdba93fe2ef92e3 (patch)
treee8f66c90bbf5fd25e373992147282f48d9d0619f /rxvt-unicode
parent06f7d17e81de21a95e35b03453242bc62b05a6aa (diff)
downloadopenembedded-113e9f87ad0dcb2a5c7d71cadfdba93fe2ef92e3.tar.gz
Add a ton of missing package DESCRIPTION fields.
BKrev: 4052c59c7bolGgKg0fqnaHTjcsYRWQ
Diffstat (limited to 'rxvt-unicode')
-rw-r--r--rxvt-unicode/rxvt-unicode_1.9.oe54
-rw-r--r--rxvt-unicode/rxvt-unicode_2.2.oe53
2 files changed, 107 insertions, 0 deletions
diff --git a/rxvt-unicode/rxvt-unicode_1.9.oe b/rxvt-unicode/rxvt-unicode_1.9.oe
index e69de29bb2..72660d60ea 100644
--- a/rxvt-unicode/rxvt-unicode_1.9.oe
+++ b/rxvt-unicode/rxvt-unicode_1.9.oe
@@ -0,0 +1,54 @@
+DEPENDS = 'virtual/libc x11 xft'
+RDEPENDS = "libc6 x11 xft"
+DESCRIPTION = "rxvt-unicode is a clone of the well known \
+terminal emulator rxvt, modified to store text in Unicode \
+(either UCS-2 or UCS-4) and to use locale-correct input and \
+output. It also supports mixing multiple fonts at the \
+same time, including Xft fonts."
+
+SRC_URI = '${SOURCEFORGE_MIRROR}/rxvt-unicode/rxvt-unicode-${PV}.tar.bz2 \
+ file://${FILESDIR}/xim.patch;patch=1 \
+ file://${FILESDIR}/include.patch;patch=1'
+
+inherit autotools libtool
+
+EXTRA_OECONF = '--disable-menubar \
+ --enable-ttygid \
+ --with-term=rxvt \
+ --enable-transparency \
+ --disable-xim \
+ --with-x=${STAGING_LIBDIR}/.. \
+ --enable-shared \
+ --disable-static \
+ --enable-xft'
+EXTRA_OEMAKE = "'XINC=-I${STAGING_INCDIR}' \
+ 'XLIB=-L${STAGING_LIBDIR} -lX11'"
+#CFLAGS_append = ' -I${S}/W11'
+#CPPFLAGS_append = '-I${S}/W11'
+
+do_configure () {
+ if test -e ${STAGING_BINDIR}/${HOST_SYS}-libtool; then
+ STAGING_DIR=${STAGING_DIR} \
+ ${HOST_SYS}-libtoolize -c -f
+ fi
+ ./reconf
+ oe_runconf
+ cat >>config.h <<EOF
+#define RXVT_UTMP_FILE "/var/run/utmp"
+/* #undef RXVT_UTMPX_FILE */
+#define RXVT_WTMP_FILE "/var/log/wtmp"
+/* #undef RXVT_WTMPX_FILE */
+#define RXVT_LASTLOG_FILE "/var/log/lastlog"
+/* #undef RXVT_LASTLOGX_FILE */
+#define HAVE_XLOCALE 1
+EOF
+}
+
+do_compile () {
+ if test -e ${S}/${HOST_SYS}-libtool; then
+ LIBTOOL=${S}/${HOST_SYS}-libtool
+ else
+ LIBTOOL=${S}/libtool
+ fi
+ oe_runmake "LIBTOOL=$LIBTOOL"
+}
diff --git a/rxvt-unicode/rxvt-unicode_2.2.oe b/rxvt-unicode/rxvt-unicode_2.2.oe
index e69de29bb2..92f500e5da 100644
--- a/rxvt-unicode/rxvt-unicode_2.2.oe
+++ b/rxvt-unicode/rxvt-unicode_2.2.oe
@@ -0,0 +1,53 @@
+DEPENDS = 'virtual/libc x11 xft'
+RDEPENDS = "libc6 x11 xft"
+DESCRIPTION = "rxvt-unicode is a clone of the well known \
+terminal emulator rxvt, modified to store text in Unicode \
+(either UCS-2 or UCS-4) and to use locale-correct input and \
+output. It also supports mixing multiple fonts at the \
+same time, including Xft fonts."
+
+SRC_URI = '${SOURCEFORGE_MIRROR}/rxvt-unicode/rxvt-unicode-${PV}.tar.bz2 \
+ file://${FILESDIR}/include.patch;patch=1'
+
+inherit autotools libtool
+
+#EXTRA_OECONF = '--enable-utmp --enable-wtmp --enable-lastlog \
+# --disable-strings --with-term=rxvt --enable-keepscrolling \
+# --enable-xft --with-name=rxvt --enable-frills \
+# --enable-swapscreen --enable-transparency \
+# --with-codesets=eu,jp --enable-menubar \
+# --enable-cursor-blink --enable-pointer-blank \
+# --enable-text-blink --enable-plain-scroll \
+# --with-x=${STAGING_LIBDIR}/.. \
+# --enable-combining'
+
+EXTRA_OECONF = '--disable-menubar --disable-xim \
+ --enable-utmp --enable-wtmp --enable-lastlog \
+ --disable-strings --with-term=rxvt --enable-keepscrolling \
+ --enable-xft --with-name=rxvt --enable-frills \
+ --enable-swapscreen --enable-transparency \
+ --with-codesets=eu,jp \
+ --enable-cursor-blink --enable-pointer-blank \
+ --enable-text-blink --enable-plain-scroll \
+ --enable-combining \
+ --with-x=${STAGING_LIBDIR}/..'
+EXTRA_OEMAKE = "'XINC=-I${STAGING_INCDIR}' \
+ 'XLIB=-L${STAGING_LIBDIR} -lX11'"
+
+do_configure () {
+ mv autoconf/configure.in configure.in
+ autotools_do_configure
+ echo '#define RXVT_UTMP_FILE "${localstatedir}/run/utmp"' >> config.h
+ echo '#define RXVT_WTMP_FILE "${localstatedir}/log/wtmp"' >> config.h
+ echo '#define RXVT_LASTLOG_FILE "${localstatedir}/log/lastlog"' >> config.h
+ echo '#define HAVE_XLOCALE 1' >> config.h
+}
+
+do_compile () {
+ if test -e ${S}/${HOST_SYS}-libtool; then
+ LIBTOOL=${S}/${HOST_SYS}-libtool
+ else
+ LIBTOOL=${S}/libtool
+ fi
+ oe_runmake "LIBTOOL=$LIBTOOL"
+}