aboutsummaryrefslogtreecommitdiffstats
path: root/sqlite
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2004-11-09 00:36:47 +0000
committerChris Larson <clarson@kergoth.com>2004-11-09 00:36:47 +0000
commitf96441b9faf769c9ecdd4d338b605ea3d0cc4010 (patch)
treeedb17ec2c4ea13c5acb1c7350957a249a820e28d /sqlite
parentb6588aa6851fb220cedc387d21c51513ef8d67f4 (diff)
downloadopenembedded-f96441b9faf769c9ecdd4d338b605ea3d0cc4010.tar.gz
Disable bk EOLN_NATIVE conversions on all files in packages FILESPATHs, to prevent it screwing up patches.
BKrev: 4190111fA4MuVozAqwE7xOSL9fr-TA
Diffstat (limited to 'sqlite')
-rw-r--r--sqlite/sqlite-2.8.9/crosscompile.patch147
-rw-r--r--sqlite/sqlite3-3.0.8/cross-compile.patch109
2 files changed, 256 insertions, 0 deletions
diff --git a/sqlite/sqlite-2.8.9/crosscompile.patch b/sqlite/sqlite-2.8.9/crosscompile.patch
index e69de29bb2..8c334a78e8 100644
--- a/sqlite/sqlite-2.8.9/crosscompile.patch
+++ b/sqlite/sqlite-2.8.9/crosscompile.patch
@@ -0,0 +1,147 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- sqlite/configure.ac~crosscompile 2003-12-22 15:29:33.000000000 +0100
++++ sqlite/configure.ac 2004-01-14 01:03:08.000000000 +0100
+@@ -202,10 +202,10 @@
+ default_build_cflags="-g"
+ if test "$config_BUILD_CC" = ""; then
+ AC_PROG_CC
+- if test "$cross_compiling" = "yes"; then
+- AC_MSG_ERROR([unable to find a compiler for building build tools])
+- fi
+- BUILD_CC=$CC
++# if test "$cross_compiling" = "yes"; then
++# AC_MSG_ERROR([unable to find a compiler for building build tools])
++# fi
++ BUILD_CC=gcc
+ default_build_cflags=$CFLAGS
+ else
+ BUILD_CC=$config_BUILD_CC
+@@ -417,120 +417,14 @@
+ fi
+ AC_SUBST(TARGET_LIBS)
+
+-##########
+-# Figure out what C libraries are required to compile Tcl programs.
+-#
+-if test "$config_TARGET_TCL_LIBS" != ""; then
+- TARGET_TCL_LIBS="$config_TARGET_TCL_LIBS"
+-else
+- if test "$with_tcl" != ""; then
+- extra=`echo $with_tcl/$tclsubdir/libtcl8*.a`
+- fi
+- CC=$TARGET_CC
+- AC_CHECK_FUNC(sin, LIBS="", LIBS="-lm")
+- AC_CHECK_LIB(dl, dlopen)
+- otherlibs=$LIBS
+- if test "$extra" != ""; then
+- LIBS=$extra
+- else
+- LIBS=""
+- AC_SEARCH_LIBS(Tcl_Init, dnl
+- tcl8.4 tcl8.3 tcl84 tcl83 tcl,,,$otherlibs)
+- fi
+- TARGET_TCL_LIBS="$LIBS $otherlibs"
+-fi
+-AC_SUBST(TARGET_TCL_LIBS)
+-
+-##########
+-# Figure out where to get the TCL header files.
+-#
+-AC_MSG_CHECKING([TCL header files])
+-found=no
+-if test "$config_TARGET_TCL_INC" != ""; then
+- TARGET_TCL_INC=$config_TARGET_TCL_INC
+- found=yes
+-else
+- if test "$with_tcl" != ""; then
+- TARGET_TCL_INC="-I$with_tcl/generic -I$with_tcl/$tclsubdir"
+- found=yes
+- else
+- TARGET_TCL_INC=""
+- found=no
+- fi
+-fi
+-if test "$found" = "yes"; then
+- AC_MSG_RESULT($TARGET_TCL_INC)
+-else
+- AC_MSG_RESULT(not specified: still searching...)
+- AC_CHECK_HEADER(tcl.h, [found=yes])
+-fi
+-if test "$found" = "no"; then
+- for dir in /usr/local /usr/X11 /usr/X11R6 /usr/pkg /usr/contrib /usr; do
+- AC_CHECK_FILE($dir/include/tcl.h, found=yes)
+- if test "$found" = "yes"; then
+- TARGET_TCL_INC="-I$dir/include"
+- break
+- fi
+- done
+-fi
+-if test "$found" = "no"; then
+- TARGET_TCL_INC="-DNO_TCL=1"
+-fi
++TARGET_TCL_INC="-DNO_TCL=1"
+ AC_SUBST(TARGET_TCL_INC)
+
+-##########
+-# Figure out what C libraries are required to compile programs
+-# that use "readline()" library.
+-#
+-if test "$config_TARGET_READLINE_LIBS" != ""; then
+- TARGET_READLINE_LIBS="$config_TARGET_READLINE_LIBS"
+-else
+- CC=$TARGET_CC
+- LIBS=""
+- AC_SEARCH_LIBS(tgetent, [readline ncurses curses termcap])
+- AC_CHECK_LIB([readline], [readline])
+- TARGET_READLINE_LIBS="$LIBS"
+-fi
++TARGET_READLINE_LIBS="-lreadline"
+ AC_SUBST(TARGET_READLINE_LIBS)
+
+-##########
+-# Figure out where to get the READLINE header files.
+-#
+-AC_MSG_CHECKING([readline header files])
+-found=no
+-if test "$config_TARGET_READLINE_INC" != ""; then
+- TARGET_READLINE_INC=$config_TARGET_READLINE_INC
+- found=yes
+-fi
+-if test "$found" = "yes"; then
+- AC_MSG_RESULT($TARGET_READLINE_INC)
+-else
+- AC_MSG_RESULT(not specified: still searching...)
+- AC_CHECK_HEADER(readline.h, [found=yes])
+-fi
+-if test "$found" = "no"; then
+- for dir in /usr /usr/local /usr/local/readline /usr/contrib /mingw; do
+- AC_CHECK_FILE($dir/include/readline.h, found=yes)
+- if test "$found" = "yes"; then
+- TARGET_READLINE_INC="-I$dir/include"
+- break
+- fi
+- AC_CHECK_FILE($dir/include/readline/readline.h, found=yes)
+- if test "$found" = "yes"; then
+- TARGET_READLINE_INC="-I$dir/include/readline"
+- break
+- fi
+- done
+-fi
+-if test "$found" = "yes"; then
+- if test "$TARGET_READLINE_LIBS" = ""; then
+- TARGET_HAVE_READLINE=0
+- else
+- TARGET_HAVE_READLINE=1
+- fi
+-else
+- TARGET_HAVE_READLINE=0
+-fi
++TARGET_HAVE_READLINE=1
++TARGET_READLINE_INC=""
+ AC_SUBST(TARGET_READLINE_INC)
+ AC_SUBST(TARGET_HAVE_READLINE)
+
diff --git a/sqlite/sqlite3-3.0.8/cross-compile.patch b/sqlite/sqlite3-3.0.8/cross-compile.patch
index e69de29bb2..36afa8e70b 100644
--- a/sqlite/sqlite3-3.0.8/cross-compile.patch
+++ b/sqlite/sqlite3-3.0.8/cross-compile.patch
@@ -0,0 +1,109 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- sqlite/configure.ac~cross-compile
++++ sqlite/configure.ac
+@@ -202,10 +202,11 @@
+ default_build_cflags="-g"
+ if test "$config_BUILD_CC" = ""; then
+ AC_PROG_CC
+- if test "$cross_compiling" = "yes"; then
+- AC_MSG_ERROR([unable to find a compiler for building build tools])
+- fi
+- BUILD_CC=$CC
++# if test "$cross_compiling" = "yes"; then
++# AC_MSG_ERROR([unable to find a compiler for building build tools])
++# fi
++# BUILD_CC=$CC
++ BUILD_CC=gcc
+ default_build_cflags=$CFLAGS
+ else
+ BUILD_CC=$config_BUILD_CC
+@@ -412,25 +413,7 @@
+ ##########
+ # Figure out what C libraries are required to compile Tcl programs.
+ #
+-if test "$config_TARGET_TCL_LIBS" != ""; then
+- TARGET_TCL_LIBS="$config_TARGET_TCL_LIBS"
+-else
+- if test "$with_tcl" != ""; then
+- extra=`echo $with_tcl/$tclsubdir/libtcl8*.a`
+- fi
+- CC=$TARGET_CC
+- AC_CHECK_FUNC(sin, LIBS="", LIBS="-lm")
+- AC_CHECK_LIB(dl, dlopen)
+- otherlibs=$LIBS
+- if test "$extra" != ""; then
+- LIBS=$extra
+- else
+- LIBS=""
+- AC_SEARCH_LIBS(Tcl_Init, dnl
+- tcl8.4 tcl8.3 tcl84 tcl83 tcl,,,$otherlibs)
+- fi
+- TARGET_TCL_LIBS="$LIBS $otherlibs"
+-fi
++TARGET_TCL_INC="-DNO_TCL=1"
+ AC_SUBST(TARGET_TCL_LIBS)
+
+ ##########
+@@ -474,55 +457,14 @@
+ # Figure out what C libraries are required to compile programs
+ # that use "readline()" library.
+ #
+-if test "$config_TARGET_READLINE_LIBS" != ""; then
+- TARGET_READLINE_LIBS="$config_TARGET_READLINE_LIBS"
+-else
+- CC=$TARGET_CC
+- LIBS=""
+- AC_SEARCH_LIBS(tgetent, [readline ncurses curses termcap])
+- AC_CHECK_LIB([readline], [readline])
+- TARGET_READLINE_LIBS="$LIBS"
+-fi
++TARGET_READLINE_LIBS="-lreadline"
+ AC_SUBST(TARGET_READLINE_LIBS)
+
+ ##########
+ # Figure out where to get the READLINE header files.
+ #
+-AC_MSG_CHECKING([readline header files])
+-found=no
+-if test "$config_TARGET_READLINE_INC" != ""; then
+- TARGET_READLINE_INC=$config_TARGET_READLINE_INC
+- found=yes
+-fi
+-if test "$found" = "yes"; then
+- AC_MSG_RESULT($TARGET_READLINE_INC)
+-else
+- AC_MSG_RESULT(not specified: still searching...)
+- AC_CHECK_HEADER(readline.h, [found=yes])
+-fi
+-if test "$found" = "no"; then
+- for dir in /usr /usr/local /usr/local/readline /usr/contrib /mingw; do
+- AC_CHECK_FILE($dir/include/readline.h, found=yes)
+- if test "$found" = "yes"; then
+- TARGET_READLINE_INC="-I$dir/include"
+- break
+- fi
+- AC_CHECK_FILE($dir/include/readline/readline.h, found=yes)
+- if test "$found" = "yes"; then
+- TARGET_READLINE_INC="-I$dir/include/readline"
+- break
+- fi
+- done
+-fi
+-if test "$found" = "yes"; then
+- if test "$TARGET_READLINE_LIBS" = ""; then
+- TARGET_HAVE_READLINE=0
+- else
+- TARGET_HAVE_READLINE=1
+- fi
+-else
+- TARGET_HAVE_READLINE=0
+-fi
++TARGET_READLINE_INC=""
++TARGET_HAVE_READLINE=1
+ AC_SUBST(TARGET_READLINE_INC)
+ AC_SUBST(TARGET_HAVE_READLINE)
+