aboutsummaryrefslogtreecommitdiffstats
path: root/tin
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2004-01-14 18:09:46 +0000
committerChris Larson <clarson@kergoth.com>2004-01-14 18:09:46 +0000
commit8d1e9a91e2ec47698dfdabb85a696c24663f29d3 (patch)
tree616d0e1c6e5f1d43bfac2d9933a454d6ea852914 /tin
parent5cd6f5021a4ad3df5c02e266b524f47003b47486 (diff)
downloadopenembedded-8d1e9a91e2ec47698dfdabb85a696c24663f29d3.tar.gz
Merge openembedded@openembedded.bkbits.net:packages
into direwolf.itg.ti.com:/home/kergoth/coding/projects/user/oe-metadata/packages 2004/01/14 12:08:55-06:00 ti.com!kergoth BUGFIX: tin: Add necessary m4 macros, fix a few macros in configure.in, and fix a bug with the build of the native makecfg binary. BKrev: 400585eaBtEHWA3N0cj03DodaYKl4w
Diffstat (limited to 'tin')
-rw-r--r--tin/tin-1.7.3/configure.patch0
-rw-r--r--tin/tin-1.7.3/m4.patch0
-rw-r--r--tin/tin-1.7.3/makecfg-buildcc.patch24
-rw-r--r--tin/tin_1.7.3.oe19
4 files changed, 43 insertions, 0 deletions
diff --git a/tin/tin-1.7.3/configure.patch b/tin/tin-1.7.3/configure.patch
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/tin/tin-1.7.3/configure.patch
diff --git a/tin/tin-1.7.3/m4.patch b/tin/tin-1.7.3/m4.patch
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/tin/tin-1.7.3/m4.patch
diff --git a/tin/tin-1.7.3/makecfg-buildcc.patch b/tin/tin-1.7.3/makecfg-buildcc.patch
index e69de29bb2..2b3dba44f9 100644
--- a/tin/tin-1.7.3/makecfg-buildcc.patch
+++ b/tin/tin-1.7.3/makecfg-buildcc.patch
@@ -0,0 +1,24 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- tin-1.7.3/src/Makefile.in~makecfg-buildcc
++++ tin-1.7.3/src/Makefile.in
+@@ -462,7 +462,7 @@
+ ./makecfg $(SRCDIR)/tincfg.tbl tincfg.h
+
+ makecfg$(EXEEXT): $(OBJDIR)/makecfg.o
+- $(LD) $(LDFLAGS) -o $@ $(OBJDIR)/makecfg.o @LIBS@
++ $(BUILD_CC) $(BUILD_LDFLAGS) -o $@ $(OBJDIR)/makecfg.o
+
+ $(OBJDIR)/active.o: $(SRCDIR)/active.c $(TIN_DEP)
+ $(OBJDIR)/art.o: $(SRCDIR)/art.c $(TIN_DEP) \
+@@ -519,6 +519,7 @@
+ $(OBJDIR)/main.o: $(SRCDIR)/main.c $(TIN_DEP) \
+ $(INCDIR)/version.h
+ $(OBJDIR)/makecfg.o: $(SRCDIR)/makecfg.c $(TIN_DEP)
++ $(BUILD_CC) $(BUILD_CFLAGS) -c -I../include -I../pcre -o $@ $(SRCDIR)/makecfg.c
+ $(OBJDIR)/memory.o: $(SRCDIR)/memory.c $(TIN_DEP) \
+ $(INCDIR)/rfc2046.h
+ $(OBJDIR)/mimetypes.o: $(SRCDIR)/mimetypes.c $(TIN_DEP)
diff --git a/tin/tin_1.7.3.oe b/tin/tin_1.7.3.oe
index e69de29bb2..254704a278 100644
--- a/tin/tin_1.7.3.oe
+++ b/tin/tin_1.7.3.oe
@@ -0,0 +1,19 @@
+SECTION="libs"
+PRIORITY="optional"
+RDEPENDS="libc6 libncurses5"
+DEPENDS=virtual/libc ncurses
+
+SRC_URI=ftp://ftp.tin.org/pub/news/clients/tin/unstable/tin-${PV}.tar.gz \
+ file://${FILESDIR}/makecfg-buildcc.patch;patch=1 \
+ file://${FILESDIR}/m4.patch;patch=1 \
+ file://${FILESDIR}/configure.patch;patch=1
+
+inherit autotools libtool
+
+EXTRA_OECONF = '--with-screen=ncurses'
+
+do_compile () {
+ ${BUILD_CC} -DLINK_SIZE=2 -I${S}/include -c pcre/dftables.c
+ ${BUILD_CC} dftables.o -o pcre/dftables
+ oe_runmake build
+}