aboutsummaryrefslogtreecommitdiffstats
path: root/xauth
diff options
context:
space:
mode:
authorRene Wagner <rw@handhelds.org>2004-08-14 22:08:42 +0000
committerRene Wagner <rw@handhelds.org>2004-08-14 22:08:42 +0000
commit1fd33f550ba1db03e7199c170569e7e75a427678 (patch)
treec055639aefcdf1b0928ddf815e1f415131bda320 /xauth
parente1066c573c0207def3dd1a3964b6a2e839d262a7 (diff)
downloadopenembedded-1fd33f550ba1db03e7199c170569e7e75a427678.tar.gz
Merge bk://openembedded@openembedded.bkbits.net/packages
into sugarcube.dyndns.org:/home/oe/oe/packages 2004/08/15 00:07:55+02:00 dyndns.org!reenoo xauth: add a few missing autotools bits, so that unix and tcp support works and the correct type for signals is used BKrev: 411e8d6aUH_-ZzG16BO7sUYw4tAInw
Diffstat (limited to 'xauth')
-rw-r--r--xauth/xauth/autofoo.patch241
1 files changed, 241 insertions, 0 deletions
diff --git a/xauth/xauth/autofoo.patch b/xauth/xauth/autofoo.patch
index e69de29bb2..ab3b36277b 100644
--- a/xauth/xauth/autofoo.patch
+++ b/xauth/xauth/autofoo.patch
@@ -0,0 +1,241 @@
+diff -urN xauth.orig/Imakefile xauth/Imakefile
+--- xauth.orig/Imakefile 2004-04-23 21:54:38.000000000 +0200
++++ xauth/Imakefile 1970-01-01 01:00:00.000000000 +0100
+@@ -1,19 +0,0 @@
+-XCOMM $Xorg: Imakefile,v 1.3 2000/08/17 19:54:11 cpqbld Exp $
+-
+-
+-
+-
+-XCOMM $XFree86: xc/programs/xauth/Imakefile,v 3.5tsi Exp $
+-
+- DEPLIBS = $(DEPXAUTHLIB) $(DEPXMUULIB) $(DEPXLIB)
+-LOCAL_LIBRARIES = $(XAUTHLIB) $(XMUULIB) $(XLIB)
+- SRCS = xauth.c gethost.c process.c parsedpy.c
+- OBJS = xauth.o gethost.o process.o parsedpy.o
+- CONN_DEFINES = $(CONNECTION_FLAGS)
+- DEPEND_DEFINES = $(CONN_DEFINES) $(SIGNAL_DEFINES)
+-
+-ComplexProgramTarget(xauth)
+-
+-SpecialCObjectRule(gethost,$(ICONFIGFILES),$(CONN_DEFINES) $(SIGNAL_DEFINES))
+-SpecialCObjectRule(process,$(ICONFIGFILES),$(CONN_DEFINES) $(SIGNAL_DEFINES))
+-SpecialCObjectRule(parsedpy,$(ICONFIGFILES),$(CONN_DEFINES))
+diff -urN xauth.orig/Makefile.am xauth/Makefile.am
+--- xauth.orig/Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ xauth/Makefile.am 2004-08-14 13:20:37.000000000 +0200
+@@ -0,0 +1,53 @@
++#
++# $Id$
++#
++# Copyright © 2003 Keith Packard
++#
++# Permission to use, copy, modify, distribute, and sell this software and its
++# documentation for any purpose is hereby granted without fee, provided that
++# the above copyright notice appear in all copies and that both that
++# copyright notice and this permission notice appear in supporting
++# documentation, and that the name of Keith Packard not be used in
++# advertising or publicity pertaining to distribution of the software without
++# specific, written prior permission. Keith Packard makes no
++# representations about the suitability of this software for any purpose. It
++# is provided "as is" without express or implied warranty.
++#
++# KEITH PACKARD DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
++# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
++# EVENT SHALL KEITH PACKARD BE LIABLE FOR ANY SPECIAL, INDIRECT OR
++# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
++# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
++# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
++# PERFORMANCE OF THIS SOFTWARE.
++#
++
++AUTOMAKE_OPTIONS = 1.7 foreign
++
++AM_CFLAGS = @XAUTH_CFLAGS@
++
++bin_PROGRAMS = xauth
++
++xauth_SOURCES = gethost.c parsedpy.c process.c xauth.c xauth.h
++
++xauth_LDADD = @XAUTH_LIBS@
++
++man5_MANS=xauth.man
++
++EXTRA_DIST= $(man5_MANS)
++
++MAINTAINERCLEANFILES = configure \
++config.guess \
++config.sub \
++install-sh \
++ltmain.sh \
++missing \
++mkinstalldirs \
++aclocal.m4 \
++Makefile.in \
++depcomp \
++autoscan.log \
++configure.scan \
++config.h \
++config.h.in \
++$(man5_MANS)
+diff -urN xauth.orig/autogen.sh xauth/autogen.sh
+--- xauth.orig/autogen.sh 1970-01-01 01:00:00.000000000 +0100
++++ xauth/autogen.sh 2004-08-14 13:15:46.000000000 +0200
+@@ -0,0 +1,3 @@
++#! /bin/sh
++autoreconf -v --install || exit 1
++./configure --enable-maintainer-mode "$@"
+diff -urN xauth.orig/configure.ac xauth/configure.ac
+--- xauth.orig/configure.ac 1970-01-01 01:00:00.000000000 +0100
++++ xauth/configure.ac 2004-08-14 23:43:54.000000000 +0200
+@@ -0,0 +1,57 @@
++dnl
++dnl $Id$
++dnl
++dnl Copyright © 2003 Keith Packard
++dnl
++dnl Permission to use, copy, modify, distribute, and sell this software and its
++dnl documentation for any purpose is hereby granted without fee, provided that
++dnl the above copyright notice appear in all copies and that both that
++dnl copyright notice and this permission notice appear in supporting
++dnl documentation, and that the name of Keith Packard not be used in
++dnl advertising or publicity pertaining to distribution of the software without
++dnl specific, written prior permission. Keith Packard makes no
++dnl representations about the suitability of this software for any purpose. It
++dnl is provided "as is" without express or implied warranty.
++dnl
++dnl KEITH PACKARD DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
++dnl INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
++dnl EVENT SHALL KEITH PACKARD BE LIABLE FOR ANY SPECIAL, INDIRECT OR
++dnl CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
++dnl DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
++dnl TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
++dnl PERFORMANCE OF THIS SOFTWARE.
++dnl
++
++AC_PREREQ(2.57)
++AC_INIT([xauth],4.4.0,[],xauth)
++AC_CONFIG_SRCDIR([Makefile.am])
++AM_INIT_AUTOMAKE([dist-bzip2])
++AM_MAINTAINER_MODE
++AM_CONFIG_HEADER(config.h)
++
++AC_PROG_CC
++AC_PROG_INSTALL
++AC_PROG_LN_S
++AC_LIBTOOL_WIN32_DLL
++AM_PROG_LIBTOOL
++AC_PROG_MAKE_SET
++
++PKG_CHECK_MODULES(XAUTH, xau xext xmu x11)
++
++AC_TYPE_SIGNAL
++
++# Transport selection
++AC_ARG_ENABLE(unix-transport,[ --disable-unix-transport ], [UNIXCONN=$enableval], [UNIXCONN=yes])
++AC_ARG_ENABLE(tcp-transport, [ --disable-tcp-transport ], [TCPCONN=$enableval], [TCPCONN=yes])
++AC_ARG_ENABLE(ipv6, [ --disable-ipv6 ], [IPV6CONN=$enableval], [IPV6CONN=yes])
++if test "$UNIXCONN" = "yes"; then
++ AC_DEFINE(UNIXCONN,1,[Support UNIX socket connections])
++fi
++if test "$TCPCONN" = "yes"; then
++ AC_DEFINE(TCPCONN,1,[Support TCP socket connections])
++fi
++if test "$IPV6CONN" = "yes"; then
++ AC_DEFINE(IPv6,1,[Support IPv6 for TCP connections])
++fi
++
++AC_OUTPUT([Makefile])
+diff -urN xauth.orig/gethost.c xauth/gethost.c
+--- xauth.orig/gethost.c 2004-04-23 21:54:38.000000000 +0200
++++ xauth/gethost.c 2004-08-14 23:55:45.000000000 +0200
+@@ -28,6 +28,10 @@
+
+ /* $XFree86: xc/programs/xauth/gethost.c,v 3.20 2003/07/27 12:34:25 herrb Exp $ */
+
++#ifdef HAVE_CONFIG_H
++#include "config.h"
++#endif
++
+ /* sorry, streams support does not really work yet */
+ #if defined(STREAMSCONN) && defined(SVR4)
+ #undef STREAMSCONN
+@@ -89,17 +93,13 @@
+
+ static jmp_buf env;
+ static
+-#ifdef SIGNALRETURNSINT
+-int
+-#else
+-void
+-#endif
++RETSIGTYPE
+ nameserver_lost(int sig)
+ {
+ nameserver_timedout = True;
+ longjmp (env, -1);
+ /* NOTREACHED */
+-#ifdef SIGNALRETURNSINT
++#if (RETSIGTYPE == int)
+ return -1; /* for picky compilers */
+ #endif
+ }
+diff -urN xauth.orig/parsedpy.c xauth/parsedpy.c
+--- xauth.orig/parsedpy.c 2004-04-23 21:54:38.000000000 +0200
++++ xauth/parsedpy.c 2004-08-14 23:55:01.000000000 +0200
+@@ -31,6 +31,10 @@
+
+ /* $XFree86: xc/programs/xauth/parsedpy.c,v 3.7 2003/07/09 15:27:37 tsi Exp $ */
+
++#ifdef HAVE_CONFIG_H
++#include "config.h"
++#endif
++
+ #include <stdio.h> /* for NULL */
+ #include <ctype.h> /* for isascii() and isdigit() */
+ #include <X11/Xos.h> /* for strchr() and string routines */
+diff -urN xauth.orig/process.c xauth/process.c
+--- xauth.orig/process.c 2004-04-25 01:26:55.000000000 +0200
++++ xauth/process.c 2004-08-14 23:55:25.000000000 +0200
+@@ -33,6 +33,10 @@
+ * Author: Jim Fulton, MIT X Consortium
+ */
+
++#ifdef HAVE_CONFIG_H
++#include "config.h"
++#endif
++
+ #include "xauth.h"
+ #include <ctype.h>
+ #include <errno.h>
+@@ -626,11 +630,7 @@
+ static char *xauth_filename = NULL;
+ static volatile Bool dieing = False;
+
+-#ifdef SIGNALRETURNSINT
+-#define _signal_t int
+-#else
+-#define _signal_t void
+-#endif
++#define _signal_t RETSIGTYPE
+
+ /* poor man's puts(), for under signal handlers */
+ #define WRITES(fd, S) (void)write((fd), (S), strlen((S)))
+@@ -642,7 +642,7 @@
+ dieing = True;
+ _exit (auth_finalize ());
+ /* NOTREACHED */
+-#ifdef SIGNALRETURNSINT
++#if (RETSIGTYPE == int)
+ return -1; /* for picky compilers */
+ #endif
+ }
+@@ -664,7 +664,7 @@
+ #endif
+ die (sig);
+ /* NOTREACHED */
+-#ifdef SIGNALRETURNSINT
++#if (RETSIGTYPE == int)
+ return -1; /* for picky compilers */
+ #endif
+ }