aboutsummaryrefslogtreecommitdiffstats
path: root/xset
diff options
context:
space:
mode:
authorRene Wagner <rw@handhelds.org>2004-08-17 12:28:06 +0000
committerRene Wagner <rw@handhelds.org>2004-08-17 12:28:06 +0000
commit10e66db03ddf82c79a57f0c2f381bc27db49e1e0 (patch)
tree9ee37424f2613e8d6e75af198175bfe12ea2310d /xset
parent3700e38b3af1cdeb483f55e8f006de3ba29f91e8 (diff)
downloadopenembedded-10e66db03ddf82c79a57f0c2f381bc27db49e1e0.tar.gz
xset: set to a fixed CVSDATE; libxp not necessary as of 20040817
BKrev: 4121f9d6amGqGPGGZ-5r_dvEP_LA7g
Diffstat (limited to 'xset')
-rw-r--r--xset/xset/autofoo.patch120
-rw-r--r--xset/xset_20040817.oe (renamed from xset/xset_cvs.oe)0
2 files changed, 120 insertions, 0 deletions
diff --git a/xset/xset/autofoo.patch b/xset/xset/autofoo.patch
index e69de29bb2..1c36df8eae 100644
--- a/xset/xset/autofoo.patch
+++ b/xset/xset/autofoo.patch
@@ -0,0 +1,120 @@
+diff -urN xset.orig/CVS/Entries xset/CVS/Entries
+--- xset.orig/CVS/Entries 2004-08-17 14:13:26.000000000 +0200
++++ xset/CVS/Entries 2004-08-17 14:13:55.000000000 +0200
+@@ -1,4 +1,4 @@
+-/Imakefile/1.4/Tue Aug 17 12:13:26 2004//
+-/xset.c/1.4/Tue Aug 17 12:13:26 2004//
+-/xset.man/1.3/Tue Aug 17 12:13:26 2004//
++/Imakefile/1.4/Tue Aug 17 12:13:55 2004//
++/xset.c/1.4/Tue Aug 17 12:13:55 2004//
++/xset.man/1.3/Tue Aug 17 12:13:55 2004//
+ D
+diff -urN xset.orig/Makefile.am xset/Makefile.am
+--- xset.orig/Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ xset/Makefile.am 2004-08-14 16:32:10.000000000 +0200
+@@ -0,0 +1,53 @@
++#
++# $Id$
++#
++# Copyright © 2003 Keith Packard
++#
++# Permission to use, copy, modify, distribute, and sell this software and its
++# documentation for any purpose is hereby granted without fee, provided that
++# the above copyright notice appear in all copies and that both that
++# copyright notice and this permission notice appear in supporting
++# documentation, and that the name of Keith Packard not be used in
++# advertising or publicity pertaining to distribution of the software without
++# specific, written prior permission. Keith Packard makes no
++# representations about the suitability of this software for any purpose. It
++# is provided "as is" without express or implied warranty.
++#
++# KEITH PACKARD DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
++# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
++# EVENT SHALL KEITH PACKARD BE LIABLE FOR ANY SPECIAL, INDIRECT OR
++# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
++# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
++# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
++# PERFORMANCE OF THIS SOFTWARE.
++#
++
++AUTOMAKE_OPTIONS = 1.7 foreign
++
++AM_CFLAGS = @XSET_CFLAGS@
++
++bin_PROGRAMS = xset
++
++xset_SOURCES = xset.c
++
++xset_LDADD = @XSET_LIBS@
++
++man5_MANS=xset.man
++
++EXTRA_DIST= $(man5_MANS)
++
++MAINTAINERCLEANFILES = configure \
++config.guess \
++config.sub \
++install-sh \
++ltmain.sh \
++missing \
++mkinstalldirs \
++aclocal.m4 \
++Makefile.in \
++depcomp \
++autoscan.log \
++configure.scan \
++config.h \
++config.h.in \
++$(man5_MANS)
+diff -urN xset.orig/autogen.sh xset/autogen.sh
+--- xset.orig/autogen.sh 1970-01-01 01:00:00.000000000 +0100
++++ xset/autogen.sh 2004-08-14 16:27:56.000000000 +0200
+@@ -0,0 +1,3 @@
++#! /bin/sh
++autoreconf -v --install || exit 1
++./configure --enable-maintainer-mode "$@"
+diff -urN xset.orig/configure.ac xset/configure.ac
+--- xset.orig/configure.ac 1970-01-01 01:00:00.000000000 +0100
++++ xset/configure.ac 2004-08-17 14:21:25.000000000 +0200
+@@ -0,0 +1,41 @@
++dnl
++dnl $Id$
++dnl
++dnl Copyright © 2003 Keith Packard
++dnl
++dnl Permission to use, copy, modify, distribute, and sell this software and its
++dnl documentation for any purpose is hereby granted without fee, provided that
++dnl the above copyright notice appear in all copies and that both that
++dnl copyright notice and this permission notice appear in supporting
++dnl documentation, and that the name of Keith Packard not be used in
++dnl advertising or publicity pertaining to distribution of the software without
++dnl specific, written prior permission. Keith Packard makes no
++dnl representations about the suitability of this software for any purpose. It
++dnl is provided "as is" without express or implied warranty.
++dnl
++dnl KEITH PACKARD DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
++dnl INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
++dnl EVENT SHALL KEITH PACKARD BE LIABLE FOR ANY SPECIAL, INDIRECT OR
++dnl CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
++dnl DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
++dnl TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
++dnl PERFORMANCE OF THIS SOFTWARE.
++dnl
++
++AC_PREREQ(2.57)
++AC_INIT([xset],4.4.0,[],xset)
++AC_CONFIG_SRCDIR([Makefile.am])
++AM_INIT_AUTOMAKE([dist-bzip2])
++AM_MAINTAINER_MODE
++AM_CONFIG_HEADER(config.h)
++
++AC_PROG_CC
++AC_PROG_INSTALL
++AC_PROG_LN_S
++AC_LIBTOOL_WIN32_DLL
++AM_PROG_LIBTOOL
++AC_PROG_MAKE_SET
++
++PKG_CHECK_MODULES(XSET, xext xextensions xmu x11)
++
++AC_OUTPUT([Makefile])
diff --git a/xset/xset_cvs.oe b/xset/xset_20040817.oe
index e69de29bb2..e69de29bb2 100644
--- a/xset/xset_cvs.oe
+++ b/xset/xset_20040817.oe