aboutsummaryrefslogtreecommitdiffstats
path: root/zip
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2004-11-09 00:05:45 +0000
committerChris Larson <clarson@kergoth.com>2004-11-09 00:05:45 +0000
commitdbbcbe33ce88fdcf1b3379750fe58d0d32fd16b2 (patch)
treeff6973b61e7aaaf2a5c554717e3531ad80a8e5fd /zip
parentb8186dca7aaed5e4983c6caf5c1abbbc37364de7 (diff)
downloadopenembedded-dbbcbe33ce88fdcf1b3379750fe58d0d32fd16b2.tar.gz
Fix the zip build to obey our variables, so that the 'zip' package actually contains TARGET binaries instead of NATIVE ones.
BKrev: 419009d9Gs5ngGuLFOHNKwUuZ911Eg
Diffstat (limited to 'zip')
-rw-r--r--zip/zip_2.3.oe11
1 files changed, 9 insertions, 2 deletions
diff --git a/zip/zip_2.3.oe b/zip/zip_2.3.oe
index 529c5a8025..7ca21268d5 100644
--- a/zip/zip_2.3.oe
+++ b/zip/zip_2.3.oe
@@ -1,11 +1,18 @@
SECTION = "console/utils"
SRC_URI = "http://www.mirror.ac.uk/sites/ftp.info-zip.org/pub/infozip/src/zip23.tar.gz"
+PR = "r1"
+
+EXTRA_OEMAKE = "'CC=${CC}' 'BIND=${CC}' 'AS=${AS}' 'CPP=${CPP}' \
+ 'CFLAGS=-I. -DUNIX ${CFLAGS}' 'INSTALL=install' \
+ 'BINFLAGS=0755' 'INSTALL_D=install -d'"
do_compile() {
- make -f unix/Makefile generic
+ oe_runmake -f unix/Makefile generic
}
do_install() {
- make -f unix/Makefile install prefix=${D}${prefix}
+ oe_runmake -f unix/Makefile prefix=${D}${prefix} \
+ BINDIR=${D}/${bindir} MANDIR=${D}/${mandir}/man1 \
+ install
}