aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/mktemp/mktemp_1.6.bb15
1 files changed, 11 insertions, 4 deletions
diff --git a/recipes/mktemp/mktemp_1.6.bb b/recipes/mktemp/mktemp_1.6.bb
index bd9c4caa7d..33c1cf132c 100644
--- a/recipes/mktemp/mktemp_1.6.bb
+++ b/recipes/mktemp/mktemp_1.6.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.mktemp.org/"
SECTION = "console/utils"
LICENSE = "GPLv2 BSD"
-inherit autotools
+inherit autotools update-alternatives
EXTRA_OECONF = "--with-libc"
@@ -12,6 +12,13 @@ SRC_URI = "\
file://add_destdir.patch;patch=1 \
file://disable-strip.patch;patch=1 \
"
-
-# FIXME should rather use update-alternatives
-RCONFLICTS_${PN} = "coreutils"
+
+do_install_append () {
+ mkdir ${D}${base_bindir}
+ mv ${D}${bindir}/mktemp ${D}${base_bindir}/mktemp.${PN}
+}
+
+ALTERNATIVE_NAME = "mktemp"
+ALTERNATIVE_LINK = "${base_bindir}/mktemp"
+ALTERNATIVE_PATH = "${base_bindir}/mktemp.${PN}"
+ALTERNATIVE_PRIORITY = "100"