aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/python/python_2.6.5.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/recipes/python/python_2.6.5.bb b/recipes/python/python_2.6.5.bb
index c144feed20..ecd9f78417 100644
--- a/recipes/python/python_2.6.5.bb
+++ b/recipes/python/python_2.6.5.bb
@@ -83,6 +83,12 @@ do_install() {
sed -i -e s,ccache,'$(CCACHE)', ${D}/${libdir}/python${PYTHON_MAJMIN}/config/Makefile
}
+do_install_append() {
+ # remove unecessary files from python-distutils' packages
+ rm ${D}/${libdir}/python${PYTHON_MAJMIN}/config/libpython2.6.a
+ rm ${D}/${libdir}/python${PYTHON_MAJMIN}/distutils/command/win*
+}
+
require python-${PYTHON_MAJMIN}-manifest.inc
# manual dependency additions