aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/xorg-xserver/xserver-xorg-conf/babbage/xorg.conf56
-rw-r--r--recipes/xorg-xserver/xserver-xorg-conf_0.1.bb2
2 files changed, 57 insertions, 1 deletions
diff --git a/recipes/xorg-xserver/xserver-xorg-conf/babbage/xorg.conf b/recipes/xorg-xserver/xserver-xorg-conf/babbage/xorg.conf
new file mode 100644
index 0000000000..d4d41db42d
--- /dev/null
+++ b/recipes/xorg-xserver/xserver-xorg-conf/babbage/xorg.conf
@@ -0,0 +1,56 @@
+#
+# X11 configuration for i.MX51 Babbage EVK
+# Based on pm9263 by Koan sas
+#
+
+Section "Monitor"
+ Identifier "Display"
+EndSection
+
+Section "Device"
+ Identifier "fbdevice"
+ Driver "fbdev"
+ Option "fbdev" "/dev/fb0"
+ Option "shadowfb" "true"
+EndSection
+
+Section "Screen"
+ Identifier "fbscreen"
+ Device "fbdevice"
+ Monitor "Display"
+EndSection
+
+Section "InputDevice"
+ Identifier "mxc_ts"
+ Driver "evdev"
+ Option "SwapAxes" "0"
+ Option "Device" "/dev/input/touchscreen0"
+EndSection
+
+Section "InputDevice"
+ Identifier "Generic Mouse"
+ Driver "mouse"
+ Option "CorePointer"
+EndSection
+
+Section "InputDevice"
+ Identifier "Keypad"
+ Driver "evdev"
+ Option "Device" "/dev/input/event0"
+# Option "XkbModel" "nokiarx51"
+# Option "XkbLayout" "us"
+EndSection
+
+Section "ServerLayout"
+ Identifier "Layout"
+ Screen "fbscreen"
+ InputDevice "mxc_ts" "CorePointer"
+ InputDevice "Keypad"
+# Enable mouse only if necessary, it may interfere with touchscreen behaviour
+# InputDevice "Generic Mouse"
+EndSection
+
+#Section "ServerFlags"
+# Option "AutoAddDevices" "false"
+#EndSection
+
diff --git a/recipes/xorg-xserver/xserver-xorg-conf_0.1.bb b/recipes/xorg-xserver/xserver-xorg-conf_0.1.bb
index df03f1bb2e..fd62ee2289 100644
--- a/recipes/xorg-xserver/xserver-xorg-conf_0.1.bb
+++ b/recipes/xorg-xserver/xserver-xorg-conf_0.1.bb
@@ -1,5 +1,5 @@
DESCRIPTION = "Machine specific xorg.conf files"
-PR = "r33"
+PR = "r34"
SRC_URI = "file://xorg.conf"