aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/qgears/files/0001-qt-embedded-patch.patch68
-rw-r--r--recipes/qgears/files/0002-add-install-logic-to-pro-file.patch23
-rw-r--r--recipes/qgears/qgears_2.bb20
3 files changed, 111 insertions, 0 deletions
diff --git a/recipes/qgears/files/0001-qt-embedded-patch.patch b/recipes/qgears/files/0001-qt-embedded-patch.patch
new file mode 100644
index 0000000000..efb0607468
--- /dev/null
+++ b/recipes/qgears/files/0001-qt-embedded-patch.patch
@@ -0,0 +1,68 @@
+From d7275f4a6089d0485572e946cc6698c384e741b9 Mon Sep 17 00:00:00 2001
+From: Cliff Brake <cbrake@bec-systems.com>
+Date: Sat, 14 Nov 2009 18:54:40 -0500
+Subject: [PATCH] qt-embedded patch
+
+---
+ commonrenderer.h | 2 +-
+ main.cpp | 3 ++-
+ qglgears.cpp | 3 ++-
+ qglgears.h | 3 ++-
+ 4 files changed, 7 insertions(+), 4 deletions(-)
+
+diff --git a/commonrenderer.h b/commonrenderer.h
+index 2972bdf..ba3813a 100644
+--- a/commonrenderer.h
++++ b/commonrenderer.h
+@@ -42,7 +42,7 @@ protected:
+ void gearsRender(QPainter *p);
+
+ void setup(int w, int h);
+- void animate(double *pts, double *deltas,
++ void animate(qreal *pts, qreal *deltas,
+ int index, int limit);
+ void animateStep(int w, int h);
+ void printFrameRate();
+diff --git a/main.cpp b/main.cpp
+index 133d09a..fa9307c 100644
+--- a/main.cpp
++++ b/main.cpp
+@@ -56,7 +56,8 @@ int main(int argc, char **argv)
+
+ switch (renderer) {
+ case OpenGL:
+-#ifndef QT_NO_OPENGL
++//#ifndef QT_NO_OPENGL
++#if 0
+ widget = new QGLGears();
+ #else
+ qWarning("OpenGL not supported!");
+diff --git a/qglgears.cpp b/qglgears.cpp
+index a8bf34b..0a95e51 100644
+--- a/qglgears.cpp
++++ b/qglgears.cpp
+@@ -1,5 +1,6 @@
+ #include "qglgears.h"
+-#ifndef QT_NO_OPENGL
++//#ifndef QT_NO_OPENGL
++#if 0
+ #include <QTimer>
+
+ QGLGears::QGLGears()
+diff --git a/qglgears.h b/qglgears.h
+index 1556da2..1af8101 100644
+--- a/qglgears.h
++++ b/qglgears.h
+@@ -1,7 +1,8 @@
+ #ifndef QGLGEARS_H
+ #define QGLGEARS_H
+
+-#ifndef QT_NO_OPENGL
++//#ifndef QT_NO_OPENGL
++#if 0
+ #include <QGLWidget>
+
+
+--
+1.6.0.4
+
diff --git a/recipes/qgears/files/0002-add-install-logic-to-pro-file.patch b/recipes/qgears/files/0002-add-install-logic-to-pro-file.patch
new file mode 100644
index 0000000000..9d39d1cc2c
--- /dev/null
+++ b/recipes/qgears/files/0002-add-install-logic-to-pro-file.patch
@@ -0,0 +1,23 @@
+From b42d1a44681e7f66169c3238135f86d65fe765c3 Mon Sep 17 00:00:00 2001
+From: Cliff Brake <cbrake@bec-systems.com>
+Date: Sat, 14 Nov 2009 19:07:39 -0500
+Subject: [PATCH] add install logic to pro file
+
+---
+ qgears.pro | 3 +++
+ 1 files changed, 3 insertions(+), 0 deletions(-)
+
+diff --git a/qgears.pro b/qgears.pro
+index b5436a8..8a3e7a0 100644
+--- a/qgears.pro
++++ b/qgears.pro
+@@ -12,3 +12,6 @@ HEADERS += qgears.h qglgears.h fdclock.h composite.h text.h rawpixmap.h
+ SOURCES += main.cpp qgears.cpp commonrenderer.cpp qglgears.cpp \
+ fdclock.cpp composite.cpp text.cpp rawpixmap.cpp
+
++target.path = /usr/bin
++INSTALLS += target
++
+--
+1.6.0.4
+
diff --git a/recipes/qgears/qgears_2.bb b/recipes/qgears/qgears_2.bb
new file mode 100644
index 0000000000..027b4c434f
--- /dev/null
+++ b/recipes/qgears/qgears_2.bb
@@ -0,0 +1,20 @@
+
+inherit qt4x11
+
+PR = "r1"
+
+SRC_URI = "http://ktown.kde.org/~zrusin/examples/qgears2.tar.bz2 \
+ file://0001-qt-embedded-patch.patch \
+ file://0002-add-install-logic-to-pro-file.patch \
+ "
+
+S = ${WORKDIR}/qgears2
+
+do_install() {
+ export INSTALL_ROOT=${D}
+ make install
+}
+
+SRC_URI[md5sum] = "1a5d0f555745c397216caa551fbda305"
+SRC_URI[sha256sum] = "dc86bb973dd904ef161a29066189ff1c48aa324a8800b83ef5415d904a0d2586"
+