aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/machine/titan.conf7
-rw-r--r--conf/machine/wrap.conf9
-rw-r--r--packages/linux/linux-handhelds-2.6_2.6.18-hh1.bb11
-rw-r--r--packages/linux/linux-handhelds-2.6_cvs.bb2
4 files changed, 23 insertions, 6 deletions
diff --git a/conf/machine/titan.conf b/conf/machine/titan.conf
index 99f8b2a18b..a7ce106356 100644
--- a/conf/machine/titan.conf
+++ b/conf/machine/titan.conf
@@ -24,8 +24,11 @@ USE_DEVFS = "0"
IMAGE_FSTYPE ?= "ext2.gz"
IMAGE_ROOTFS_SIZE_ext2 ?= "63984"
-# Extra items to include in the fs image
-BOOTSTRAP_EXTRA_RDEPENDS += "kernel pciutils udev kernel-modules lilo-sh"
+# Things to include in the fs image
+MACHINE_FEATURES = "kernel26 pci ext2 usbhost"
+MACHINE_TASK_PROVIDER = "task-base"
+# The kernel and lilo-sh need to installed to boot from flash
+MACHINE_EXTRA_RDEPENDS = "kernel lilo-sh"
# Add the SCI (serial) and SM (flash) devices to the minimal /dev
IMAGE_DEVICE_TABLES = "files/device_table-minimal.txt \
diff --git a/conf/machine/wrap.conf b/conf/machine/wrap.conf
index 592be8dd3c..e0c65475f6 100644
--- a/conf/machine/wrap.conf
+++ b/conf/machine/wrap.conf
@@ -3,7 +3,7 @@
#@DESCRIPTION: Machine configuration for the PC Engines WRAP (Wireless Router Application Platform) boards.
TARGET_ARCH = "i486"
-PACKAGE_EXTRA_ARCHS = "i386"
+PACKAGE_EXTRA_ARCHS = "i386 x86"
PREFERRED_PROVIDER_virtual/kernel = "linux-wrap-geode"
PREFERRED_PROVIDERS += "virtual/${TARGET_PREFIX}depmod:module-init-tools-cross"
@@ -21,8 +21,11 @@ USE_DEVFS = "0"
# partition on the compact flash card being used.
IMAGE_FSTYPE ?= "tar.gz"
-# Extra items to include in the fs image
-BOOTSTRAP_EXTRA_RDEPENDS += "kernel pciutils udev kernel-modules grub"
+# Things to include in the fs image
+MACHINE_FEATURES = "kernel26 pci ext2"
+MACHINE_TASK_PROVIDER = "task-base"
+# The kernel and grub need to installed to boot from flash
+MACHINE_EXTRA_RDEPENDS = "kernel grub"
# Minimal device table is fine
IMAGE_DEVICE_TABLES = "files/device_table-minimal.txt"
diff --git a/packages/linux/linux-handhelds-2.6_2.6.18-hh1.bb b/packages/linux/linux-handhelds-2.6_2.6.18-hh1.bb
new file mode 100644
index 0000000000..b34d4630a0
--- /dev/null
+++ b/packages/linux/linux-handhelds-2.6_2.6.18-hh1.bb
@@ -0,0 +1,11 @@
+SECTION = "kernel"
+DESCRIPTION = "handhelds.org Linux kernel 2.6 for PocketPCs and other consumer handheld devices."
+LICENSE = "GPL"
+PR = "r0"
+
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "${HANDHELDS_CVS};module=linux/kernel26;tag=${@'K' + bb.data.getVar('PV',d,1).replace('.', '-')} \
+ file://defconfig"
+
+require linux-handhelds-2.6.inc
diff --git a/packages/linux/linux-handhelds-2.6_cvs.bb b/packages/linux/linux-handhelds-2.6_cvs.bb
index e921643a53..1c1d8f38fe 100644
--- a/packages/linux/linux-handhelds-2.6_cvs.bb
+++ b/packages/linux/linux-handhelds-2.6_cvs.bb
@@ -7,7 +7,7 @@ PR = "r5"
K_MAJOR = "2"
K_MINOR = "6"
K_MICRO = "18"
-HHV = "0"
+HHV = "1"
SRC_URI = "${HANDHELDS_CVS};module=linux/kernel26 \
file://defconfig"