aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/distro/angstrom-2008.1.conf2
-rw-r--r--conf/distro/foonas.conf2
-rw-r--r--conf/distro/include/angstrom-2007-for-openmoko.inc2
-rw-r--r--conf/distro/include/angstrom.inc14
-rw-r--r--conf/machine/cm-x270.conf2
-rwxr-xr-xcontrib/angstrom/build-feeds.sh4
-rwxr-xr-xcontrib/angstrom/build-release.sh4
-rw-r--r--packages/images/liveramdisk-image.bb2
-rw-r--r--packages/linux/linux-handhelds-2.6.inc4
9 files changed, 18 insertions, 18 deletions
diff --git a/conf/distro/angstrom-2008.1.conf b/conf/distro/angstrom-2008.1.conf
index 8654509f89..49fc4ac034 100644
--- a/conf/distro/angstrom-2008.1.conf
+++ b/conf/distro/angstrom-2008.1.conf
@@ -47,7 +47,7 @@ IMAGE_LINGUAS = '${@base_less_or_equal("ROOT_FLASH_SIZE", "16", "", "en-us", d)}
# set feed path variables
-FEED_BASEPATH = "feeds/2008/${ANGSTROM_PKG_FORMAT}/${ANGSTROM_MODE}/"
+FEED_BASEPATH = "feeds/2008/${ANGSTROM_PKG_FORMAT}/${ANGSTROMLIBC}/"
#The angstrom-mirrors.bbclass should have everything, but we can use this as a fallback
diff --git a/conf/distro/foonas.conf b/conf/distro/foonas.conf
index 8e26a282ab..30c1136f5f 100644
--- a/conf/distro/foonas.conf
+++ b/conf/distro/foonas.conf
@@ -7,7 +7,7 @@
#@--------------------------------------------------------------------
FOONAS_MODE ?= "glibc"
-ANGSTROM_MODE = ${FOONAS_MODE}
+ANGSTROMLIBC = ${FOONAS_MODE}
require conf/distro/angstrom-2008.1.conf
DISTRO_NAME = "foonas"
diff --git a/conf/distro/include/angstrom-2007-for-openmoko.inc b/conf/distro/include/angstrom-2007-for-openmoko.inc
index 7a4d498539..34fbc52cfe 100644
--- a/conf/distro/include/angstrom-2007-for-openmoko.inc
+++ b/conf/distro/include/angstrom-2007-for-openmoko.inc
@@ -29,7 +29,7 @@ DISTRO_TYPE ?= "debug"
IMAGE_LINGUAS = '${@base_less_or_equal("ROOT_FLASH_SIZE", "16", "", "en-gb", d)}'
# set feed path variables
-FEED_BASEPATH = "feeds/2007/${ANGSTROM_PKG_FORMAT}/${ANGSTROM_MODE}/"
+FEED_BASEPATH = "feeds/2007/${ANGSTROM_PKG_FORMAT}/${ANGSTROMLIBC}/"
#The angstrom-mirrors.bbclass should have everything, but we can use this as a fallback
diff --git a/conf/distro/include/angstrom.inc b/conf/distro/include/angstrom.inc
index 847078b21e..25dee11ff2 100644
--- a/conf/distro/include/angstrom.inc
+++ b/conf/distro/include/angstrom.inc
@@ -17,12 +17,12 @@ INHERIT += "src_distribute_local"
SRC_DIST_LOCAL ?= "symlink"
# Can be "glibc", "eglibc" or "uclibc"
-ANGSTROM_MODE ?= "glibc"
-PSTAGE_EXTRAPATH = "${ANGSTROM_MODE}"
+ANGSTROMLIBC ?= "glibc"
+PSTAGE_EXTRAPATH = "${ANGSTROMLIBC}"
-CACHE = "${TMPDIR}/cache/${ANGSTROM_MODE}/${MACHINE}"
-DEPLOY_DIR = "${TMPDIR}/deploy/${ANGSTROM_MODE}"
-require conf/distro/include/angstrom-${ANGSTROM_MODE}.inc
+CACHE = "${TMPDIR}/cache/${ANGSTROMLIBC}/${MACHINE}"
+DEPLOY_DIR = "${TMPDIR}/deploy/${ANGSTROMLIBC}"
+require conf/distro/include/angstrom-${ANGSTROMLIBC}.inc
# ARM920T and up can use thumb mode to decrease binary size at the expense of speed
# (the complete story is a bit more nuanced due to cache starvation)
@@ -287,7 +287,7 @@ PACKAGE_EXTRA_ARCHS_htcwallaby = "arm-oabi"
#Name the generated images in a sane way
-IMAGE_NAME = "${DISTRO_NAME}-${IMAGE_BASENAME}-${ANGSTROM_MODE}-${ANGSTROM_PKG_FORMAT}-${DISTRO_VERSION}-${MACHINE}"
+IMAGE_NAME = "${DISTRO_NAME}-${IMAGE_BASENAME}-${ANGSTROMLIBC}-${ANGSTROM_PKG_FORMAT}-${DISTRO_VERSION}-${MACHINE}"
DEPLOY_DIR_IMAGE = "${DEPLOY_DIR}/images/${MACHINE}"
# Angstrom *always* has some form of release config, so error out if someone thinks he knows better
@@ -299,7 +299,7 @@ DISTRO_CHECK := "${@bb.data.getVar("DISTRO_VERSION",d,1) or bb.fatal('Remove thi
# in their local.conf
#Name of the client
-TINDER_MACHINE = "${MACHINE}-${ANGSTROM_MODE}-build-image"
+TINDER_MACHINE = "${MACHINE}-${ANGSTROMLIBC}-build-image"
# Which lof file to write to, which tree to report to
TINDER_LOG = "${TMPDIR}/tinder.log"
diff --git a/conf/machine/cm-x270.conf b/conf/machine/cm-x270.conf
index e01b37d3e6..3c21c546b1 100644
--- a/conf/machine/cm-x270.conf
+++ b/conf/machine/cm-x270.conf
@@ -52,7 +52,7 @@ MACHINE_FEATURES = "kernel26 pcmcia usbhost usbgadget pcmcia touchscreen alsa iw
# to program the compulab NAND flash, the following scheme is suggested. Create
# a small rootfs that can fit in NOR flash using the following config:
# - Angstrom distro
-# - uclibc (set ANGSTROM_MODE = "uclibc" in local.conf)
+# - uclibc (set ANGSTROMLIBC = "uclibc" in local.conf)
# - angstrom-minimal-image-with-mtd-utils bitbake target
# - put the following in your local.conf
# - IMAGE_FSTYPES = "jffs2 tar cpio.gz"
diff --git a/contrib/angstrom/build-feeds.sh b/contrib/angstrom/build-feeds.sh
index a156d5b8c8..fd07747aad 100755
--- a/contrib/angstrom/build-feeds.sh
+++ b/contrib/angstrom/build-feeds.sh
@@ -25,12 +25,12 @@ do_build() {
if [ "$BUILD_CLEAN" != "" ]
then
- ANGSTROM_MODE=uclibc MACHINE=$BUILD_MACHINE bitbake -c clean $BUILD_CLEAN
+ ANGSTROMLIBC=uclibc MACHINE=$BUILD_MACHINE bitbake -c clean $BUILD_CLEAN
fi
for target in $BUILD_TARGETS
do
- ANGSTROM_MODE=uclibc MACHINE=$BUILD_MACHINE bitbake $target && do_report_success
+ ANGSTROMLIBC=uclibc MACHINE=$BUILD_MACHINE bitbake $target && do_report_success
done
fi
}
diff --git a/contrib/angstrom/build-release.sh b/contrib/angstrom/build-release.sh
index 0912476b47..14244a315e 100755
--- a/contrib/angstrom/build-release.sh
+++ b/contrib/angstrom/build-release.sh
@@ -6,7 +6,7 @@ do_build() {
if [ $DO_UCLIBC = 1 ]
then
BUILD_MODE="uclibc"
- echo 'ANGSTROM_MODE = "uclibc"' > conf/auto.conf
+ echo 'ANGSTROMLIBC = "uclibc"' > conf/auto.conf
if [ "$BUILD_CLEAN" != "" ]
then
@@ -20,7 +20,7 @@ do_build() {
fi
BUILD_MODE="glibc"
- echo 'ANGSTROM_MODE = "glibc"' > conf/auto.conf
+ echo 'ANGSTROMLIBC = "glibc"' > conf/auto.conf
if [ "$BUILD_CLEAN" != "" ]
then
diff --git a/packages/images/liveramdisk-image.bb b/packages/images/liveramdisk-image.bb
index 49af33c4ed..5caa4baa11 100644
--- a/packages/images/liveramdisk-image.bb
+++ b/packages/images/liveramdisk-image.bb
@@ -1,5 +1,5 @@
# LiveRamdisk image
-# Building with ANGSTROM_MODE=uclibc is recommended
+# Building with ANGSTROMLIBC=uclibc is recommended
#
# LiveRamdisk concept/implementation by Paul Sokolovsky
LICENSE = "MIT"
diff --git a/packages/linux/linux-handhelds-2.6.inc b/packages/linux/linux-handhelds-2.6.inc
index c9edbf301e..5270c1465b 100644
--- a/packages/linux/linux-handhelds-2.6.inc
+++ b/packages/linux/linux-handhelds-2.6.inc
@@ -35,7 +35,7 @@ do_configure() {
die "No default configuration for ${MACHINE} available."
fi
- if [ -n "${KERNEL_INITRAMFS_PATH}" -a "${ANGSTROM_MODE}" = "glibc" ]; then
+ if [ -n "${KERNEL_INITRAMFS_PATH}" -a "${ANGSTROMLIBC}" = "glibc" ]; then
if [ ! -f ${KERNEL_INITRAMFS_PATH} ]; then
echo "Kernel is requested to be built with internal initramfs."
echo "The initramfs image must exist prior to building the kernel, but it does not"
@@ -74,7 +74,7 @@ do_deploy_append() {
echo "${MACHINE}-kernel-${DATETIME} ${KERNEL_IMAGE_BASE_NAME} - kernel" >> ${DEPLOY_DIR_IMAGE}/reflash.ctl
gen_haret_startup
- if [ -n "${KERNEL_INITRAMFS_PATH}" -a "${ANGSTROM_MODE}" == "glibc" ]; then
+ if [ -n "${KERNEL_INITRAMFS_PATH}" -a "${ANGSTROMLIBC}" == "glibc" ]; then
cp ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGE_BASE_NAME}.bin ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-$(basename ${KERNEL_INITRAMFS_PATH} | awk -F. '{print $1}')-${PV}-${PR}-${MACHINE}.bin
fi
}