aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/checksums.ini4
-rw-r--r--recipes/libogg/libogg.inc11
-rw-r--r--recipes/libogg/libogg_1.0.bb18
-rw-r--r--recipes/libogg/libogg_1.1.3.bb17
-rw-r--r--recipes/libogg/libogg_1.1.4.bb4
-rw-r--r--recipes/libogg/libogg_1.1.bb19
6 files changed, 26 insertions, 47 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index 43dfb5a94e..a881d6bbe3 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -15682,6 +15682,10 @@ sha256=920fa2a0924d66884825d36a2e843de069cfdf1af01945d05da25999bbd6396c
md5=eaf7dc6ebbff30975de7527a80831585
sha256=bae29e79fbc50bbedf1235852094b71c8c910a1ef0cd42fe4163b7b545630b65
+[http://downloads.xiph.org/releases/ogg/libogg-1.1.4.tar.gz]
+md5=10200ec22543841d9d1c23e0aed4e5e9
+sha256=9354c183fd88417c2860778b60b7896c9487d8f6e58b9fec3fdbf971142ce103
+
[http://www.vorbis.com/files/1.0.1/unix/libogg-1.1.tar.gz]
md5=461d7097bf47864b872085a94ff94e10
sha256=01453d561255b5fcb361997904752860e4f8c6b9742f290578a44615fcc94356
diff --git a/recipes/libogg/libogg.inc b/recipes/libogg/libogg.inc
new file mode 100644
index 0000000000..f8eed60fef
--- /dev/null
+++ b/recipes/libogg/libogg.inc
@@ -0,0 +1,11 @@
+SECTION = "libs"
+DESCRIPTION = "libogg is the bitstream and framing library \
+for the Ogg project. It provides functions which are \
+necessary to codec libraries like libvorbis."
+LICENSE = "BSD"
+
+INC_PR = "r4"
+
+inherit autotools
+
+SRC_URI = "http://downloads.xiph.org/releases/ogg/libogg-${PV}.tar.gz"
diff --git a/recipes/libogg/libogg_1.0.bb b/recipes/libogg/libogg_1.0.bb
index 7af1468004..d5bad18a0a 100644
--- a/recipes/libogg/libogg_1.0.bb
+++ b/recipes/libogg/libogg_1.0.bb
@@ -1,18 +1,4 @@
-SECTION = "libs"
-DESCRIPTION = "libogg is the bitstream and framing library \
-for the Ogg project. It provides functions which are \
-necessary to codec libraries like libvorbis."
-LICENSE = "BSD"
-PR = "r1"
+require libogg.inc
-SRC_URI = "http://www.vorbis.com/files/${PV}/unix/libogg-${PV}.tar.gz"
+PR = "${INC_PR}.0"
-inherit autotools pkgconfig
-
-do_stage () {
- oe_libinstall -a -so -C src libogg ${STAGING_LIBDIR}
-
- install -d ${STAGING_INCDIR}/ogg
- (cd ${S}/include/ogg; cp config_types.h ogg.h os_types.h ${STAGING_INCDIR}/ogg/)
- install -m 0644 ${S}/ogg.m4 ${STAGING_DATADIR}/aclocal/
-}
diff --git a/recipes/libogg/libogg_1.1.3.bb b/recipes/libogg/libogg_1.1.3.bb
index 0a6e827ff1..d5bad18a0a 100644
--- a/recipes/libogg/libogg_1.1.3.bb
+++ b/recipes/libogg/libogg_1.1.3.bb
@@ -1,17 +1,4 @@
-SECTION = "libs"
-DESCRIPTION = "libogg is the bitstream and framing library \
-for the Ogg project. It provides functions which are \
-necessary to codec libraries like libvorbis."
-LICENSE = "BSD"
+require libogg.inc
-SRC_URI = "http://downloads.xiph.org/releases/ogg/libogg-${PV}.tar.gz"
+PR = "${INC_PR}.0"
-inherit autotools pkgconfig
-
-do_stage () {
- oe_libinstall -a -so -C src libogg ${STAGING_LIBDIR}
-
- install -d ${STAGING_INCDIR}/ogg
- (cd ${S}/include/ogg; cp config_types.h ogg.h os_types.h ${STAGING_INCDIR}/ogg/)
- install -m 0644 ${S}/ogg.m4 ${STAGING_DATADIR}/aclocal/
-}
diff --git a/recipes/libogg/libogg_1.1.4.bb b/recipes/libogg/libogg_1.1.4.bb
new file mode 100644
index 0000000000..d5bad18a0a
--- /dev/null
+++ b/recipes/libogg/libogg_1.1.4.bb
@@ -0,0 +1,4 @@
+require libogg.inc
+
+PR = "${INC_PR}.0"
+
diff --git a/recipes/libogg/libogg_1.1.bb b/recipes/libogg/libogg_1.1.bb
index 687b4decec..0baec126e3 100644
--- a/recipes/libogg/libogg_1.1.bb
+++ b/recipes/libogg/libogg_1.1.bb
@@ -1,19 +1,6 @@
-SECTION = "libs"
-DESCRIPTION = "libogg is the bitstream and framing library \
-for the Ogg project. It provides functions which are \
-necessary to codec libraries like libvorbis."
-LICENSE = "BSD"
-PR = "r3"
+require libogg.inc
-SRC_URI = "http://www.vorbis.com/files/1.0.1/unix/libogg-${PV}.tar.gz \
-file://m4.patch;patch=1"
+PR = "${INC_PR}.0"
-inherit autotools pkgconfig
+SRC_URI += "file://m4.patch;patch=1"
-do_stage () {
- oe_libinstall -a -so -C src libogg ${STAGING_LIBDIR}
-
- install -d ${STAGING_INCDIR}/ogg
- (cd ${S}/include/ogg; cp config_types.h ogg.h os_types.h ${STAGING_INCDIR}/ogg/)
- install -m 0644 ${S}/ogg.m4 ${STAGING_DATADIR}/aclocal/
-}