aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/dri/libdrm_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/dri/libdrm_git.bb b/recipes/dri/libdrm_git.bb
new file mode 100644
index 0000000000..1eabc20067
--- /dev/null
+++ b/recipes/dri/libdrm_git.bb
@@ -0,0 +1,24 @@
+SECTION = "x11/base"
+LICENSE = "MIT"
+SRC_URI = "git://anongit.freedesktop.org/mesa/drm;protocol=git;branch=master"
+SRC_URI_om-gta02 = "git://git.bitwiz.org.uk/libdrm.git;protocol=git;branch=glamo"
+
+PROVIDES = "drm"
+DEPENDS = "libpthread-stubs virtual/kernel"
+
+PE = "1"
+PV = "2.4.15+gitr${SRCREV}"
+PR = "r1"
+
+DEFAULT_PREFERENCE = "-1"
+DEFAULT_PREFERENCE_om-gta02 = "1"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OECONF_append_om-gta02 = " --enable-glamo-experimental-api --disable-intel"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ autotools_stage_all
+}