aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/eglibc/eglibc-svn/armv4-eabi-compile-fix.patch24
-rw-r--r--recipes/eglibc/eglibc_2.12.bb3
-rw-r--r--recipes/eglibc/eglibc_svn.bb3
3 files changed, 28 insertions, 2 deletions
diff --git a/recipes/eglibc/eglibc-svn/armv4-eabi-compile-fix.patch b/recipes/eglibc/eglibc-svn/armv4-eabi-compile-fix.patch
new file mode 100644
index 0000000000..cf1b2a8c9b
--- /dev/null
+++ b/recipes/eglibc/eglibc-svn/armv4-eabi-compile-fix.patch
@@ -0,0 +1,24 @@
+Source: http://sourceware.org/bugzilla/show_bug.cgi?id=12097
+
+The patch should be merged into glibc-ports
+
+-Khem
+Index: libc/ports/sysdeps/unix/sysv/linux/arm/eabi/libc-do-syscall.S
+===================================================================
+--- libc.orig/ports/sysdeps/unix/sysv/linux/arm/eabi/libc-do-syscall.S
++++ libc/ports/sysdeps/unix/sysv/linux/arm/eabi/libc-do-syscall.S
+@@ -16,6 +16,8 @@
+ Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+ 02111-1307 USA. */
+
++#if defined(__thumb__)
++
+ #include <sysdep.h>
+
+ /* Out-of-line syscall stub. We expect the system call number in ip
+@@ -41,3 +43,5 @@ ENTRY (__libc_do_syscall)
+ pop {r7, pc}
+ .fnend
+ END (__libc_do_syscall)
++
++#endif /* __thumb__ */
diff --git a/recipes/eglibc/eglibc_2.12.bb b/recipes/eglibc/eglibc_2.12.bb
index c0949c4da7..fbb3280367 100644
--- a/recipes/eglibc/eglibc_2.12.bb
+++ b/recipes/eglibc/eglibc_2.12.bb
@@ -4,7 +4,7 @@ DEFAULT_PREFERENCE = "-1"
DEPENDS += "gperf-native"
FILESPATHPKG =. "eglibc-svn:"
PV = "2.12"
-PR = "${INC_PR}.5"
+PR = "${INC_PR}.6"
PR_append = "+svnr${SRCPV}"
SRCREV="11306"
EGLIBC_BRANCH="eglibc-2_12"
@@ -15,6 +15,7 @@ SRC_URI = "svn://svn.eglibc.org/branches;module=${EGLIBC_BRANCH};proto=svn \
file://sh4_set_fpscr_2.12.patch \
file://sh4_local-fpscr_values.patch \
file://eglibc-dont-cache-slibdir.patch \
+ file://armv4-eabi-compile-fix.patch \
file://etc/ld.so.conf \
file://generate-supported.mk"
S = "${WORKDIR}/${EGLIBC_BRANCH}/libc"
diff --git a/recipes/eglibc/eglibc_svn.bb b/recipes/eglibc/eglibc_svn.bb
index c5a4990761..0b1a77c342 100644
--- a/recipes/eglibc/eglibc_svn.bb
+++ b/recipes/eglibc/eglibc_svn.bb
@@ -5,13 +5,14 @@ SRCREV = "11461"
DEFAULT_PREFERENCE = "-1"
FILESPATHPKG =. "eglibc-svn:"
PV = "2.12+svnr${SRCPV}"
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
EGLIBC_BRANCH="trunk"
SRC_URI = "svn://svn.eglibc.org;module=${EGLIBC_BRANCH} \
file://eglibc-svn-arm-lowlevellock-include-tls.patch \
file://IO-acquire-lock-fix.patch \
file://sh4_set_fpscr_2.12.patch \
file://sh4_local-fpscr_values.patch \
+ file://armv4-eabi-compile-fix.patch \
file://etc/ld.so.conf \
file://generate-supported.mk"
S = "${WORKDIR}/${EGLIBC_BRANCH}/libc"