aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/lmbench/lmbench/rename-line-binary.patch11
-rw-r--r--recipes/lmbench/lmbench_3.0-a9.bb6
2 files changed, 15 insertions, 2 deletions
diff --git a/recipes/lmbench/lmbench/rename-line-binary.patch b/recipes/lmbench/lmbench/rename-line-binary.patch
new file mode 100644
index 0000000000..997143b3b0
--- /dev/null
+++ b/recipes/lmbench/lmbench/rename-line-binary.patch
@@ -0,0 +1,11 @@
+--- patches/scripts/config-run 2006-11-26 15:11:04.000000000 -0500
++++ patches/scripts/config-run 2011-04-01 09:35:50.000000000 -0400
+@@ -224,7 +224,7 @@ fi
+
+ echo "Hang on, we are calculating your cache line size."
+ ../bin/$OS/msleep 250
+-LINE_SIZE=`../bin/$OS/line -M ${MB}M`
++LINE_SIZE=`../bin/$OS/lm_line -M ${MB}M`
+ export LINE_SIZE
+ echo "OK, it looks like your cache line is $LINE_SIZE bytes."
+ echo ""
diff --git a/recipes/lmbench/lmbench_3.0-a9.bb b/recipes/lmbench/lmbench_3.0-a9.bb
index 1e2598ac65..d1e9162bbe 100644
--- a/recipes/lmbench/lmbench_3.0-a9.bb
+++ b/recipes/lmbench/lmbench_3.0-a9.bb
@@ -3,12 +3,13 @@ DESCRIPTION = "Tools for performance analysis."
LICENSE = "GPL"
RDEPENDS_${PN} = "debianutils"
-PR = "r2"
+PR = "r3"
inherit autotools
SRC_URI = "${SOURCEFORGE_MIRROR}/lmbench/lmbench-${PV}.tgz \
- file://lmbench-run"
+ file://lmbench-run \
+ file://rename-line-binary.patch"
SRC_URI[md5sum] = "b3351a3294db66a72e2864a199d37cbf"
SRC_URI[sha256sum] = "cbd5777d15f44eab7666dcac418054c3c09df99826961a397d9acf43d8a2a551"
@@ -56,6 +57,7 @@ do_install () {
install -m 0755 ${S}/scripts/lmbench ${D}${bindir}
install -d ${D}${datadir}/lmbench/scripts
install -m 0755 ${S}/scripts/* ${D}${datadir}/lmbench/scripts
+ mv ${D}${bindir}/line ${D}${bindir}/lm_line
}
FILES_${PN} += "${datadir}/lmbench"