aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/checksums.ini16
-rw-r--r--recipes/dash/dash_0.5.5.1.bb (renamed from recipes/dash/dash_0.5.2.bb)3
-rw-r--r--recipes/dash/files/makefile-build-cc.diff28
3 files changed, 28 insertions, 19 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index aa8b8cb61e..edff235d62 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -28726,3 +28726,19 @@ sha256=0c398b749574b6bd54f5c5ac1d71118400cd54791e2f47a96a1ad07915d22832
md5=b49f997897f5dfc2d2b8e0b6ea3df83c
sha256=56dcebb128d401cd5608fcd77739b42f9cfc5af531d85822287f631ad6328dcd
+[ftp://ftp.us.debian.org/debian/pool/main/d/diffstat/diffstat_1.47.orig.tar.gz]
+md5=c6d221ff4a032e1bbf227f5936a7841a
+sha256=0c398b749574b6bd54f5c5ac1d71118400cd54791e2f47a96a1ad07915d22832
+
+[ftp://ftp.us.debian.org/debian/pool/main/d/diffstat/diffstat_1.47-1.diff.gz]
+md5=b49f997897f5dfc2d2b8e0b6ea3df83c
+sha256=56dcebb128d401cd5608fcd77739b42f9cfc5af531d85822287f631ad6328dcd
+
+[http://ftp.debian.org/debian/pool/main/d/dash/dash_0.5.5.1.orig.tar.gz]
+md5=7ac832b440b91f5a52cf8eb68e172616
+sha256=1c6717a1014c73aa16bc78a4767f1e00b40ff2a01a6c2cf2cce9a5335c24493f
+
+[http://ftp.debian.org/debian/pool/main/d/dash/dash_0.5.5.1-2.3.diff.gz]
+md5=be9cf0b148f4127d06cede66241175c0
+sha256=afa02603f39a9557c65f88702f41190fa69e41ebe5d7729b4a52ab04573539c5
+
diff --git a/recipes/dash/dash_0.5.2.bb b/recipes/dash/dash_0.5.5.1.bb
index ee4e8c1bd6..7a88407925 100644
--- a/recipes/dash/dash_0.5.2.bb
+++ b/recipes/dash/dash_0.5.5.1.bb
@@ -1,10 +1,9 @@
DESCRIPTION = "The Debian Almquist Shell is a POSIX compliant shell that is much smaller than 'bash'."
PROVIDES = "virtual/sh"
LICENSE = "BSD GPL"
-PR = "r1"
SRC_URI = "http://ftp.debian.org/debian/pool/main/d/dash/dash_${PV}.orig.tar.gz \
- http://snapshot.debian.net/archive/2005/07/11/debian/pool/main/d/dash/dash_0.5.2-6.diff.gz;patch=1 \
+ http://ftp.debian.org/debian/pool/main/d/dash/dash_${PV}-2.3.diff.gz;patch=1 \
file://makefile-build-cc.diff;patch=1"
inherit autotools
diff --git a/recipes/dash/files/makefile-build-cc.diff b/recipes/dash/files/makefile-build-cc.diff
index 8ffd6c2c37..a980a83324 100644
--- a/recipes/dash/files/makefile-build-cc.diff
+++ b/recipes/dash/files/makefile-build-cc.diff
@@ -1,29 +1,23 @@
---- dash-0.5.1/src/Makefile.am.orig 2004-07-03 05:13:27.000000000 +0200
-+++ dash-0.5.1/src/Makefile.am 2005-01-11 11:14:11.896299544 +0100
-@@ -3,6 +3,7 @@
- AM_CPPFLAGS = -include $(top_builddir)/config.h
- AM_YFLAGS = -d
-
-+BUILD_CC ?= gcc
- CFLAGS = -g -O2 -Wall
- DEFS = \
- -DBSD=1 -DSMALL -DSHELL \
-@@ -35,6 +36,18 @@
- mktokens mkbuiltins builtins.def mkinit.c \
+Index: dash-0.5.5.1/src/Makefile.am
+===================================================================
+--- dash-0.5.5.1.orig/src/Makefile.am 2009-01-13 15:37:13.000000000 -0800
++++ dash-0.5.5.1/src/Makefile.am 2009-08-26 23:56:58.879275498 -0700
+@@ -44,6 +44,18 @@
+ mktokens mkbuiltins builtins.def.in mkinit.c \
mknodes.c nodetypes nodes.c.pat mksyntax.c mksignames.c
+mknodes:
-+ $(BUILD_CC) mknodes.c -o mknodes
++ $(COMPILE_FOR_BUILD) mknodes.c -o mknodes
+
+mksyntax:
-+ $(BUILD_CC) mksyntax.c -o mksyntax
++ $(COMPILE_FOR_BUILD) mksyntax.c -o mksyntax
+
+mkinit:
-+ $(BUILD_CC) mkinit.c -o mkinit
++ $(COMPILE_FOR_BUILD) mkinit.c -o mkinit
+
+mksignames:
-+ $(BUILD_CC) mksignames.c -o mksignames
-+
++ $(COMPILE_FOR_BUILD) mksignames.c -o mksignames
++
token.h: mktokens
sh $^