aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/update-rc.d.bbclass2
-rw-r--r--conf/documentation.conf2
-rw-r--r--packages/flex/flex-native_2.5.31.bb9
-rw-r--r--packages/flex/flex.inc8
-rw-r--r--packages/flex/flex_2.5.31.bb9
-rw-r--r--packages/gkdial/gkdial_1.8.1.bb2
-rw-r--r--packages/wireless-tools/wireless-tools_28-pre6.bb43
-rw-r--r--packages/wpa-supplicant/wpa-supplicant_cvs.bb6
8 files changed, 66 insertions, 15 deletions
diff --git a/classes/update-rc.d.bbclass b/classes/update-rc.d.bbclass
index 7583c88f83..a41dd7850c 100644
--- a/classes/update-rc.d.bbclass
+++ b/classes/update-rc.d.bbclass
@@ -48,7 +48,7 @@ python populate_packages_prepend () {
if not prerm:
prerm = '#!/bin/sh\n'
prerm += bb.data.getVar('updatercd_prerm', localdata, 1)
- bb.data.setVar('pkg_prerm%s' % pkg, prerm, d)
+ bb.data.setVar('pkg_prerm_%s' % pkg, prerm, d)
pkgs = bb.data.getVar('INITSCRIPT_PACKAGES', d, 1)
if pkgs == None:
diff --git a/conf/documentation.conf b/conf/documentation.conf
index f3c31ce609..1da4e2d306 100644
--- a/conf/documentation.conf
+++ b/conf/documentation.conf
@@ -14,7 +14,7 @@ BUILD_PREFIX[doc] = "FIXME"
BUILD_CC_ARCH[doc] = "FIXME"
HOST_ARCH[doc] = "The name of the target architecture. Normally same as the TARGET_ARCH (@see TARGET_ARCH)"
-HOST_OS[doc] = "The name of the target operating system. Normall same as the TARGET_OS \
+HOST_OS[doc] = "The name of the target operating system. Normally the same as the TARGET_OS \
(@see TARGET_OS)"
HOST_VENDOR[doc] = "The name of the vendor. Normally same as the TARGET_VENDOR (@see TARGET_VENDOR)"
HOST_SYS[doc] = "FIXME"
diff --git a/packages/flex/flex-native_2.5.31.bb b/packages/flex/flex-native_2.5.31.bb
index 28dcda51d2..fa125d6be7 100644
--- a/packages/flex/flex-native_2.5.31.bb
+++ b/packages/flex/flex-native_2.5.31.bb
@@ -1,4 +1,11 @@
include flex.inc
inherit native
-PR = "r0"
+PR = "r1"
+
+do_stage () {
+ install -m 0755 flex ${STAGING_BINDIR}
+ oe_libinstall -a libfl ${STAGING_LIBDIR}
+ ln -sf ./flex ${STAGING_BINDIR}/flex++
+ ln -sf ./flex ${STAGING_BINDIR}/lex
+}
diff --git a/packages/flex/flex.inc b/packages/flex/flex.inc
index 41beef3245..8f84eb1996 100644
--- a/packages/flex/flex.inc
+++ b/packages/flex/flex.inc
@@ -5,11 +5,5 @@ LICENSE = "BSD"
SRC_URI = "http://mesh.dl.sf.net/lex/flex-2.5.31.tar.bz2"
S = "${WORKDIR}/flex-${PV}"
-inherit native autotools
+inherit autotools
-do_stage () {
- install -m 0755 flex ${STAGING_BINDIR}
- oe_libinstall -a libfl ${STAGING_LIBDIR}
- ln -sf ./flex ${STAGING_BINDIR}/flex++
- ln -sf ./flex ${STAGING_BINDIR}/lex
-}
diff --git a/packages/flex/flex_2.5.31.bb b/packages/flex/flex_2.5.31.bb
index b7c316fb1b..8349355b89 100644
--- a/packages/flex/flex_2.5.31.bb
+++ b/packages/flex/flex_2.5.31.bb
@@ -1,2 +1,9 @@
+BROKEN_arm="1"
+
+# On ARM I got:
+#
+# tables.c: In function `yytbl_write16':
+# tables.c:313: internal compiler error: in arm_print_operand, at config/arm/arm.c:11410
+
include flex.inc
-PR = "r0"
+PR = "r1"
diff --git a/packages/gkdial/gkdial_1.8.1.bb b/packages/gkdial/gkdial_1.8.1.bb
index 15ca1612e8..ac37080d11 100644
--- a/packages/gkdial/gkdial_1.8.1.bb
+++ b/packages/gkdial/gkdial_1.8.1.bb
@@ -9,7 +9,7 @@ PRIORITY = "optional"
PR = "r2gpe1"
-SRC_URI = "http://gkdial.sourceforge.net/downloads/${PN}-${PV}.tar.gz \
+SRC_URI = "http://familiar.handhelds.org/source/v0.8.2/${PN}-${PV}.tar.gz \
file://gkdial-pgpe.patch;patch=1 \
file://gkdial-ungnome.patch;patch=1;pnum=0 \
file://gkdial-gladedir.patch;patch=1;pnum=0 \
diff --git a/packages/wireless-tools/wireless-tools_28-pre6.bb b/packages/wireless-tools/wireless-tools_28-pre6.bb
index e69de29bb2..f230cd307b 100644
--- a/packages/wireless-tools/wireless-tools_28-pre6.bb
+++ b/packages/wireless-tools/wireless-tools_28-pre6.bb
@@ -0,0 +1,43 @@
+DESCRIPTION = "Tools for the Linux Standard Wireless Extension Subsystem"
+HOMEPAGE = "http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux/Tools.html"
+SECTION = "base"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "GPL"
+PR = "r1"
+
+SRC_URI = "http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux/wireless_tools.28.pre6.tar.gz \
+ file://man.patch;patch=1 \
+ file://fixheaders.patch;patch=1 \
+ file://wireless-tools.if-pre-up"
+S = "${WORKDIR}/wireless_tools.28"
+
+CFLAGS =+ "-I${S}"
+EXTRA_OEMAKE = "-e 'BUILD_SHARED=y' \
+ 'INSTALL_DIR=${D}${base_sbindir}' \
+ 'INSTALL_LIB=${D}${libdir}' \
+ 'INSTALL_INC=${D}${includedir}' \
+ 'INSTALL_MAN=${D}${mandir}'"
+
+do_compile() {
+ oe_runmake all libiw.a
+}
+
+do_stage () {
+ install -m 0644 wireless.h ${STAGING_INCDIR}/
+ install -m 0644 iwlib.h ${STAGING_INCDIR}/
+ oe_libinstall -a -so libiw ${STAGING_LIBDIR}/
+}
+
+do_install() {
+ oe_runmake PREFIX=${D} install-iwmulticall install-dynamic
+ install -d ${D}${sysconfdir}/network/if-pre-up.d
+ install ${WORKDIR}/wireless-tools.if-pre-up ${D}${sysconfdir}/network/if-pre-up.d/wireless-tools
+}
+
+PACKAGES = "libiw libiw-dev libiw-doc ${PN} ${PN}-doc"
+FILES_libiw = "${libdir}/*.so.*"
+FILES_libiw-dev = "${libdir}/*.a ${libdir}/*.so ${includedir}"
+FILES_libiw-doc = "${mandir}/man7"
+FILES_${PN} = "${bindir} ${sbindir} ${base_sbindir} ${base_bindir} ${sysconfdir}/network"
+FILES_${PN}-doc = "${mandir}/man8"
diff --git a/packages/wpa-supplicant/wpa-supplicant_cvs.bb b/packages/wpa-supplicant/wpa-supplicant_cvs.bb
index 6696df6d0c..c558d4e834 100644
--- a/packages/wpa-supplicant/wpa-supplicant_cvs.bb
+++ b/packages/wpa-supplicant/wpa-supplicant_cvs.bb
@@ -5,7 +5,7 @@ MAINTAINER = "Holger Schurig"
HOMEPAGE = "http://hostap.epitest.fi/wpa_supplicant/"
DEPENDS = "openssl"
PV = "0.0cvs${CVSDATE}"
-PR = "r1"
+PR = "r2"
SRC_URI = "cvs://anonymous@hostap.epitest.fi/cvs;module=hostap \
file://use-channel.patch;patch=1 \
@@ -54,6 +54,6 @@ do_install () {
install -d ${D}${sysconfdir}/init.d
install -m700 ${WORKDIR}/init.sh ${D}${sysconfdir}/init.d/wpa
- install -d ${D}${sysconfdir}/defaults
- install -m600 ${WORKDIR}/defaults ${D}${sysconfdir}/defaults/wpa
+ install -d ${D}${sysconfdir}/default
+ install -m600 ${WORKDIR}/defaults ${D}${sysconfdir}/default/wpa
}