aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/distro/include/fso-autorev.inc2
-rw-r--r--recipes/android/android-image-utils-native_git.bb19
2 files changed, 21 insertions, 0 deletions
diff --git a/conf/distro/include/fso-autorev.inc b/conf/distro/include/fso-autorev.inc
index fe231d6be6..cb02400e2f 100644
--- a/conf/distro/include/fso-autorev.inc
+++ b/conf/distro/include/fso-autorev.inc
@@ -1,4 +1,5 @@
# FSO
+SRCREV_pn-android-image-utils-native = "${AUTOREV}"
SRCREV_pn-dbus-hlid = "${AUTOREV}"
SRCREV_pn-frameworkd = "${AUTOREV}"
SRCREV_pn-frameworkd-devel = "${AUTOREV}"
@@ -21,6 +22,7 @@ SRCREV_pn-fso-specs = "${AUTOREV}"
SRCREV_pn-gsmd2 = "${AUTOREV}"
SRCREV_pn-illume-theme-freesmartphone = "${AUTOREV}"
SRCREV_pn-libascenario = "${AUTOREV}"
+SRCREV_pn-libeflvala = "${AUTOREV}"
SRCREV_pn-libfsobasics = "${AUTOREV}"
SRCREV_pn-libfsoframework = "${AUTOREV}"
SRCREV_pn-libfsoresource = "${AUTOREV}"
diff --git a/recipes/android/android-image-utils-native_git.bb b/recipes/android/android-image-utils-native_git.bb
new file mode 100644
index 0000000000..3b39886278
--- /dev/null
+++ b/recipes/android/android-image-utils-native_git.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Android Image Creation and Booting Utilities"
+SECTION = "console/utils"
+LICENSE = "GPL"
+PV = "1.0+gitr${SRCREV}"
+PR = "r0"
+
+SRC_URI = "\
+ ${FREESMARTPHONE_GIT}/utilities.git;protocol=git;branch=master \
+"
+S = "${WORKDIR}/git/android/image-utils"
+
+inherit autotools_stage native
+
+do_deploy () {
+ install -d ${DEPLOY_DIR_IMAGE}
+ install -m 0755 fastboot ${DEPLOY_DIR_IMAGE}
+}
+do_deploy[dirs] = "${S}"
+addtask deploy before do_build after do_compile