aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/xorg-lib/pixman.inc13
-rw-r--r--recipes/xorg-lib/pixman_0.10.0.bb15
-rw-r--r--recipes/xorg-lib/pixman_0.11.4.bb15
-rw-r--r--recipes/xorg-lib/pixman_0.11.8.bb18
-rw-r--r--recipes/xorg-lib/pixman_0.12.0.bb16
-rw-r--r--recipes/xorg-lib/pixman_0.13.2.bb22
-rw-r--r--recipes/xorg-lib/pixman_0.15.18.bb13
-rw-r--r--recipes/xorg-lib/pixman_0.15.6.bb13
-rw-r--r--recipes/xorg-lib/pixman_0.16.2.bb17
-rw-r--r--recipes/xorg-lib/pixman_0.17.12.bb25
-rw-r--r--recipes/xorg-lib/pixman_0.17.8.bb17
-rw-r--r--recipes/xorg-lib/pixman_0.9.6.bb15
-rw-r--r--recipes/xorg-lib/pixman_git.bb15
13 files changed, 67 insertions, 147 deletions
diff --git a/recipes/xorg-lib/pixman.inc b/recipes/xorg-lib/pixman.inc
new file mode 100644
index 0000000000..1828eef4ce
--- /dev/null
+++ b/recipes/xorg-lib/pixman.inc
@@ -0,0 +1,13 @@
+SECTION = "libs"
+PRIORITY = "optional"
+DESCRIPTION = "Low-level pixel manipulation library."
+LICENSE = "X11"
+
+BBCLASSEXTEND="native"
+
+SRC_URI = "http://cairographics.org/releases/${BPN}-${PV}.tar.gz;name=archive "
+
+INC_PR = "r5"
+
+inherit autotools_stage pkgconfig
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
diff --git a/recipes/xorg-lib/pixman_0.10.0.bb b/recipes/xorg-lib/pixman_0.10.0.bb
index 35f62990b5..b1ac2eb5bd 100644
--- a/recipes/xorg-lib/pixman_0.10.0.bb
+++ b/recipes/xorg-lib/pixman_0.10.0.bb
@@ -1,13 +1,2 @@
-SECTION = "libs"
-PRIORITY = "optional"
-DESCRIPTION = "Low-level pixel manipulation library."
-LICENSE = "X11"
-
-SRC_URI = "http://cairographics.org/releases/pixman-${PV}.tar.gz"
-
-inherit autotools pkgconfig
-
-do_stage () {
- autotools_stage_all
-}
-
+require pixman.inc
+PR = "${INC_PR}.0"
diff --git a/recipes/xorg-lib/pixman_0.11.4.bb b/recipes/xorg-lib/pixman_0.11.4.bb
index d9da96718f..873a57df6e 100644
--- a/recipes/xorg-lib/pixman_0.11.4.bb
+++ b/recipes/xorg-lib/pixman_0.11.4.bb
@@ -1,15 +1,4 @@
-SECTION = "libs"
-PRIORITY = "optional"
-DESCRIPTION = "Low-level pixel manipulation library."
-LICENSE = "X11"
+require pixman.inc
+PR = "${INC_PR}.0"
DEFAULT_PREFERENCE = "-1"
-
-SRC_URI = "http://cairographics.org/releases/pixman-${PV}.tar.gz"
-
-inherit autotools pkgconfig
-
-do_stage () {
- autotools_stage_all
-}
-
diff --git a/recipes/xorg-lib/pixman_0.11.8.bb b/recipes/xorg-lib/pixman_0.11.8.bb
index 239684e71f..b3413dea10 100644
--- a/recipes/xorg-lib/pixman_0.11.8.bb
+++ b/recipes/xorg-lib/pixman_0.11.8.bb
@@ -1,19 +1,7 @@
-SECTION = "libs"
-PRIORITY = "optional"
-DESCRIPTION = "Low-level pixel manipulation library."
-LICENSE = "X11"
+require pixman.inc
+PR = "${INC_PR}.0"
-PR = "r4"
-
-SRC_URI = "http://cairographics.org/releases/pixman-${PV}.tar.gz \
+SRC_URI += " \
file://pixman-arm.patch;patch=1 \
file://pixman-x888-565.patch;patch=1 \
"
-
-inherit autotools
-
-AUTOTOOLS_STAGE_PKGCONFIG = "1"
-do_stage () {
- autotools_stage_all
-}
-
diff --git a/recipes/xorg-lib/pixman_0.12.0.bb b/recipes/xorg-lib/pixman_0.12.0.bb
index 5d43adba30..b3413dea10 100644
--- a/recipes/xorg-lib/pixman_0.12.0.bb
+++ b/recipes/xorg-lib/pixman_0.12.0.bb
@@ -1,17 +1,7 @@
-SECTION = "libs"
-PRIORITY = "optional"
-DESCRIPTION = "Low-level pixel manipulation library."
-LICENSE = "X11"
+require pixman.inc
+PR = "${INC_PR}.0"
-SRC_URI = "http://cairographics.org/releases/pixman-${PV}.tar.gz \
+SRC_URI += " \
file://pixman-arm.patch;patch=1 \
file://pixman-x888-565.patch;patch=1 \
"
-
-inherit autotools
-
-AUTOTOOLS_STAGE_PKGCONFIG = "1"
-do_stage () {
- autotools_stage_all
-}
-
diff --git a/recipes/xorg-lib/pixman_0.13.2.bb b/recipes/xorg-lib/pixman_0.13.2.bb
index 4b489f89a6..87ffda4748 100644
--- a/recipes/xorg-lib/pixman_0.13.2.bb
+++ b/recipes/xorg-lib/pixman_0.13.2.bb
@@ -1,23 +1,11 @@
-SECTION = "libs"
-PRIORITY = "optional"
-DESCRIPTION = "Low-level pixel manipulation library."
-LICENSE = "X11"
-
-PR = "r2"
+require pixman.inc
+PR = "${INC_PR}.0"
DEFAULT_PREFERENCE = "-1"
-SRC_URI = "http://cairographics.org/releases/pixman-${PV}.tar.gz \
- file://pixman-0.13.2-neon1.patch;patch=1 \
- "
-
-inherit autotools
+SRC_URI += " \
+ file://pixman-0.13.2-neon1.patch;patch=1 \
+ "
# We have NEON
EXTRA_OECONF_append_armv7a = " --disable-arm-simd"
-
-AUTOTOOLS_STAGE_PKGCONFIG = "1"
-do_stage () {
- autotools_stage_all
-}
-
diff --git a/recipes/xorg-lib/pixman_0.15.18.bb b/recipes/xorg-lib/pixman_0.15.18.bb
index 2517f8f354..873a57df6e 100644
--- a/recipes/xorg-lib/pixman_0.15.18.bb
+++ b/recipes/xorg-lib/pixman_0.15.18.bb
@@ -1,13 +1,4 @@
-SECTION = "libs"
-PRIORITY = "optional"
-DESCRIPTION = "Low-level pixel manipulation library."
-LICENSE = "X11"
+require pixman.inc
+PR = "${INC_PR}.0"
DEFAULT_PREFERENCE = "-1"
-
-SRC_URI = "http://cairographics.org/releases/pixman-${PV}.tar.gz \
- "
-
-inherit autotools_stage
-AUTOTOOLS_STAGE_PKGCONFIG = "1"
-
diff --git a/recipes/xorg-lib/pixman_0.15.6.bb b/recipes/xorg-lib/pixman_0.15.6.bb
index 2517f8f354..873a57df6e 100644
--- a/recipes/xorg-lib/pixman_0.15.6.bb
+++ b/recipes/xorg-lib/pixman_0.15.6.bb
@@ -1,13 +1,4 @@
-SECTION = "libs"
-PRIORITY = "optional"
-DESCRIPTION = "Low-level pixel manipulation library."
-LICENSE = "X11"
+require pixman.inc
+PR = "${INC_PR}.0"
DEFAULT_PREFERENCE = "-1"
-
-SRC_URI = "http://cairographics.org/releases/pixman-${PV}.tar.gz \
- "
-
-inherit autotools_stage
-AUTOTOOLS_STAGE_PKGCONFIG = "1"
-
diff --git a/recipes/xorg-lib/pixman_0.16.2.bb b/recipes/xorg-lib/pixman_0.16.2.bb
index 1a15ac4a96..b1ac2eb5bd 100644
--- a/recipes/xorg-lib/pixman_0.16.2.bb
+++ b/recipes/xorg-lib/pixman_0.16.2.bb
@@ -1,15 +1,2 @@
-SECTION = "libs"
-PRIORITY = "optional"
-DESCRIPTION = "Low-level pixel manipulation library."
-LICENSE = "X11"
-
-PR = "r1"
-
-BBCLASSEXTEND="native"
-
-SRC_URI = "http://cairographics.org/releases/pixman-${PV}.tar.gz \
- "
-
-inherit autotools_stage
-AUTOTOOLS_STAGE_PKGCONFIG = "1"
-
+require pixman.inc
+PR = "${INC_PR}.0"
diff --git a/recipes/xorg-lib/pixman_0.17.12.bb b/recipes/xorg-lib/pixman_0.17.12.bb
new file mode 100644
index 0000000000..dbaf36a561
--- /dev/null
+++ b/recipes/xorg-lib/pixman_0.17.12.bb
@@ -0,0 +1,25 @@
+require pixman.inc
+PR = "${INC_PR}.0"
+
+DEFAULT_PREFERENCE = "-1"
+DEFAULT_PREFERENCE_angstrom = "2"
+DEFAULT_PREFERENCE_shr = "2"
+
+SRC_URI += "\
+ file://0001-Generic-C-implementation-of-pixman_blt-with-overlapp.patch;patch=1 \
+ file://0002-Support-of-overlapping-src-dst-for-pixman_blt_mmx.patch;patch=1 \
+ file://0003-Support-of-overlapping-src-dst-for-pixman_blt_sse2.patch;patch=1 \
+ file://0004-Support-of-overlapping-src-dst-for-pixman_blt_neon.patch;patch=1 \
+ file://0005-ARM-added-NEON-optimizations-for-fetch-store-r5g6b5-.patch;patch=1 \
+ file://0006-Revert-ARM-SIMD-Try-without-any-CFLAGS-before-forcin.patch;patch=1 \
+ file://over-n-8-0565.patch;patch=1 \
+ file://src-8888-0565.patch;patch=1 \
+"
+
+SRC_URI[archive.md5sum] = "331415d7a110145cf27aa00e11d0a683"
+SRC_URI[archive.sha256sum] = "8cce103af1b4200a13bedca5b763f74c9bc99a55985ab44ca92ba532dac6b57f"
+
+NEON = " --disable-arm-neon "
+NEON_armv7a = " "
+
+EXTRA_OECONF = "${NEON} --disable-gtk"
diff --git a/recipes/xorg-lib/pixman_0.17.8.bb b/recipes/xorg-lib/pixman_0.17.8.bb
index adc0c4e301..eb3fe85a20 100644
--- a/recipes/xorg-lib/pixman_0.17.8.bb
+++ b/recipes/xorg-lib/pixman_0.17.8.bb
@@ -1,17 +1,11 @@
-SECTION = "libs"
-PRIORITY = "optional"
-DESCRIPTION = "Low-level pixel manipulation library."
-LICENSE = "X11"
-
-PR = "r1"
+require pixman.inc
+PR = "${INC_PR}.0"
DEFAULT_PREFERENCE = "-1"
DEFAULT_PREFERENCE_angstrom = "2"
DEFAULT_PREFERENCE_shr = "2"
-BBCLASSEXTEND="native"
-
-SRC_URI = "http://cairographics.org/releases/pixman-${PV}.tar.gz;name=archive \
+SRC_URI += " \
file://0003-Generic-C-implementation-of-pixman_blt-with-overlapp.patch;patch=1 \
file://0004-Support-of-overlapping-src-dst-for-pixman_blt_mmx.patch;patch=1 \
file://0005-Support-of-overlapping-src-dst-for-pixman_blt_sse2.patch;patch=1 \
@@ -24,10 +18,7 @@ SRC_URI = "http://cairographics.org/releases/pixman-${PV}.tar.gz;name=archive \
SRC_URI[archive.md5sum] = "a7deb2ff6b286b676d67aa6ae91317ae"
SRC_URI[archive.sha256sum] = "ea24e9003455a0881bd43bf7e4169f2b34c90c8521405103e3490553876a81b4"
-inherit autotools
-
NEON = " --disable-arm-neon "
-NEON_armv7a = ""
+NEON_armv7a = " "
EXTRA_OECONF = "${NEON} --disable-gtk"
-
diff --git a/recipes/xorg-lib/pixman_0.9.6.bb b/recipes/xorg-lib/pixman_0.9.6.bb
index 1269ff46a7..76ec2955f4 100644
--- a/recipes/xorg-lib/pixman_0.9.6.bb
+++ b/recipes/xorg-lib/pixman_0.9.6.bb
@@ -1,14 +1,3 @@
-SECTION = "libs"
-PRIORITY = "optional"
-DESCRIPTION = "Low-level pixel manipulation library."
-LICENSE = "X11"
-
-SRC_URI = "http://cairographics.org/releases/pixman-${PV}.tar.gz"
+require pixman.inc
+PR = "${INC_PR}.0"
S = "${WORKDIR}/pixman-${PV}"
-
-inherit autotools pkgconfig
-
-do_stage () {
- autotools_stage_all
-}
-
diff --git a/recipes/xorg-lib/pixman_git.bb b/recipes/xorg-lib/pixman_git.bb
index 543cf50f9f..70886edc31 100644
--- a/recipes/xorg-lib/pixman_git.bb
+++ b/recipes/xorg-lib/pixman_git.bb
@@ -1,14 +1,8 @@
-SECTION = "libs"
-PRIORITY = "optional"
-DESCRIPTION = "Low-level pixel manipulation library."
-LICENSE = "X11"
-
+require pixman.inc
PV = "0.17.13"
-PR = "r1"
+PR = "${INC_PR}.0"
PR_append = "+gitr${SRCREV}"
-BBCLASSEXTEND="native"
-
SRCREV = "69f1ec9a7827aeb522fcae99846237ef0f896e7b"
DEFAULT_PREFERENCE = "-1"
@@ -26,12 +20,7 @@ SRC_URI = "git://anongit.freedesktop.org/pixman;protocol=git;branch=master \
S = "${WORKDIR}/git"
-inherit autotools_stage
-
NEON = " --disable-arm-neon "
NEON_armv7a = " "
EXTRA_OECONF = "${NEON} --disable-gtk"
-
-AUTOTOOLS_STAGE_PKGCONFIG = "1"
-