aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/checksums.ini4
-rw-r--r--recipes/lyx/lyx/qt4tools-detect.diff15
-rw-r--r--recipes/lyx/lyx_1.6.4.1.bb28
3 files changed, 47 insertions, 0 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index 19958c8081..b986e3a709 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -17054,6 +17054,10 @@ sha256=d720ff082ed29d385c52e7ad370499d23275e595e9d7a321b383609f68acf23e
md5=fdac2fc40b435857afa1089fc04c1fcb
sha256=8f45da9653fc9ea927f3b8c7c96390fc8277d7c969b735a7b615c06e4e5c03d7
+[ftp://ftp.lyx.org/pub/lyx/stable/1.6.x/lyx-1.6.4.1.tar.bz2]
+md5=c1a0da5aee3b7e1a2f74e8018805c7b1
+sha256=56f3120f814de0fc55866d92b08b2513ad0d0532fc6675aeaf36154eb73c403b
+
[http://downloads.sourceforge.net/sevenzip/lzma417.tar.bz2]
md5=b1ab85e4dc1eb1323d77fef47a2cb71c
sha256=84124d4501798ecb284fceb28931db023850535e1b1146c884add7b3b0331cbc
diff --git a/recipes/lyx/lyx/qt4tools-detect.diff b/recipes/lyx/lyx/qt4tools-detect.diff
new file mode 100644
index 0000000000..3c0110a40d
--- /dev/null
+++ b/recipes/lyx/lyx/qt4tools-detect.diff
@@ -0,0 +1,15 @@
+--- /tmp/qt4.m4 2009-10-22 22:45:15.000000000 +0200
++++ lyx-1.6.4.1/config/qt4.m4 2009-10-22 22:46:23.000000000 +0200
+@@ -138,9 +138,9 @@
+ if test "$pkg_failed" != "no" ; then
+ QT4_DO_MANUAL_CONFIG
+ fi
+- AC_PATH_PROGS(MOC4, [moc-qt4 moc],[],$qt4_cv_bin:$PATH)
+- AC_PATH_PROGS(UIC4, [uic-qt4 uic],[],$qt4_cv_bin:$PATH)
+- AC_PATH_PROGS(RCC4, [rcc-qt4 rcc],[],$qt4_cv_bin:$PATH)
++ AC_PATH_PROGS(MOC4, [moc-qt4 moc4],[],$qt4_cv_bin:$PATH)
++ AC_PATH_PROGS(UIC4, [uic-qt4 uic4],[],$qt4_cv_bin:$PATH)
++ AC_PATH_PROGS(RCC4, [rcc-qt4 rcc4],[],$qt4_cv_bin:$PATH)
+ ])
+
+ AC_DEFUN([QT4_DO_PKG_CONFIG],
diff --git a/recipes/lyx/lyx_1.6.4.1.bb b/recipes/lyx/lyx_1.6.4.1.bb
new file mode 100644
index 0000000000..8f37ceeddc
--- /dev/null
+++ b/recipes/lyx/lyx_1.6.4.1.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "LyX is an advanced type setting processor - a frontend for LaTeX"
+SECTION = "x11/office"
+LICENSE = "GPL"
+HOMEPAGE = "http://www.lyx.org"
+DEPENDS = "qt4-x11-free"
+RSUGGESTS = "tetex"
+RDEPENDS = "python-shell python-textutils"
+
+SRC_URI = "\
+ ftp://ftp.lyx.org/pub/lyx/stable/1.6.x/lyx-${PV}.tar.bz2 \
+ file://no-session-manager.patch;patch=1 \
+ file://qt4tools-detect.diff;patch=1 \
+"
+
+inherit qt4x11 autotools
+
+EXTRA_OECONF = "\
+ --with-qt4-dir=${QTDIR} \
+ --enable-threads=posix \
+"
+
+do_configure_prepend() {
+ rm -f ${S}/config/libtool.m4
+}
+
+EXTRA_QMAKEVARS_POST = "DEFINES+=_LIBC"
+PARALLEL_MAKE = ""
+