aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/ntpclient/files/fix-adjtimex-uclibc.patch22
-rw-r--r--recipes/ntpclient/ntpclient_2007_365.bb10
2 files changed, 30 insertions, 2 deletions
diff --git a/recipes/ntpclient/files/fix-adjtimex-uclibc.patch b/recipes/ntpclient/files/fix-adjtimex-uclibc.patch
new file mode 100644
index 0000000000..49472c9d4c
--- /dev/null
+++ b/recipes/ntpclient/files/fix-adjtimex-uclibc.patch
@@ -0,0 +1,22 @@
+Index: ntpclient-2007/ntpclient.c
+===================================================================
+--- ntpclient-2007.orig/ntpclient.c 2010-10-01 17:25:20.000000000 +0200
++++ ntpclient-2007/ntpclient.c 2010-10-01 17:25:38.000000000 +0200
+@@ -146,7 +146,7 @@
+ #ifdef __linux__
+ struct timex txc;
+ txc.modes=0;
+- if (__adjtimex(&txc) < 0) {
++ if (adjtimex(&txc) < 0) {
+ perror("adjtimex"); exit(1);
+ }
+ return txc.freq;
+@@ -163,7 +163,7 @@
+ struct timex txc;
+ txc.modes = ADJ_FREQUENCY;
+ txc.freq = new_freq;
+- if (__adjtimex(&txc) < 0) {
++ if (adjtimex(&txc) < 0) {
+ perror("adjtimex"); exit(1);
+ }
+ return txc.freq;
diff --git a/recipes/ntpclient/ntpclient_2007_365.bb b/recipes/ntpclient/ntpclient_2007_365.bb
index 40a4e1b933..9d3824530d 100644
--- a/recipes/ntpclient/ntpclient_2007_365.bb
+++ b/recipes/ntpclient/ntpclient_2007_365.bb
@@ -4,14 +4,20 @@ AUTHOR = "Larry Doolittle <larry@doolittle.boa.org>"
RDEPENDS_${PN} = "busybox"
SECTION = "admin"
LICENSE = "GPLv2"
-PR = "r3"
+PR = "r4"
# The ntpclient package uses version numbers that include an underscore :(
PV = "2007_365"
# ntpclient unpacks into a directory that doesn't include version info :(
S = "${WORKDIR}/${PN}-2007"
SRC_URI = "http://doolittle.icarus.com/ntpclient/ntpclient_${PV}.tar.gz \
- file://init"
+ file://init \
+ "
+
+UCLIBC_PATCHES = " file://fix-adjtimex-uclibc.patch \
+ "
+SRC_URI_append_linux-uclibc = ${UCLIBC_PATCHES}
+SRC_URI_append_linux-uclibceabi = ${UCLIBC_PATCHES}
INITSCRIPT_NAME = "ntpclient"
INITSCRIPT_PARAMS = "defaults 65"