aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/lua/lua-filesystem-1.5.0/makefile.patch23
-rw-r--r--recipes/lua/lua-filesystem_1.5.0.bb25
2 files changed, 48 insertions, 0 deletions
diff --git a/recipes/lua/lua-filesystem-1.5.0/makefile.patch b/recipes/lua/lua-filesystem-1.5.0/makefile.patch
new file mode 100644
index 0000000000..64154e1b9a
--- /dev/null
+++ b/recipes/lua/lua-filesystem-1.5.0/makefile.patch
@@ -0,0 +1,23 @@
+Index: git/config
+===================================================================
+--- git.orig/config 2010-09-25 17:50:51.000000000 +0200
++++ git/config 2010-09-25 17:51:15.000000000 +0200
+@@ -1,7 +1,7 @@
+ # Installation directories
+
+ # Default installation prefix
+-PREFIX=/usr/local
++#PREFIX=/usr/local
+
+ # System's libraries directory (where binary libraries are installed)
+ LUA_LIBDIR= $(PREFIX)/lib/lua/5.1
+@@ -18,7 +18,7 @@
+ # Compilation directives
+ WARN= -O2 -Wall -fPIC -W -Waggregate-return -Wcast-align -Wmissing-prototypes -Wnested-externs -Wshadow -Wwrite-strings -pedantic
+ INCS= -I$(LUA_INC)
+-CFLAGS= $(WARN) $(INCS)
+-CC= gcc
++CFLAGS= $(WARN) $(INCS) $(MYFLAGS)
++#CC= gcc
+
+ # $Id: config,v 1.21 2007/10/27 22:42:32 carregal Exp $
diff --git a/recipes/lua/lua-filesystem_1.5.0.bb b/recipes/lua/lua-filesystem_1.5.0.bb
new file mode 100644
index 0000000000..83050091d0
--- /dev/null
+++ b/recipes/lua/lua-filesystem_1.5.0.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "LuaFileSystem is a Lua library with set of functions related to file systems operations."
+LICENSE = "MIT"
+HOMEPAGE = "http://keplerproject.org/luafilesystem"
+
+DEPENDS += "lua5.1"
+
+SRC_URI = "git://github.com/keplerproject/luafilesystem.git;protocol=git \
+ file://makefile.patch "
+
+SRCREV = "ae5a05deec8a3737bd6972213b5495108b6566cc"
+S = "${WORKDIR}/git/"
+
+LUA_LIB_DIR = "/usr/local/lib/lua/5.1"
+
+PACKAGES = "${PN} ${PN}-dbg"
+FILES_${PN}-dbg = "${LUA_LIB_DIR}/.debug/lfs.so"
+FILES_${PN} = "${LUA_LIB_DIR}/lfs.so"
+
+EXTRA_OEMAKE = "PREFIX='${D}/usr/local' MYFLAGS='${CFLAGS} ${LDFLAGS}'"
+
+do_install() {
+ oe_runmake install PREFIX=${D}/usr/local
+ install -d ${D}/${docdir}/${PN}-${PV}
+ install -m 0644 doc/us/* ${D}/${docdir}/${PN}-${PV}
+}