aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/clearsilver/clearsilver_0.10.3.bb6
-rw-r--r--recipes/clearsilver/files/crosscompile.patch2
2 files changed, 4 insertions, 4 deletions
diff --git a/recipes/clearsilver/clearsilver_0.10.3.bb b/recipes/clearsilver/clearsilver_0.10.3.bb
index 6c41497ef4..752223d998 100644
--- a/recipes/clearsilver/clearsilver_0.10.3.bb
+++ b/recipes/clearsilver/clearsilver_0.10.3.bb
@@ -3,16 +3,16 @@ SECTION = "net"
DESCRIPTION = "Clearsilver is a fast, powerful, and language-neutral HTML template system"
LICENSE = "Neotonic ClearSilver License"
DEPENDS = "python"
-PR = "r1"
+PR = "r2"
SRC_URI = "http://www.clearsilver.net/downloads/${P}.tar.gz \
file://crosscompile.patch;patch=1"
EXTRA_OECONF = "--disable-apache --disable-perl --disable-ruby --disable-java --disable-csharp --enable-gettext --with-python=${STAGING_BINDIR_NATIVE}/python"
-inherit autotools
+inherit autotools distutils-common-base
-FILES_${PN} += "/usr/lib/python*"
+export PYTHON_DIR
do_compile() {
BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} oe_runmake
diff --git a/recipes/clearsilver/files/crosscompile.patch b/recipes/clearsilver/files/crosscompile.patch
index 1b73bd5576..a19506d48c 100644
--- a/recipes/clearsilver/files/crosscompile.patch
+++ b/recipes/clearsilver/files/crosscompile.patch
@@ -52,7 +52,7 @@ Index: clearsilver-0.10.3/python/Makefile
TARGETS = $(NEO_UTIL_SO)
endif
-+PYTHON_SITE = /usr/lib/python2.4/site-packages/
++PYTHON_SITE = /usr/lib/${PYTHON_DIR}/site-packages/
+
all: $(TARGETS)