aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/python/python-pycurl_7.19.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/python/python-pycurl_7.19.0.bb b/recipes/python/python-pycurl_7.19.0.bb
new file mode 100644
index 0000000000..36d90d657c
--- /dev/null
+++ b/recipes/python/python-pycurl_7.19.0.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "libcurl Python Bindings"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+DEPENDS = "curl"
+SRCNAME = "pycurl"
+PR = "ml2"
+
+SRC_URI = "\
+ http://${SRCNAME}.sourceforge.net/download/${SRCNAME}-${PV}.tar.gz;name=archive \
+ file://no-static-link.patch;patch=1 \
+"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+SRC_URI[archive.md5sum] = "919d58fe37e69fe87ce4534d8b6a1c7b"
+SRC_URI[archive.sha256sum] = "eb782dfcc5a7c023539a077462b83c167e178128ee9f7201665b9fbb1a8b0642"
+
+inherit distutils
+
+RDEPENDS = "python-core curl"