aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/machine/include/omap3.inc2
-rw-r--r--recipes/linux/linux-omap-psp-2.6.32/0034-modedb.c-add-proper-720p60-mode.patch27
-rw-r--r--recipes/linux/linux-omap-psp_2.6.32.bb1
3 files changed, 29 insertions, 1 deletions
diff --git a/conf/machine/include/omap3.inc b/conf/machine/include/omap3.inc
index ecc15224d0..8db0bee1e7 100644
--- a/conf/machine/include/omap3.inc
+++ b/conf/machine/include/omap3.inc
@@ -3,7 +3,7 @@ SOC_FAMILY = "omap3"
require conf/machine/include/tune-cortexa8.inc
PREFERRED_PROVIDER_virtual/kernel = "linux-omap"
# Increase this everytime you change something in the kernel
-MACHINE_KERNEL_PR = "r63"
+MACHINE_KERNEL_PR = "r64"
KERNEL_IMAGETYPE = "uImage"
diff --git a/recipes/linux/linux-omap-psp-2.6.32/0034-modedb.c-add-proper-720p60-mode.patch b/recipes/linux/linux-omap-psp-2.6.32/0034-modedb.c-add-proper-720p60-mode.patch
new file mode 100644
index 0000000000..80cc5b0dc2
--- /dev/null
+++ b/recipes/linux/linux-omap-psp-2.6.32/0034-modedb.c-add-proper-720p60-mode.patch
@@ -0,0 +1,27 @@
+From e90a865efcda00b35e6a9a3c7efd2942d2c7d3d4 Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Mon, 8 Mar 2010 14:38:31 +0100
+Subject: [PATCH 34/34] modedb.c: add proper 720p60 mode
+
+---
+ drivers/video/modedb.c | 4 ++++
+ 1 files changed, 4 insertions(+), 0 deletions(-)
+
+diff --git a/drivers/video/modedb.c b/drivers/video/modedb.c
+index b32fa2a..f017d57 100644
+--- a/drivers/video/modedb.c
++++ b/drivers/video/modedb.c
+@@ -44,6 +44,10 @@ static const struct fb_videomode modedb[] = {
+ NULL, 60, 640, 480, 39721, 40, 24, 32, 11, 96, 2,
+ 0, FB_VMODE_NONINTERLACED
+ }, {
++ /* 1280x720 @ 60 Hz, 45 kHz hsync, CEA 681-E Format 4 */
++ "hd720", 60, 1280, 720, 13468, 220, 110, 20, 5, 40, 5,
++ 0, FB_VMODE_NONINTERLACED
++ }, {
+ /* 800x600 @ 56 Hz, 35.15 kHz hsync */
+ NULL, 56, 800, 600, 27777, 128, 24, 22, 1, 72, 2,
+ 0, FB_VMODE_NONINTERLACED
+--
+1.6.6.1
+
diff --git a/recipes/linux/linux-omap-psp_2.6.32.bb b/recipes/linux/linux-omap-psp_2.6.32.bb
index 33e372b742..91a36e5760 100644
--- a/recipes/linux/linux-omap-psp_2.6.32.bb
+++ b/recipes/linux/linux-omap-psp_2.6.32.bb
@@ -44,6 +44,7 @@ SRC_URI = "git://arago-project.org/git/people/sriram/ti-psp-omap.git;protocol=gi
file://0031-ARM-VFP-add-support-to-sync-the-VFP-state-of-the-cur.patch;patch=1 \
file://0032-ARM-VFP-preserve-the-HW-context-when-calling-signal-.patch;patch=1 \
file://0033-Switch-SGX-clocks-to-200MHz-on-DM37xx-OMAP36xx.patch;patch=1 \
+ file://0034-modedb.c-add-proper-720p60-mode.patch;patch=1 \
file://defconfig"
SRC_URI_append_beagleboard = " file://logo_linux_clut224.ppm \