aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/distro/include/preferred-om-2008-versions.inc2
-rw-r--r--recipes/gobby/gobby_0.4.1.bb3
-rw-r--r--recipes/gobby/gtksourceview_1.7.2.bb9
-rw-r--r--recipes/gtksourceview/gtksourceview1_1.7.2.bb16
-rw-r--r--recipes/tea/tea_17.3.5.bb4
5 files changed, 21 insertions, 13 deletions
diff --git a/conf/distro/include/preferred-om-2008-versions.inc b/conf/distro/include/preferred-om-2008-versions.inc
index b81f0b17e1..7cc923cc60 100644
--- a/conf/distro/include/preferred-om-2008-versions.inc
+++ b/conf/distro/include/preferred-om-2008-versions.inc
@@ -635,7 +635,7 @@ PREFERRED_VERSION_gtkmm ?= "2.10.10"
PREFERRED_VERSION_gtk-sato-engine ?= "0.1"
PREFERRED_VERSION_gtk-sharp ?= "2.10.2"
PREFERRED_VERSION_gtk-smooth-engine ?= "0.5.8"
-PREFERRED_VERSION_gtksourceview ?= "1.7.2"
+PREFERRED_VERSION_gtksourceview1 ?= "1.7.2"
PREFERRED_VERSION_gtkterm2 ?= "0.2.3"
PREFERRED_VERSION_gtk-xfce-engine ?= "2.4.1"
PREFERRED_VERSION_gtracer ?= "0.0.10"
diff --git a/recipes/gobby/gobby_0.4.1.bb b/recipes/gobby/gobby_0.4.1.bb
index f9474c8fe3..87f0fb9c5e 100644
--- a/recipes/gobby/gobby_0.4.1.bb
+++ b/recipes/gobby/gobby_0.4.1.bb
@@ -1,7 +1,8 @@
LICENSE = "LGPL"
HOMEPAGE = "http://darcs.0x539.de/trac/obby/cgi-bin/trac.cgi/wiki/"
+PR = "r1"
-DEPENDS = "net6 gtkmm obby gtksourceview libxml++"
+DEPENDS = "net6 gtkmm obby gtksourceview1 libxml++"
inherit autotools pkgconfig
SRC_URI = "http://releases.0x539.de/gobby/gobby-${PV}.tar.gz"
diff --git a/recipes/gobby/gtksourceview_1.7.2.bb b/recipes/gobby/gtksourceview_1.7.2.bb
deleted file mode 100644
index 6b4c8e686c..0000000000
--- a/recipes/gobby/gtksourceview_1.7.2.bb
+++ /dev/null
@@ -1,9 +0,0 @@
-LICENSE = "GPL"
-
-DEPENDS = "gtk+ libgnomeprint"
-
-inherit gnome pkgconfig
-
-do_stage() {
-autotools_stage_all
-}
diff --git a/recipes/gtksourceview/gtksourceview1_1.7.2.bb b/recipes/gtksourceview/gtksourceview1_1.7.2.bb
new file mode 100644
index 0000000000..44d88fb80d
--- /dev/null
+++ b/recipes/gtksourceview/gtksourceview1_1.7.2.bb
@@ -0,0 +1,16 @@
+LICENSE = "GPL"
+
+PNAME = "gtksourceview"
+
+DEPENDS = "gtk+ libgnomeprint"
+
+S = "${WORKDIR}/${PNAME}-${PV}"
+
+inherit gnome pkgconfig
+
+# overrule SRC_URI from gnome.conf
+SRC_URI = "${GNOME_MIRROR}/${PNAME}/${@gnome_verdir("${PV}")}/${PNAME}-${PV}.tar.bz2"
+
+do_stage() {
+autotools_stage_all
+}
diff --git a/recipes/tea/tea_17.3.5.bb b/recipes/tea/tea_17.3.5.bb
index c8dac8c94f..6412db0466 100644
--- a/recipes/tea/tea_17.3.5.bb
+++ b/recipes/tea/tea_17.3.5.bb
@@ -1,8 +1,8 @@
DESCRIPTION = "Tea - a GTK based text editor with highlighting and a lot of processing features"
SECTION = "gpe"
LICENSE = "GPL"
-DEPENDS = "gtk+ gtksourceview"
-PR = "r1"
+DEPENDS = "gtk+ gtksourceview1"
+PR = "r2"
inherit autotools