aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/checksums.ini8
-rw-r--r--recipes/gphoto2/gphoto2_2.4.7.bb15
-rw-r--r--recipes/gphoto2/libgphoto2_2.4.7.bb25
3 files changed, 48 insertions, 0 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index 593bea995a..acb7fef1b2 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -10626,6 +10626,10 @@ sha256=c9ef8c2f61bbe9978b38341ca2bf09786416ddd82d4708066a26a0483341ca72
md5=bcc5621e09802e114c7f72a6f6172230
sha256=68cd94664882fdab5fa781b4b8fabe1ac49db7d97bdf3aa917563439afa9b9b6
+[http://downloads.sourceforge.net/gphoto/gphoto2-2.4.7.tar.bz2]
+md5=a0bd7629040735f16e510b63edf386dd
+sha256=16e21ab5387220ad885e1d27f936f3add4081d15a1039577002682be521b2c03
+
[http://downloads.sourceforge.net/lxde/gpicview-0.1.5.tar.gz]
md5=5c484ea089f5a6455265e1e1f472240e
sha256=7663e1849f3b1f2225a3310f907f86068d7ac5c8957d68fc4a684059b49211ca
@@ -15162,6 +15166,10 @@ sha256=f319655b272186ad76ab73317b7e8c5e3b87d51c1265ce676f02e8c312745226
md5=8aff5ac4ca72cba17de633078cf1612e
sha256=2582362ae318b62c31832edfcaf401397fcc98fd307347ee15babff94770784d
+[http://downloads.sourceforge.net/gphoto/libgphoto2-2.4.7.tar.bz2]
+md5=3c1f1b1e56214e83b97e2bc7aadba4c5
+sha256=9e7613f21ac3dd7cf1decbab5c47c1e9a16d39c32062d7f8632adb4fc8d0271f
+
[http://kent.dl.sourceforge.net/sourceforge/gtkpod/libgpod-0.6.0.tar.gz]
md5=b44d8aee3f6610370b6faf61770c5f3c
sha256=a2c8c998588361d8aaa4c662a38f50db164b8b4fce4e7bc49ac445a9ac87f80f
diff --git a/recipes/gphoto2/gphoto2_2.4.7.bb b/recipes/gphoto2/gphoto2_2.4.7.bb
new file mode 100644
index 0000000000..8af31d15dc
--- /dev/null
+++ b/recipes/gphoto2/gphoto2_2.4.7.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "gphoto2 is a command-line utility to fetch pictures from digital cameras"
+SECTION = "console/utils"
+LICENSE = "GPL"
+DEPENDS = "libtool libgphoto2 popt"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/gphoto/gphoto2-${PV}.tar.bz2\
+ file://gphoto-popt-fixup.patch;patch=1"
+
+inherit autotools
+
+do_configure_append() {
+ find ${S} -name Makefile | xargs sed -i 's:/usr/include:${STAGING_INCDIR}:'
+}
+
diff --git a/recipes/gphoto2/libgphoto2_2.4.7.bb b/recipes/gphoto2/libgphoto2_2.4.7.bb
new file mode 100644
index 0000000000..45d42c398c
--- /dev/null
+++ b/recipes/gphoto2/libgphoto2_2.4.7.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "libgphoto2 allows you to access digital cameras"
+SECTION = "libs"
+LICENSE = "GPL"
+DEPENDS = "libtool jpeg virtual/libusb0 libexif"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/gphoto/libgphoto2-${PV}.tar.bz2"
+
+inherit autotools pkgconfig lib_package
+
+OE_LT_RPATH_ALLOW=":${libdir}:"
+OE_LT_RPATH_ALLOW[export]="1"
+
+EXTRA_OECONF = " --with-drivers=all ac_cv_lib_ltdl_lt_dlcaller_register=yes"
+
+PACKAGES =+ "libgphotoport libgphoto2-camlibs"
+FILES_libgphoto2-camlibs = "${libdir}/libgphoto2*/*/*.so*"
+RDEPENDS_${PN} = "libgphoto2-camlibs"
+
+FILES_libgphotoport = "${libdir}/libgphoto2_port.so.*"
+
+FILES_${PN} += "${libdir}/udev/*"
+FILES_${PN}-dbg += "${libdir}/*/*/.debug"
+
+
+