aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/gpe-mixer/gpe-mixer/fix-install.patch11
-rw-r--r--recipes/gpe-mixer/gpe-mixer_0.42.bb3
2 files changed, 13 insertions, 1 deletions
diff --git a/recipes/gpe-mixer/gpe-mixer/fix-install.patch b/recipes/gpe-mixer/gpe-mixer/fix-install.patch
new file mode 100644
index 0000000000..ec5ea2cd0e
--- /dev/null
+++ b/recipes/gpe-mixer/gpe-mixer/fix-install.patch
@@ -0,0 +1,11 @@
+--- Makefile.old 2009-05-09 21:11:12.000000000 +0200
++++ Makefile 2009-05-09 21:11:39.000000000 +0200
+@@ -36,7 +36,7 @@
+
+ install-program: all $(PACKAGE).desktop
+ mkdir -p $(DESTDIR)$(PREFIX)/bin
+- install -s $(PACKAGE) $(DESTDIR)$(PREFIX)/bin/$(PACKAGE)
++ install $(PACKAGE) $(DESTDIR)$(PREFIX)/bin/$(PACKAGE)
+ mkdir -p $(DESTDIR)$(PREFIX)/share/pixmaps
+ install -m 644 $(PACKAGE).png $(DESTDIR)$(PREFIX)/share/pixmaps/$(PACKAGE).png
+ mkdir -p $(DESTDIR)$(PREFIX)/share/$(PACKAGE)
diff --git a/recipes/gpe-mixer/gpe-mixer_0.42.bb b/recipes/gpe-mixer/gpe-mixer_0.42.bb
index 5fe0e98c82..c2f7bbe098 100644
--- a/recipes/gpe-mixer/gpe-mixer_0.42.bb
+++ b/recipes/gpe-mixer/gpe-mixer_0.42.bb
@@ -3,7 +3,8 @@ PR = "r1"
inherit gpe pkgconfig
-SRC_URI += "file://gpemixer-no-host-includes.patch;patch=1"
+SRC_URI += "file://gpemixer-no-host-includes.patch;patch=1 \
+ file://fix-install.patch;patch=1"
DESCRIPTION = "GPE audio mixer"
DEPENDS = "gtk+ libgpewidget"