aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/machine/nokia900.conf6
-rw-r--r--recipes/tasks/task-boot.bb2
2 files changed, 6 insertions, 2 deletions
diff --git a/conf/machine/nokia900.conf b/conf/machine/nokia900.conf
index 2d6fb54989..f7543b672f 100644
--- a/conf/machine/nokia900.conf
+++ b/conf/machine/nokia900.conf
@@ -14,6 +14,8 @@ XSERVER = "xserver-xorg \
xf86-input-keyboard \
xf86-video-omapfb "
+MACHINE_EXTRA_RRECOMMENDS = "watchdog"
+
GUI_MACHINE_CLASS = "bigscreen"
MACHINE_DISPLAY_WIDTH_PIXELS = "800"
MACHINE_DISPLAY_HEIGHT_PIXELS = "480"
@@ -32,7 +34,9 @@ PREFERRED_PROVIDER_virtual/kernel = "linux"
#use this if you are using the nokia initfs
ROOTFS_POSTPROCESS_COMMAND += " remove_init_link; "
-MACHINE_FEATURES = "kernel26 apm alsa bluetooth usbgadget vfat"
+MACHINE_FEATURES = "kernel26 apm alsa bluetooth usbgadget vfat keyboard"
+
+module_autoload_g_ether = "g_ether"
# Copied from include/omap3.inc (as we do not use linux-omap recipes):
#
diff --git a/recipes/tasks/task-boot.bb b/recipes/tasks/task-boot.bb
index d193393875..0eb34a8e0a 100644
--- a/recipes/tasks/task-boot.bb
+++ b/recipes/tasks/task-boot.bb
@@ -1,5 +1,5 @@
DESCRIPTION = "Basic task to get a device booting"
-PR = "r52"
+PR = "r53"
inherit task