aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/libgee/libgee.inc9
-rw-r--r--recipes/libgee/libgee_0.5.2.bb7
-rw-r--r--recipes/libgee/libgee_0.6.0.bb5
3 files changed, 8 insertions, 13 deletions
diff --git a/recipes/libgee/libgee.inc b/recipes/libgee/libgee.inc
index 208e4e9c80..918f45b0a5 100644
--- a/recipes/libgee/libgee.inc
+++ b/recipes/libgee/libgee.inc
@@ -2,10 +2,15 @@ DESCRIPTION = "libgee is a collection library providing GObject-based interfaces
and classes for commonly used data structures."
HOMEPAGE = "http://live.gnome.org/Libgee"
SECTION = "libs"
-DEPENDS = "glib-2.0"
+DEPENDS = "glib-2.0 gobject-introspection"
BBCLASSEXTEND = "native"
-DEPENDS_virtclass-native = "glib-2.0-native"
LICENSE = "LGPL"
PE = "1"
inherit autotools vala
+
+do_configure() {
+ gnu-configize
+ oe_runconf
+}
+
diff --git a/recipes/libgee/libgee_0.5.2.bb b/recipes/libgee/libgee_0.5.2.bb
index 364711d1ab..5c9462085f 100644
--- a/recipes/libgee/libgee_0.5.2.bb
+++ b/recipes/libgee/libgee_0.5.2.bb
@@ -6,10 +6,3 @@ S = "${WORKDIR}/${BPN}-${PV}"
SRC_URI[md5sum] = "fc5a36eb5f61154a1456cbb8b1798e41"
SRC_URI[sha256sum] = "8625ebfb479600046b9e36e1a8fd1142d624645dce66a6cd8c9067d8f7f5ce51"
-
-inherit autotools vala
-
-do_configure() {
- gnu-configize
- oe_runconf
-}
diff --git a/recipes/libgee/libgee_0.6.0.bb b/recipes/libgee/libgee_0.6.0.bb
index e499ed4b45..41bfce133b 100644
--- a/recipes/libgee/libgee_0.6.0.bb
+++ b/recipes/libgee/libgee_0.6.0.bb
@@ -1,12 +1,9 @@
require libgee.inc
-DEPENDS = "gobject-introspection-native"
PE = "1"
-PR = "r2"
+PR = "r3"
SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/libgee/0.6/${BPN}-${PV}.tar.bz2"
S = "${WORKDIR}/${BPN}-${PV}"
SRC_URI[md5sum] = "4eb513b23ab6ea78884989518a4acf6f"
SRC_URI[sha256sum] = "e586678d0a88637abeaaf850b62231000772e79ea6d9c4b45dc3cea99f778a7a"
-
-inherit autotools vala